aboutsummaryrefslogtreecommitdiff
path: root/net/phpldapadmin
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2018-10-21 22:53:57 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2018-10-21 22:53:57 +0000
commite8f2c2835b360ab5fa29085013ffd65b3165a4f0 (patch)
tree294103398144eed90635618472b2fc816c1b32cc /net/phpldapadmin
parent42135de9d2bdf2e865c840c2fb8fdd137b0272c5 (diff)
downloadports-e8f2c2835b360ab5fa29085013ffd65b3165a4f0.tar.gz
ports-e8f2c2835b360ab5fa29085013ffd65b3165a4f0.zip
Update files/patch-lib__functions.php to add php72 compatibility (1)
Hand over maintainership to submitter Flavourize Mark as ignored with php73 Use PLIST_FILES instead of pkg-plist-chunk. Consequently, just substitute in the value of ${WWWDIR_REL} directly, rather than playing around with %%WWWDIR%% sed-tokens. Swap around the ordering a bit to pacify portlint PR: 232482 Submitted by: ports@bsdserwis.com (1)
Notes
Notes: svn path=/head/; revision=482726
Diffstat (limited to 'net/phpldapadmin')
-rw-r--r--net/phpldapadmin/Makefile17
-rw-r--r--net/phpldapadmin/files/patch-lib__functions.php44
-rw-r--r--net/phpldapadmin/pkg-plist-chunk1
3 files changed, 44 insertions, 18 deletions
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
index b3ebc1f4fdd2..6003e82e0560 100644
--- a/net/phpldapadmin/Makefile
+++ b/net/phpldapadmin/Makefile
@@ -3,30 +3,32 @@
PORTNAME= phpldapadmin
PORTVERSION= 1.2.3
-PORTREVISION= 8
+PORTREVISION= 9
PORTEPOCH= 1
CATEGORIES= net www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-php5/${PORTVERSION}
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
-MAINTAINER= matthew@FreeBSD.org
+MAINTAINER= ports@bsdserwis.com
COMMENT= PHP application to administer LDAP over the web
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cpe php:web tar:tgz
-CPE_VENDOR= deon_george
+USES= cpe php:web,flavors tar:tgz
+USE_PHP= gettext ldap openssl pcre session xml iconv hash
+IGNORE_WITH_PHP=73
NO_ARCH= yes
NO_BUILD= yes
-USE_PHP= gettext ldap openssl pcre session xml iconv hash
+CPE_VENDOR= deon_george
GROUPS?= ${WWWGRP}
CFGDIR= config
CFGFILE= config.php
PLIST= ${WRKDIR}/plist
-PLIST_SUB+= PLA_GRP=${GROUPS}
+PLIST_FILES= '@sample(,${GROUPS},640) ${WWWDIR_REL}/config/config.php.example ${WWWDIR_REL}/config/config.php'
SUB_LIST+= PKGNAME=${PKGNAME}
SUB_FILES+= pkg-message
@@ -37,8 +39,7 @@ post-patch:
cd ${WRKSRC} ; \
${FIND} . ! -type d ! -name ${CFGFILE}.example ! -name .cvsignore \
! -name .gitignore ! -name *.orig | ${SORT} | \
- ${SED} -e "s!^\.!%%WWWDIR%%!" >${PLIST} ; \
- ${CAT} ${PKGDIR}/pkg-plist-chunk >>${PLIST}
+ ${SED} -e "s!^\.!${WWWDIR_REL}!" >${PLIST} ; \
do-install:
cd ${WRKSRC} ; \
diff --git a/net/phpldapadmin/files/patch-lib__functions.php b/net/phpldapadmin/files/patch-lib__functions.php
index 2b607e86f827..7680a23812ea 100644
--- a/net/phpldapadmin/files/patch-lib__functions.php
+++ b/net/phpldapadmin/files/patch-lib__functions.php
@@ -1,6 +1,23 @@
--- lib/functions.php.orig 2012-10-01 06:54:14 UTC
+++ lib/functions.php
-@@ -745,6 +745,7 @@ function blowfish_encrypt($data,$secret=
+@@ -51,7 +51,7 @@ if (file_exists(LIBDIR.'functions.custom
+ /**
+ * Loads class definition
+ */
+-function __autoload($className) {
++function pla_autoloader($className) {
+ if (file_exists(HOOKSDIR."classes/$className.php"))
+ require_once(HOOKSDIR."classes/$className.php");
+ elseif (file_exists(LIBDIR."$className.php"))
+@@ -65,6 +65,7 @@ function __autoload($className) {
+ __METHOD__,_('Called to load a class that cant be found'),$className),
+ 'type'=>'error'));
+ }
++spl_autoload_register('pla_autoloader');
+
+ /**
+ * Strips all slashes from the specified array in place (pass by ref).
+@@ -745,6 +746,7 @@ function blowfish_encrypt($data,$secret=
if (! trim($secret))
return $data;
@@ -8,7 +25,7 @@
if (function_exists('mcrypt_module_open') && ! empty($data)) {
$td = mcrypt_module_open(MCRYPT_BLOWFISH,'',MCRYPT_MODE_ECB,'');
$iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td),MCRYPT_DEV_URANDOM);
-@@ -754,6 +755,7 @@ function blowfish_encrypt($data,$secret=
+@@ -754,6 +756,7 @@ function blowfish_encrypt($data,$secret=
return $encrypted_data;
}
@@ -16,7 +33,7 @@
if (file_exists(LIBDIR.'blowfish.php'))
require_once LIBDIR.'blowfish.php';
-@@ -801,6 +803,7 @@ function blowfish_decrypt($encdata,$secr
+@@ -801,6 +804,7 @@ function blowfish_decrypt($encdata,$secr
if (! trim($secret))
return $encdata;
@@ -24,7 +41,7 @@
if (function_exists('mcrypt_module_open') && ! empty($encdata)) {
$td = mcrypt_module_open(MCRYPT_BLOWFISH,'',MCRYPT_MODE_ECB,'');
$iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td),MCRYPT_DEV_URANDOM);
-@@ -810,6 +813,7 @@ function blowfish_decrypt($encdata,$secr
+@@ -810,6 +814,7 @@ function blowfish_decrypt($encdata,$secr
return $decrypted_data;
}
@@ -32,7 +49,16 @@
if (file_exists(LIBDIR.'blowfish.php'))
require_once LIBDIR.'blowfish.php';
-@@ -2127,7 +2131,7 @@ function password_types() {
+@@ -1080,7 +1085,7 @@ function masort(&$data,$sortby,$rev=0) {
+
+ $code .= 'return $c;';
+
+- $CACHE[$sortby] = create_function('$a, $b',$code);
++ $CACHE[$sortby] = function($a, $b) { global $code; return $code; };
+ }
+
+ uasort($data,$CACHE[$sortby]);
+@@ -2127,7 +2132,7 @@ function password_types() {
* crypt, ext_des, md5crypt, blowfish, md5, sha, smd5, ssha, sha512, or clear.
* @return string The hashed password.
*/
@@ -41,7 +67,7 @@
if (DEBUG_ENABLED && (($fargs=func_get_args())||$fargs='NOARGS'))
debug_log('Entered (%%)',1,0,__FILE__,__LINE__,__METHOD__,$fargs);
-@@ -2318,7 +2322,7 @@ function password_check($cryptedpassword
+@@ -2318,7 +2323,7 @@ function password_check($cryptedpassword
# SHA crypted passwords
case 'sha':
@@ -50,7 +76,7 @@
return true;
else
return false;
-@@ -2327,7 +2331,7 @@ function password_check($cryptedpassword
+@@ -2327,7 +2332,7 @@ function password_check($cryptedpassword
# MD5 crypted passwords
case 'md5':
@@ -59,7 +85,7 @@
return true;
else
return false;
-@@ -2392,7 +2396,7 @@ function password_check($cryptedpassword
+@@ -2392,7 +2397,7 @@ function password_check($cryptedpassword
# SHA512 crypted passwords
case 'sha512':
@@ -68,7 +94,7 @@
return true;
else
return false;
-@@ -2564,13 +2568,24 @@ function dn_unescape($dn) {
+@@ -2564,13 +2569,24 @@ function dn_unescape($dn) {
if (is_array($dn)) {
$a = array();
diff --git a/net/phpldapadmin/pkg-plist-chunk b/net/phpldapadmin/pkg-plist-chunk
deleted file mode 100644
index aeffdb4a9c9c..000000000000
--- a/net/phpldapadmin/pkg-plist-chunk
+++ /dev/null
@@ -1 +0,0 @@
-@sample(,%%PLA_GRP%%,640) %%WWWDIR%%/config/config.php.example %%WWWDIR%%/config/config.php