aboutsummaryrefslogtreecommitdiff
path: root/net/pjsip
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:16:16 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:16:16 +0000
commit8d6597e0bb9591c40fc6d0c6e2159fca51178d56 (patch)
treed3548a0f08ca434f11cb4415a93d98037409413b /net/pjsip
parenta9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2 (diff)
downloadports-8d6597e0bb9591c40fc6d0c6e2159fca51178d56.tar.gz
ports-8d6597e0bb9591c40fc6d0c6e2159fca51178d56.zip
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412348
Diffstat (limited to 'net/pjsip')
-rw-r--r--net/pjsip/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/net/pjsip/Makefile b/net/pjsip/Makefile
index 32a1629de193..33ca03ff3742 100644
--- a/net/pjsip/Makefile
+++ b/net/pjsip/Makefile
@@ -11,7 +11,7 @@ COMMENT= Multimedia communication library written in C language
LICENSE= GPLv2
-LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio
+LIB_DEPENDS= libportaudio.so:audio/portaudio
CONFLICTS= pjsip-extsrtp-[0-9]*
@@ -44,39 +44,39 @@ EXTSRTP_DESC= Use libsrtp port (needed to get SRTP support in asterisk13 pjsip b
OPTIONS_SUB= yes
FFMPEG_CONFIGURE_ENABLE= ffmpeg
-FFMPEG_LIB_DEPENDS= libswresample.so:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_LIB_DEPENDS= libswresample.so:multimedia/ffmpeg
G711_CONFIGURE_ENABLE= g711-codec
G722_CONFIGURE_ENABLE= g722-codec
G7221_CONFIGURE_ENABLE= g7221-codec
GSM_CONFIGURE_ENABLE= gsm-codec
-GSM_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
+GSM_LIB_DEPENDS= libgsm.so:audio/gsm
GSM_CONFIGURE_ON= --with-external-gsm
ILBC_CONFIGURE_ENABLE= ilbc-codec
L16_CONFIGURE_ENABLE= l16-codec
OPENH264_CONFIGURE_ENABLE= openh264
-OPENH264_LIB_DEPENDS= libopenh264.so:${PORTSDIR}/multimedia/openh264
+OPENH264_LIB_DEPENDS= libopenh264.so:multimedia/openh264
RESAMPLE_CONFIGURE_ENABLE= resample
RESAMPLEDLL_CONFIGURE_ENABLE= resample-dll
SAMPLERATE_CONFIGURE_ENABLE= libsamplerate
-SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
+SAMPLERATE_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
SDL_CONFIGURE_ENABLE= sdl
SDL_USE= SDL=sdl
SHARED_CONFIGURE_ENABLE= shared
SPEEX_CONFIGURE_ENABLE= speex-codec
SPEEX_CONFIGURE_ON= --with-external-speex
-SPEEX_LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
+SPEEX_LIB_DEPENDS= libspeex.so:audio/speex
SPEEXAEC_CONFIGURE_ENABLE= speex-aec
V4L_CONFIGURE_ENABLE= v4l2
-V4L_BUILD_DEPENDS= v4l_compat>=0:${PORTSDIR}/multimedia/v4l_compat
-V4L_LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
+V4L_BUILD_DEPENDS= v4l_compat>=0:multimedia/v4l_compat
+V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
IPV6_CFLAGS= "-DPJ_HAS_IPV6=1"
SOUND_CONFIGURE_ENABLE= sound
VIDEO_CONFIGURE_ENABLE= video
AMR_CONFIGURE_WITH= opencore-amr
-AMR_LIB_DEPENDS= libopencore-amrwb.so:${PORTSDIR}/audio/opencore-amr \
- libvo-amrwbenc.so:${PORTSDIR}/audio/vo-amrwbenc
+AMR_LIB_DEPENDS= libopencore-amrwb.so:audio/opencore-amr \
+ libvo-amrwbenc.so:audio/vo-amrwbenc
EXTSRTP_CONFIGURE_WITH= external-srtp
-EXTSRTP_LIB_DEPENDS= libsrtp.so:${PORTSDIR}/net/libsrtp
+EXTSRTP_LIB_DEPENDS= libsrtp.so:net/libsrtp
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \