aboutsummaryrefslogtreecommitdiff
path: root/net/pjsip
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-03-18 14:05:57 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-03-18 14:05:57 +0000
commitc607d266f192722d75e4c0150cde98b00c9f2361 (patch)
tree70c743232ec327e82e771fabe83bddd767e70998 /net/pjsip
parent020833350bb62110d7012edcf66784a33a3484af (diff)
downloadports-c607d266f192722d75e4c0150cde98b00c9f2361.tar.gz
ports-c607d266f192722d75e4c0150cde98b00c9f2361.zip
Update pjsip to 2.11
Notes
Notes: svn path=/head/; revision=568742
Diffstat (limited to 'net/pjsip')
-rw-r--r--net/pjsip/Makefile11
-rw-r--r--net/pjsip/distinfo6
-rw-r--r--net/pjsip/files/patch-Makefile11
-rw-r--r--net/pjsip/files/patch-aconfigure6
-rw-r--r--net/pjsip/files/patch-build_rules.mak44
-rw-r--r--net/pjsip/files/patch-pjsip_build_Makefile11
-rw-r--r--net/pjsip/pkg-plist128
7 files changed, 89 insertions, 128 deletions
diff --git a/net/pjsip/Makefile b/net/pjsip/Makefile
index 6ad778e89856..854be800ff54 100644
--- a/net/pjsip/Makefile
+++ b/net/pjsip/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pjsip
-DISTVERSION= 2.10
-PORTREVISION= 1
+DISTVERSION= 2.11
CATEGORIES= net
MAINTAINER= madpilot@FreeBSD.org
@@ -26,9 +25,9 @@ PATHFIX_MAKEFILEIN= Makefile
PLIST_SUB= CONFIGURE_TARGET="${CONFIGURE_TARGET}"
OPTIONS_DEFINE= AMR DEBUG EXTSRTP FFMPEG G711 G722 G7221 GSM ILBC IPV6 \
- L16 OPENH264 OPUS PJSUA RESAMPLE RESAMPLEDLL SAMPLERATE SDL \
- SHARED SOUND SPEEX SPEEXAEC V4L VIDEO VPX WEBRTC
-OPTIONS_DEFAULT=G711 G722 G7221 GSM ILBC L16 OPUS SHARED SPEEX SPEEXAEC \
+ L16 OPENH264 OPUS PJSUA PJSUA2 RESAMPLE RESAMPLEDLL \
+ SAMPLERATE SDL SHARED SOUND SPEEX SPEEXAEC V4L VIDEO VPX WEBRTC
+OPTIONS_DEFAULT=G711 G722 G7221 GSM ILBC L16 OPUS PJSUA2 SHARED SPEEX SPEEXAEC \
VIDEO VPX WEBRTC
EXTSRTP_DESC= Use libsrtp port (needed to get SRTP support in asterisk pjsip backend)
@@ -39,6 +38,7 @@ ILBC_DESC= iLBC codec support
L16_DESC= Linear/L16 codec support
OPENH264_DESC= OpenH264 support
PJSUA_DESC= Command line SIP agent
+PJSUA2_DESC= SIP User agent 2 library
RESAMPLE_DESC= Enable resampling implementations
RESAMPLEDLL_DESC= Build libresample as shared library
SHARED_DESC= Build shared libraries (other ports may depend on this)
@@ -72,6 +72,7 @@ OPENH264_CONFIGURE_ENABLE= openh264
OPENH264_LIB_DEPENDS= libopenh264.so:multimedia/openh264
OPUS_CONFIGURE_ENABLE= opus
OPUS_LIB_DEPENDS= libopus.so:audio/opus
+PJSUA2_CONFIGURE_ENABLE= pjsua2
RESAMPLE_CONFIGURE_ENABLE= resample
RESAMPLEDLL_CONFIGURE_ENABLE= resample-dll
SAMPLERATE_CONFIGURE_ENABLE= libsamplerate
diff --git a/net/pjsip/distinfo b/net/pjsip/distinfo
index d9beba6dd5d1..8f86050a1ebd 100644
--- a/net/pjsip/distinfo
+++ b/net/pjsip/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586797388
-SHA256 (pjsip-pjproject-2.10_GH0.tar.gz) = 936a4c5b98601b52325463a397ddf11ab4106c6a7b04f8dc7cdd377efbb597de
-SIZE (pjsip-pjproject-2.10_GH0.tar.gz) = 8768705
+TIMESTAMP = 1616054727
+SHA256 (pjsip-pjproject-2.11_GH0.tar.gz) = c89b155a38daef6e92c8e1ae5c6895357fe5c5406dfdee2f3717962e21565f1c
+SIZE (pjsip-pjproject-2.11_GH0.tar.gz) = 8968137
diff --git a/net/pjsip/files/patch-Makefile b/net/pjsip/files/patch-Makefile
new file mode 100644
index 000000000000..06c774de3e4d
--- /dev/null
+++ b/net/pjsip/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2021-03-17 07:34:46 UTC
++++ Makefile
+@@ -123,7 +123,7 @@ install:
+ mkdir -p $(DESTDIR)$(libdir)/
+ cp -af $(APP_LIB_FILES) $(DESTDIR)$(libdir)/
+ if [ "$(PJ_EXCLUDE_PJSUA2)x" = "x" ] ; then \
+- cp -af $(PJ_DIR)/pjsip/lib/libpjsua2-$(LIB_SUFFIX) $(DESTDIR)$(libdir)/; \
++ cp -af $(APP_LIBXX_FILES) $(DESTDIR)$(libdir)/; \
+ fi
+ mkdir -p $(DESTDIR)$(includedir)/
+ for d in pjlib pjlib-util pjnath pjmedia pjsip; do \
diff --git a/net/pjsip/files/patch-aconfigure b/net/pjsip/files/patch-aconfigure
index 0acdaa5a2288..11deecbcd04d 100644
--- a/net/pjsip/files/patch-aconfigure
+++ b/net/pjsip/files/patch-aconfigure
@@ -1,6 +1,6 @@
---- aconfigure.orig 2018-07-05 11:16:11 UTC
+--- aconfigure.orig 2021-03-17 07:34:46 UTC
+++ aconfigure
-@@ -7085,7 +7085,7 @@ else
+@@ -7151,7 +7151,7 @@ else
FFMPEG_PREFIX=$with_ffmpeg
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: Using ffmpeg prefix... $FFMPEG_PREFIX" >&5
$as_echo "Using ffmpeg prefix... $FFMPEG_PREFIX" >&6; }
@@ -9,7 +9,7 @@
fi
for ac_prog in pkg-config "python pkgconfig.py"
-@@ -8884,7 +8884,7 @@ $as_echo "Checking if libwebrtc is disabled...no" >&6;
+@@ -9162,7 +9162,7 @@ $as_echo "Checking if libwebrtc is disabled...no" >&6;
ac_webrtc_instset=sse2
ac_webrtc_cflags="-msse2"
;;
diff --git a/net/pjsip/files/patch-build_rules.mak b/net/pjsip/files/patch-build_rules.mak
deleted file mode 100644
index caa251e16df3..000000000000
--- a/net/pjsip/files/patch-build_rules.mak
+++ /dev/null
@@ -1,44 +0,0 @@
---- build/rules.mak.orig 2020-02-14 09:48:27 UTC
-+++ build/rules.mak
-@@ -129,7 +129,7 @@ endif
- $(OBJDIR)/$(app).o: $(OBJDIRS) $(OBJS)
- $(CROSS_COMPILE)ld -r -o $@ $(OBJS)
-
--$(OBJDIR)/$(app).ko: $(OBJDIR)/$(app).o
-+$(OBJDIR)/$(app).ko: $(OBJDIR)/$(app).o | $(OBJDIRS)
- @echo Creating kbuild Makefile...
- @echo "# Our module name:" > $(OBJDIR)/Makefile
- @echo 'obj-m += $(app).o' >> $(OBJDIR)/Makefile
-@@ -154,27 +154,27 @@ $(OBJDIR)/$(app).ko: $(OBJDIR)/$(app).o
- ../lib/$(app).ko: $(LIB) $(OBJDIR)/$(app).ko
- cp $(OBJDIR)/$(app).ko ../lib
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.m
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.m | $(OBJDIRS)
- $(CC) $($(APP)_CFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.c
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.c | $(OBJDIRS)
- $(CC) $($(APP)_CFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.S
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.S | $(OBJDIRS)
- $(CC) $($(APP)_CFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.cpp
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.cpp | $(OBJDIRS)
- $(CXX) $($(APP)_CXXFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.cc
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.cc | $(OBJDIRS)
- $(CXX) $($(APP)_CXXFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
diff --git a/net/pjsip/files/patch-pjsip_build_Makefile b/net/pjsip/files/patch-pjsip_build_Makefile
deleted file mode 100644
index f144c89883a4..000000000000
--- a/net/pjsip/files/patch-pjsip_build_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- pjsip/build/Makefile.orig 2020-02-14 09:48:27 UTC
-+++ pjsip/build/Makefile
-@@ -262,7 +262,7 @@ $(PJSUA_LIB_LIB) $(PJSUA_LIB_SONAME): $(PJSIP_LIB) $(P
-
- pjsua2-lib: $(PJSUA2_LIB_LIB)
- $(PJSUA2_LIB_SONAME): $(PJSUA2_LIB_LIB)
--$(PJSUA2_LIB_LIB) $(PJSUA2_LIB_SONAME): $(PJSUA_LIB) $(PSJUA_LIB_SONAME) $(PJSIP_LIB) $(PJSIP_SONAME) $(PJSIP_SIMPLE_LIB) $(PJSIP_SIMPLE_SONAME) $(PJSIP_UA_LIB) $(PJSIP_UA_SONAME)
-+$(PJSUA2_LIB_LIB) $(PJSUA2_LIB_SONAME): $(PJSUA_LIB_LIB) $(PSJUA_LIB_SONAME) $(PJSIP_LIB) $(PJSIP_SONAME) $(PJSIP_SIMPLE_LIB) $(PJSIP_SIMPLE_SONAME) $(PJSIP_UA_LIB) $(PJSIP_UA_SONAME)
- $(MAKE) -f $(RULES_MAK) APP=PJSUA2_LIB app=pjsua2-lib $(subst /,$(HOST_PSEP),$(LIBDIR)/$@)
-
- pjsip-test: $(TEST_EXE)
diff --git a/net/pjsip/pkg-plist b/net/pjsip/pkg-plist
index a2d1c8bb141d..0200a5304949 100644
--- a/net/pjsip/pkg-plist
+++ b/net/pjsip/pkg-plist
@@ -1,5 +1,18 @@
%%PJSUA%%bin/pjsua
%%PJSUA%%bin/pjsystest
+include/pj++/file.hpp
+include/pj++/hash.hpp
+include/pj++/list.hpp
+include/pj++/lock.hpp
+include/pj++/os.hpp
+include/pj++/pool.hpp
+include/pj++/proactor.hpp
+include/pj++/scanner.hpp
+include/pj++/sock.hpp
+include/pj++/string.hpp
+include/pj++/timer.hpp
+include/pj++/tree.hpp
+include/pj++/types.hpp
include/pj/activesock.h
include/pj/addr_resolv.h
include/pj/array.h
@@ -33,8 +46,8 @@ include/pj/compat/os_palmos.h
include/pj/compat/os_rtems.h
include/pj/compat/os_sunos.h
include/pj/compat/os_symbian.h
-include/pj/compat/os_win32_wince.h
include/pj/compat/os_win32.h
+include/pj/compat/os_win32_wince.h
include/pj/compat/os_winphone8.h
include/pj/compat/os_winuwp.h
include/pj/compat/rand.h
@@ -45,9 +58,10 @@ include/pj/compat/stdarg.h
include/pj/compat/stdfileio.h
include/pj/compat/string.h
include/pj/compat/time.h
-include/pj/config_site_sample.h
-include/pj/config_site.h
include/pj/config.h
+include/pj/config_site.h
+include/pj/config_site_sample.h
+include/pj/config_site_test.h
include/pj/ctype.h
include/pj/doxygen.h
include/pj/errno.h
@@ -60,50 +74,38 @@ include/pj/hash.h
include/pj/ioqueue.h
include/pj/ip_helper.h
include/pj/limits.h
-include/pj/list_i.h
include/pj/list.h
+include/pj/list_i.h
include/pj/lock.h
include/pj/log.h
include/pj/math.h
include/pj/os.h
+include/pj/pool.h
include/pj/pool_alt.h
include/pj/pool_buf.h
include/pj/pool_i.h
-include/pj/pool.h
include/pj/rand.h
include/pj/rbtree.h
+include/pj/sock.h
include/pj/sock_qos.h
include/pj/sock_select.h
-include/pj/sock.h
include/pj/ssl_sock.h
-include/pj/string_i.h
include/pj/string.h
+include/pj/string_i.h
include/pj/timer.h
include/pj/types.h
include/pj/unicode.h
-include/pj++/file.hpp
-include/pj++/hash.hpp
-include/pj++/list.hpp
-include/pj++/lock.hpp
-include/pj++/os.hpp
-include/pj++/pool.hpp
-include/pj++/proactor.hpp
-include/pj++/scanner.hpp
-include/pj++/sock.hpp
-include/pj++/string.hpp
-include/pj++/timer.hpp
-include/pj++/tree.hpp
-include/pj++/types.hpp
+include/pjlib++.hpp
include/pjlib-util.h
include/pjlib-util/base64.h
+include/pjlib-util/cli.h
include/pjlib-util/cli_console.h
include/pjlib-util/cli_imp.h
include/pjlib-util/cli_telnet.h
-include/pjlib-util/cli.h
include/pjlib-util/config.h
include/pjlib-util/crc32.h
-include/pjlib-util/dns_server.h
include/pjlib-util/dns.h
+include/pjlib-util/dns_server.h
include/pjlib-util/errno.h
include/pjlib-util/getopt.h
include/pjlib-util/hmac_md5.h
@@ -113,9 +115,9 @@ include/pjlib-util/json.h
include/pjlib-util/md5.h
include/pjlib-util/pcap.h
include/pjlib-util/resolver.h
+include/pjlib-util/scanner.h
include/pjlib-util/scanner_cis_bitwise.h
include/pjlib-util/scanner_cis_uint.h
-include/pjlib-util/scanner.h
include/pjlib-util/sha1.h
include/pjlib-util/srv_resolver.h
include/pjlib-util/string.h
@@ -123,26 +125,25 @@ include/pjlib-util/stun_simple.h
include/pjlib-util/types.h
include/pjlib-util/xml.h
include/pjlib.h
-include/pjlib++.hpp
-include/pjmedia_audiodev.h
-include/pjmedia_videodev.h
-include/pjmedia-audiodev/audiodev_imp.h
include/pjmedia-audiodev/audiodev.h
+include/pjmedia-audiodev/audiodev_imp.h
include/pjmedia-audiodev/audiotest.h
include/pjmedia-audiodev/config.h
include/pjmedia-audiodev/errno.h
include/pjmedia-codec.h
include/pjmedia-codec/amr_helper.h
include/pjmedia-codec/amr_sdp_match.h
+include/pjmedia-codec/and_aud_mediacodec.h
+include/pjmedia-codec/and_vid_mediacodec.h
include/pjmedia-codec/audio_codecs.h
include/pjmedia-codec/bcg729.h
+include/pjmedia-codec/config.h
include/pjmedia-codec/config_auto.h
include/pjmedia-codec/config_auto.h.in
-include/pjmedia-codec/config.h
include/pjmedia-codec/ffmpeg_vid_codecs.h
include/pjmedia-codec/g722.h
-include/pjmedia-codec/g7221_sdp_match.h
include/pjmedia-codec/g7221.h
+include/pjmedia-codec/g7221_sdp_match.h
include/pjmedia-codec/gsm.h
include/pjmedia-codec/h263_packetizer.h
include/pjmedia-codec/h264_packetizer.h
@@ -157,30 +158,32 @@ include/pjmedia-codec/silk.h
include/pjmedia-codec/speex.h
include/pjmedia-codec/types.h
include/pjmedia-codec/vid_toolbox.h
+%%VPX%%include/pjmedia-codec/vpx.h
+include/pjmedia-codec/vpx_packetizer.h
include/pjmedia-videodev/avi_dev.h
include/pjmedia-videodev/config.h
include/pjmedia-videodev/errno.h
include/pjmedia-videodev/opengl_dev.h
-include/pjmedia-videodev/videodev_imp.h
include/pjmedia-videodev/videodev.h
+include/pjmedia-videodev/videodev_imp.h
include/pjmedia.h
include/pjmedia/alaw_ulaw.h
include/pjmedia/audiodev.h
-include/pjmedia/avi_stream.h
include/pjmedia/avi.h
+include/pjmedia/avi_stream.h
include/pjmedia/bidirectional.h
include/pjmedia/circbuf.h
include/pjmedia/clock.h
include/pjmedia/codec.h
include/pjmedia/conference.h
+include/pjmedia/config.h
include/pjmedia/config_auto.h
include/pjmedia/config_auto.h.in
-include/pjmedia/config.h
include/pjmedia/converter.h
include/pjmedia/delaybuf.h
include/pjmedia/doxygen.h
-include/pjmedia/echo_port.h
include/pjmedia/echo.h
+include/pjmedia/echo_port.h
include/pjmedia/endpoint.h
include/pjmedia/errno.h
include/pjmedia/event.h
@@ -194,32 +197,32 @@ include/pjmedia/null_port.h
include/pjmedia/plc.h
include/pjmedia/port.h
include/pjmedia/resample.h
+include/pjmedia/rtcp.h
include/pjmedia/rtcp_fb.h
include/pjmedia/rtcp_xr.h
-include/pjmedia/rtcp.h
include/pjmedia/rtp.h
-include/pjmedia/sdp_neg.h
include/pjmedia/sdp.h
+include/pjmedia/sdp_neg.h
include/pjmedia/session.h
include/pjmedia/signatures.h
include/pjmedia/silencedet.h
-include/pjmedia/sound_port.h
include/pjmedia/sound.h
+include/pjmedia/sound_port.h
include/pjmedia/splitcomb.h
include/pjmedia/stereo.h
-include/pjmedia/stream_common.h
include/pjmedia/stream.h
+include/pjmedia/stream_common.h
include/pjmedia/symbian_sound_aps.h
include/pjmedia/tonegen.h
+include/pjmedia/transport.h
include/pjmedia/transport_adapter_sample.h
include/pjmedia/transport_ice.h
include/pjmedia/transport_loop.h
include/pjmedia/transport_srtp.h
include/pjmedia/transport_udp.h
-include/pjmedia/transport.h
include/pjmedia/types.h
-include/pjmedia/vid_codec_util.h
include/pjmedia/vid_codec.h
+include/pjmedia/vid_codec_util.h
include/pjmedia/vid_conf.h
include/pjmedia/vid_port.h
include/pjmedia/vid_stream.h
@@ -229,7 +232,8 @@ include/pjmedia/wav_playlist.h
include/pjmedia/wav_port.h
include/pjmedia/wave.h
include/pjmedia/wsola.h
-%%VPX%%include/pjmedia-codec/vpx.h
+include/pjmedia_audiodev.h
+include/pjmedia_videodev.h
include/pjnath.h
include/pjnath/config.h
include/pjnath/errno.h
@@ -245,12 +249,9 @@ include/pjnath/stun_transaction.h
include/pjnath/turn_session.h
include/pjnath/turn_sock.h
include/pjnath/types.h
-include/pjsip_auth.h
-include/pjsip_simple.h
-include/pjsip_ua.h
include/pjsip-simple/errno.h
-include/pjsip-simple/evsub_msg.h
include/pjsip-simple/evsub.h
+include/pjsip-simple/evsub_msg.h
include/pjsip-simple/iscomposing.h
include/pjsip-simple/mwi.h
include/pjsip-simple/pidf.h
@@ -267,10 +268,10 @@ include/pjsip-ua/sip_timer.h
include/pjsip-ua/sip_xfer.h
include/pjsip.h
include/pjsip/print_util.h
+include/pjsip/sip_auth.h
include/pjsip/sip_auth_aka.h
include/pjsip/sip_auth_msg.h
include/pjsip/sip_auth_parser.h
-include/pjsip/sip_auth.h
include/pjsip/sip_autoconf.h
include/pjsip/sip_autoconf.h.in
include/pjsip/sip_config.h
@@ -286,30 +287,33 @@ include/pjsip/sip_private.h
include/pjsip/sip_resolve.h
include/pjsip/sip_tel_uri.h
include/pjsip/sip_transaction.h
+include/pjsip/sip_transport.h
include/pjsip/sip_transport_loop.h
include/pjsip/sip_transport_tcp.h
include/pjsip/sip_transport_tls.h
include/pjsip/sip_transport_udp.h
-include/pjsip/sip_transport.h
include/pjsip/sip_types.h
include/pjsip/sip_ua_layer.h
include/pjsip/sip_uri.h
include/pjsip/sip_util.h
-include/pjsua-lib/pjsua_internal.h
+include/pjsip_auth.h
+include/pjsip_simple.h
+include/pjsip_ua.h
include/pjsua-lib/pjsua.h
+include/pjsua-lib/pjsua_internal.h
include/pjsua.h
-include/pjsua2.hpp
-include/pjsua2/account.hpp
-include/pjsua2/call.hpp
-include/pjsua2/config.hpp
-include/pjsua2/doxygen.hpp
-include/pjsua2/endpoint.hpp
-include/pjsua2/json.hpp
-include/pjsua2/media.hpp
-include/pjsua2/persistent.hpp
-include/pjsua2/presence.hpp
-include/pjsua2/siptypes.hpp
-include/pjsua2/types.hpp
+%%PJSUA2%%include/pjsua2.hpp
+%%PJSUA2%%include/pjsua2/account.hpp
+%%PJSUA2%%include/pjsua2/call.hpp
+%%PJSUA2%%include/pjsua2/config.hpp
+%%PJSUA2%%include/pjsua2/doxygen.hpp
+%%PJSUA2%%include/pjsua2/endpoint.hpp
+%%PJSUA2%%include/pjsua2/json.hpp
+%%PJSUA2%%include/pjsua2/media.hpp
+%%PJSUA2%%include/pjsua2/persistent.hpp
+%%PJSUA2%%include/pjsua2/presence.hpp
+%%PJSUA2%%include/pjsua2/siptypes.hpp
+%%PJSUA2%%include/pjsua2/types.hpp
%%G7221%%lib/libg7221codec-%%CONFIGURE_TARGET%%.a
%%SHARED%%%%G7221%%lib/libg7221codec.so
%%SHARED%%%%G7221%%lib/libg7221codec.so.2
@@ -349,9 +353,9 @@ lib/libpjsip-ua-%%CONFIGURE_TARGET%%.a
lib/libpjsua-%%CONFIGURE_TARGET%%.a
%%SHARED%%lib/libpjsua.so
%%SHARED%%lib/libpjsua.so.2
-lib/libpjsua2-%%CONFIGURE_TARGET%%.a
-%%SHARED%%lib/libpjsua2.so
-%%SHARED%%lib/libpjsua2.so.2
+%%PJSUA2%%lib/libpjsua2-%%CONFIGURE_TARGET%%.a
+%%PJSUA2%%%%SHARED%%lib/libpjsua2.so
+%%PJSUA2%%%%SHARED%%lib/libpjsua2.so.2
%%NO_SAMPLERATE%%%%RESAMPLE%%lib/libresample-%%CONFIGURE_TARGET%%.a
%%NO_SAMPLERATE%%%%RESAMPLE%%%%RESAMPLEDLL%%lib/libresample.so
%%NO_SAMPLERATE%%%%RESAMPLE%%%%RESAMPLEDLL%%lib/libresample.so.2