aboutsummaryrefslogtreecommitdiff
path: root/net/pjsip
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-05-13 14:25:21 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-05-13 14:25:21 +0000
commitec0cd005ec83a546b3b8444a51860704aabeeb67 (patch)
tree9ccfad721e71ab06b879cddb18470de04a8c82bb /net/pjsip
parentef6f077ab441b37ebc21c16a424f5f76efe35c16 (diff)
downloadports-ec0cd005ec83a546b3b8444a51860704aabeeb67.tar.gz
ports-ec0cd005ec83a546b3b8444a51860704aabeeb67.zip
- Update net/pjsip to 2.5 [1]
- Disable unneeded ALSA support in pjsip [1] - Replace custom patch with USES=pathfix - Fix pjsip build system to allow building while previous version is installed in PREFIX/LOCALBASE - Bump dependent port asterisk13 PORTREVISION to avoid runtime crash (seen while testing) PR: 209477 [1] Submitted by: yuri at rawbw.com
Notes
Notes: svn path=/head/; revision=415115
Diffstat (limited to 'net/pjsip')
-rw-r--r--net/pjsip/Makefile9
-rw-r--r--net/pjsip/distinfo4
-rw-r--r--net/pjsip/files/patch-Makefile26
-rw-r--r--net/pjsip/files/patch-aconfigure19
-rw-r--r--net/pjsip/files/patch-pjmedia_build_os-auto.mak.in11
-rw-r--r--net/pjsip/pkg-plist3
6 files changed, 39 insertions, 33 deletions
diff --git a/net/pjsip/Makefile b/net/pjsip/Makefile
index 04ddfdd8fb11..1c4066652473 100644
--- a/net/pjsip/Makefile
+++ b/net/pjsip/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pjsip
-PORTVERSION= 2.4.5
-PORTREVISION= 1
+PORTVERSION= 2.5
CATEGORIES= net
MASTER_SITES= http://www.pjsip.org/release/${PORTVERSION}/
DISTNAME= pjproject-${DISTVERSION}
@@ -19,7 +18,8 @@ CONFLICTS= pjsip-extsrtp-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-external-pa \
--disable-silk
-USES= gmake localbase tar:bz2
+USES= gmake localbase pathfix tar:bz2
+PATHFIX_MAKEFILEIN= Makefile
USE_LDCONFIG= yes
PLIST_SUB= CONFIGURE_TARGET="${CONFIGURE_TARGET}"
MAKE_JOBS_UNSAFE= yes
@@ -86,6 +86,9 @@ EXTSRTP_LIB_DEPENDS= libsrtp.so:net/libsrtp
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/pkgconfig.py
+ @${REINPLACE_CMD} -e 's/$$(APP_LDFLAGS) \{0,1\}//' \
+ -e 's/$$(OS_LDFLAGS)/$$(APP_LDFLAGS) &/' \
+ ${WRKSRC}/*/build/Makefile
@${ECHO} "#include <sys/select.h>" > ${WRKSRC}/pjlib/include/pj/config_site.h
@${ECHO} "#define PJ_IOQUEUE_MAX_HANDLES (FD_SETSIZE)" >> ${WRKSRC}/pjlib/include/pj/config_site.h
diff --git a/net/pjsip/distinfo b/net/pjsip/distinfo
index 51effc705e96..bf029fb167da 100644
--- a/net/pjsip/distinfo
+++ b/net/pjsip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pjproject-2.4.5.tar.bz2) = 086f5e70dcaee312b66ddc24dac6ef85e6f1fec4eed00ff2915cebe0ee3cdd8d
-SIZE (pjproject-2.4.5.tar.bz2) = 4654415
+SHA256 (pjproject-2.5.tar.bz2) = 66e2ee1a81548efba21fa6c234d7fa6260dc98b3cd95af2137b851846d6501de
+SIZE (pjproject-2.5.tar.bz2) = 4179560
diff --git a/net/pjsip/files/patch-Makefile b/net/pjsip/files/patch-Makefile
deleted file mode 100644
index 35a0b70d20af..000000000000
--- a/net/pjsip/files/patch-Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- Makefile.orig 2014-07-14 07:21:58 UTC
-+++ Makefile
-@@ -124,7 +124,7 @@ install:
- for d in pjlib pjlib-util pjnath pjmedia pjsip; do \
- cp -RLf $$d/include/* $(DESTDIR)$(includedir)/; \
- done
-- mkdir -p $(DESTDIR)$(libdir)/pkgconfig
-+ mkdir -p $(DESTDIR)$(prefix)/libdata/pkgconfig
- sed -e "s!@PREFIX@!$(prefix)!" libpjproject.pc.in | \
- sed -e "s!@INCLUDEDIR@!$(includedir)!" | \
- sed -e "s!@LIBDIR@!$(libdir)!" | \
-@@ -132,11 +132,11 @@ install:
- sed -e "s!@PJ_LDLIBS@!!" | \
- sed -e "s!@PJ_LDXXLIBS@!$(PJ_LDXXLIBS)!" | \
- sed -e "s!@PJ_INSTALL_CFLAGS@!!" | \
-- sed -e "s!@PJ_INSTALL_CXXFLAGS@!$(PJ_INSTALL_CXXFLAGS)!" > $(DESTDIR)/$(libdir)/pkgconfig/libpjproject.pc
-+ sed -e "s!@PJ_INSTALL_CXXFLAGS@!$(PJ_INSTALL_CXXFLAGS)!" > $(DESTDIR)/$(prefix)/libdata/pkgconfig/libpjproject.pc
-
- uninstall:
-- $(RM) $(DESTDIR)$(libdir)/pkgconfig/libpjproject.pc
-- -rmdir $(DESTDIR)$(libdir)/pkgconfig 2> /dev/null
-+ $(RM) $(DESTDIR)$(prefix)/libdata/pkgconfig/libpjproject.pc
-+ -rmdir $(DESTDIR)$(prefix)/libdata/pkgconfig 2> /dev/null
- for d in pjlib pjlib-util pjnath pjmedia pjsip; do \
- for f in $$d/include/*; do \
- $(RM) -r "$(DESTDIR)$(includedir)/`basename $$f`"; \
diff --git a/net/pjsip/files/patch-aconfigure b/net/pjsip/files/patch-aconfigure
index 2301a789e330..117f856649cf 100644
--- a/net/pjsip/files/patch-aconfigure
+++ b/net/pjsip/files/patch-aconfigure
@@ -1,6 +1,21 @@
---- aconfigure.orig 2014-08-19 02:18:07 UTC
+--- aconfigure.orig 2016-04-12 07:46:12 UTC
+++ aconfigure
-@@ -6654,7 +6654,7 @@ else
+@@ -6179,14 +6179,7 @@ $as_echo "Checking sound device backend.
+ ;;
+ *)
+ ac_pjmedia_snd=alsa
+- ac_pa_use_alsa=1
+-
+- ac_fn_c_check_header_mongrel "$LINENO" "alsa/version.h" "ac_cv_header_alsa_version_h" "$ac_includes_default"
+-if test "x$ac_cv_header_alsa_version_h" = xyes; then :
+- LIBS="$LIBS -lasound"
+-else
+ ac_pa_use_alsa=0
+-fi
+
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: Checking sound device backend... unix" >&5
+@@ -6773,7 +6766,7 @@ else
FFMPEG_PREFIX=$with_ffmpeg
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: Using ffmpeg prefix... $FFMPEG_PREFIX" >&5
$as_echo "Using ffmpeg prefix... $FFMPEG_PREFIX" >&6; }
diff --git a/net/pjsip/files/patch-pjmedia_build_os-auto.mak.in b/net/pjsip/files/patch-pjmedia_build_os-auto.mak.in
new file mode 100644
index 000000000000..a32cb5088506
--- /dev/null
+++ b/net/pjsip/files/patch-pjmedia_build_os-auto.mak.in
@@ -0,0 +1,11 @@
+--- pjmedia/build/os-auto.mak.in.orig 2016-05-13 06:08:17 UTC
++++ pjmedia/build/os-auto.mak.in
+@@ -209,7 +209,7 @@ endif
+ # Unix specific
+ #
+ ifneq ($(findstring alsa,$(AC_PJMEDIA_SND)),)
+-export CFLAGS += -DPJMEDIA_AUDIO_DEV_HAS_ALSA=1 \
++export CFLAGS += -DPJMEDIA_AUDIO_DEV_HAS_ALSA=0 \
+ -DPJMEDIA_AUDIO_DEV_HAS_PORTAUDIO=0 \
+ -DPJMEDIA_AUDIO_DEV_HAS_WMME=0
+ endif
diff --git a/net/pjsip/pkg-plist b/net/pjsip/pkg-plist
index 975ce2a718b6..791c591b1bb3 100644
--- a/net/pjsip/pkg-plist
+++ b/net/pjsip/pkg-plist
@@ -143,6 +143,7 @@ include/pjmedia-codec/ipp_codecs.h
include/pjmedia-codec/l16.h
include/pjmedia-codec/opencore_amr.h
include/pjmedia-codec/openh264.h
+include/pjmedia-codec/opus.h
include/pjmedia-codec/passthrough.h
include/pjmedia-codec/silk.h
include/pjmedia-codec/speex.h
@@ -155,6 +156,7 @@ include/pjmedia-videodev/videodev.h
include/pjmedia-videodev/videodev_imp.h
include/pjmedia.h
include/pjmedia/alaw_ulaw.h
+include/pjmedia/audiodev.h
include/pjmedia/avi.h
include/pjmedia/avi_stream.h
include/pjmedia/bidirectional.h
@@ -211,6 +213,7 @@ include/pjmedia/vid_codec_util.h
include/pjmedia/vid_port.h
include/pjmedia/vid_stream.h
include/pjmedia/vid_tee.h
+include/pjmedia/videodev.h
include/pjmedia/wav_playlist.h
include/pjmedia/wav_port.h
include/pjmedia/wave.h