aboutsummaryrefslogtreecommitdiff
path: root/net/poptop
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-10-24 09:21:58 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-10-24 09:21:58 +0000
commitea9c48b7a59c0e09ed9df194c6e835e356e3e141 (patch)
tree0d5f949efc59729107f90624d932984b0da73920 /net/poptop
parent6e397bd0840ed703ecef9df67e4f74f632cd6748 (diff)
downloadports-ea9c48b7a59c0e09ed9df194c6e835e356e3e141.tar.gz
ports-ea9c48b7a59c0e09ed9df194c6e835e356e3e141.zip
Notes
Diffstat (limited to 'net/poptop')
-rw-r--r--net/poptop/Makefile22
-rw-r--r--net/poptop/distinfo4
-rw-r--r--net/poptop/files/patch-aa28
-rw-r--r--net/poptop/files/patch-ab386
-rw-r--r--net/poptop/files/patch-ad46
-rw-r--r--net/poptop/files/patch-ae64
-rw-r--r--net/poptop/files/patch-defaults.h11
-rw-r--r--net/poptop/files/patch-pptpctrl.c11
-rw-r--r--net/poptop/files/patch-pptpd.820
-rw-r--r--net/poptop/files/patch-pptpd.conf.511
-rw-r--r--net/poptop/pkg-plist6
11 files changed, 500 insertions, 109 deletions
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index c457d9f46ee4..aedce37f323c 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -6,17 +6,28 @@
#
PORTNAME= poptop
-PORTVERSION= 1.1.4.b4
-PORTREVISION= 3
+PORTVERSION= 1.2.1
+PORTREVISION= 0
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= http://jaist.dl.sourceforge.net/sourceforge/poptop/ \
+ http://easynews.dl.sourceforge.net/sourceforge/poptop/ \
+ http://nchc.dl.sourceforge.net/sourceforge/poptop/ \
+ http://optusnet.dl.sourceforge.net/sourceforge/poptop/ \
+ http://mesh.dl.sourceforge.net/sourceforge/poptop/ \
+ http://switch.dl.sourceforge.net/sourceforge/poptop/ \
+ http://kent.dl.sourceforge.net/sourceforge/poptop/ \
+ http://puzzle.dl.sourceforge.net/sourceforge/poptop/ \
+ http://cogent.dl.sourceforge.net/sourceforge/poptop/ \
+ http://citkit.dl.sourceforge.net/sourceforge/poptop/ \
+ http://belnet.dl.sourceforge.net/sourceforge/poptop/ \
+ ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= pptpd-${PORTVERSION:S/.b/-b/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= olmi@rentech.ru
COMMENT= Windows 9x compatible PPTP (VPN) server
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+WRKSRC= ${WRKDIR}/pptpd-${PORTVERSION}
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
@@ -36,6 +47,7 @@ post-patch:
.for file in bcrelay.c pptpd.c
@${REINPLACE_CMD} -e 's|"out_getopt\.h"|<getopt.h>|g' ${WRKSRC}/${file}
.endfor
+ @${REINPLACE_CMD} -e "s#%%PREFIX%%#${PREFIX}#" ${WRKSRC}/pptpd.8 ${WRKSRC}/pptpd.conf.5
post-install:
${INSTALL_DATA} ${WRKSRC}/samples/pptpd.conf \
diff --git a/net/poptop/distinfo b/net/poptop/distinfo
index 5add2d721294..0fed4ac650f8 100644
--- a/net/poptop/distinfo
+++ b/net/poptop/distinfo
@@ -1,2 +1,2 @@
-MD5 (pptpd-1.1.4-b4.tar.gz) = 58603224998f22542e8d7ecb357bc006
-SIZE (pptpd-1.1.4-b4.tar.gz) = 157684
+MD5 (pptpd-1.2.1.tar.gz) = 067e9474998345485ba1e92cc5ff59c6
+SIZE (pptpd-1.2.1.tar.gz) = 180974
diff --git a/net/poptop/files/patch-aa b/net/poptop/files/patch-aa
index cec44ad6f0c8..2f298eec81e3 100644
--- a/net/poptop/files/patch-aa
+++ b/net/poptop/files/patch-aa
@@ -1,17 +1,11 @@
---- defaults.h.orig Thu Mar 7 19:09:42 2002
-+++ defaults.h Sun Sep 8 10:19:58 2002
-@@ -40,10 +40,14 @@
- #endif
-
- #define PPP_SPEED_DEFAULT "115200"
-+#ifdef __FreeBSD__
-+#define PPTPD_CONFIG_FILE_DEFAULT ETCDIR "/pptpd.conf"
-+#else
- #if EMBED
- #define PPTPD_CONFIG_FILE_DEFAULT "/etc/config/pptpd.conf"
- #else
- #define PPTPD_CONFIG_FILE_DEFAULT "/etc/pptpd.conf"
-+#endif
- #endif
- #define PIDFILE_DEFAULT "/var/run/pptpd.pid"
-
+--- configure.in.orig Wed Jun 23 07:38:43 2004
++++ configure.in Thu Oct 20 22:33:48 2005
+@@ -112,7 +112,7 @@
+ if test "$ac_cv_header_libintl_h" = yes; then
+ if test "$ac_cv_lib_c_gettext" = no; then
+ if test "$ac_cv_lib_intl_gettext" = yes; then
+- XTRALIBS_MGR = "$XTRALIBS_MGR -lintl"
++ XTRALIBS_MGR="$XTRALIBS_MGR -lintl"
+ else
+ echo "Have libintl.h but no usable gettext!" 1>&2
+ exit 1
diff --git a/net/poptop/files/patch-ab b/net/poptop/files/patch-ab
index 61166519a849..74bbf2fcfa66 100644
--- a/net/poptop/files/patch-ab
+++ b/net/poptop/files/patch-ab
@@ -1,35 +1,355 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Fri Feb 28 00:41:21 2003
-+++ Makefile.in Sat Oct 18 21:51:01 2003
-@@ -75,7 +75,7 @@
- AUTOMAKE_OPTIONS = no-dependencies foreign
+--- configure.orig Wed Jun 23 07:39:15 2004
++++ configure Thu Oct 20 22:33:48 2005
+@@ -958,7 +958,7 @@
+ else
+ echo "$as_me: WARNING: no configuration information is in $ac_dir" >&2
+ fi
+- cd "$ac_popdir"
++ cd $ac_popdir
+ done
+ fi
- INCLUDES = -I.
--CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
-+CFLAGS= @CFLAGS@ -DSBINDIR='"$(sbindir)"' -DETCDIR='"$(sysconfdir)"'
- #CFLAGS = -O2 -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"'
- #CFLAGS = -O2 -fno-builtin -Wall -ansi -pedantic -Wmissing-prototypes -Werror -DSBINDIR='"$(sbindir)"'
+@@ -2301,7 +2301,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2359,7 +2360,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2475,7 +2477,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2529,7 +2532,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2574,7 +2578,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2618,7 +2623,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -3107,7 +3113,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -3167,7 +3174,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -3309,7 +3317,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -3625,7 +3634,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -3795,7 +3805,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -3862,7 +3873,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4011,7 +4023,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4160,7 +4173,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4309,7 +4323,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4458,7 +4473,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4606,7 +4622,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4671,7 +4688,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4736,7 +4754,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4801,7 +4820,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4866,7 +4886,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4971,7 +4992,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5024,7 +5046,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5101,7 +5124,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5174,7 +5198,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5247,7 +5272,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5320,7 +5346,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5393,7 +5420,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5466,7 +5494,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5539,7 +5568,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5612,7 +5642,8 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5683,7 +5714,7 @@
+ if test "$ac_cv_header_libintl_h" = yes; then
+ if test "$ac_cv_lib_c_gettext" = no; then
+ if test "$ac_cv_lib_intl_gettext" = yes; then
+- XTRALIBS_MGR = "$XTRALIBS_MGR -lintl"
++ XTRALIBS_MGR="$XTRALIBS_MGR -lintl"
+ else
+ echo "Have libintl.h but no usable gettext!" 1>&2
+ exit 1
+@@ -6712,6 +6743,11 @@
+ *) ac_INSTALL=$ac_top_builddir$INSTALL ;;
+ esac
-@@ -93,8 +93,8 @@
- # for dependencies, so just attribute them all to pptpd.
-
- pptpd_SOURCES = \
-- pptpd.c configfile.c pptpmanager.c compat.c inststr.c getopt.c getopt1.c \
-- compat.h configfile.h ctrlpacket.h defaults.h inststr.h our_getopt.h \
-+ pptpd.c configfile.c pptpmanager.c compat.c inststr.c \
-+ compat.h configfile.h ctrlpacket.h defaults.h inststr.h out_getopt.h \
- our_syslog.h ppphdlc.h pptpctrl.h pptpdefs.h pptpgre.h pptpmanager.h
-
-
-@@ -118,8 +118,7 @@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
- pptpd_OBJECTS = pptpd.$(OBJEXT) configfile.$(OBJEXT) \
--pptpmanager.$(OBJEXT) compat.$(OBJEXT) inststr.$(OBJEXT) \
--getopt.$(OBJEXT) getopt1.$(OBJEXT)
-+pptpmanager.$(OBJEXT) compat.$(OBJEXT) inststr.$(OBJEXT)
- pptpd_DEPENDENCIES =
- pptpd_LDFLAGS =
- pptpctrl_OBJECTS = pptpctrl.$(OBJEXT) ctrlpacket.$(OBJEXT) \
++ if test x"$ac_file" != x-; then
++ { echo "$as_me:$LINENO: creating $ac_file" >&5
++echo "$as_me: creating $ac_file" >&6;}
++ rm -f "$ac_file"
++ fi
+ # Let's still pretend it is `configure' which instantiates (i.e., don't
+ # use $as_me), people would be surprised to read:
+ # /* config.h. Generated by config.status. */
+@@ -6750,12 +6786,6 @@
+ fi;;
+ esac
+ done` || { (exit 1); exit 1; }
+-
+- if test x"$ac_file" != x-; then
+- { echo "$as_me:$LINENO: creating $ac_file" >&5
+-echo "$as_me: creating $ac_file" >&6;}
+- rm -f "$ac_file"
+- fi
+ _ACEOF
+ cat >>$CONFIG_STATUS <<_ACEOF
+ sed "$ac_vpsub
diff --git a/net/poptop/files/patch-ad b/net/poptop/files/patch-ad
index bb267c4d0919..d39d99969a96 100644
--- a/net/poptop/files/patch-ad
+++ b/net/poptop/files/patch-ad
@@ -1,39 +1,11 @@
---- pptpd.c.orig Thu Feb 27 04:01:10 2003
-+++ pptpd.c Sat May 3 18:02:26 2003
-@@ -82,24 +82,23 @@
- static void showusage(char *prog)
- {
- printf("\nPoPToP v%s\n", VERSION);
-- printf("The PPTP Server for Linux\n");
-+ printf("The PPTP Server for FreeBSD\n");
- printf("Usage: pptpd [options], where options are:\n\n");
- #ifdef BCRELAY
- printf(" [-b] [--bcrelay if] Use broadcast relay for broadcasts comming from.\n");
- printf(" the specified interface (default is eth1).\n");
- #endif
- printf(" [-c] [--conf file] Specifies the config file to read default\n");
-- printf(" settings from (default is /etc/pptpd.conf).\n");
-+ printf(" settings from (default is " PPTPD_CONFIG_FILE_DEFAULT ").\n");
- printf(" [-d] [--debug] Turns on debugging (to syslog).\n");
- printf(" [-f] [--fg] Run in foreground.\n");
- printf(" [-h] [--help] Displays this help message.\n");
- printf(" [-l] [--listen x.x.x.x] Specifies IP of local interface to listen to.\n");
- #if !defined(BSDUSER_PPP)
- printf(" [-o] [--option file] Specifies the PPP options file to use\n");
-- printf(" (default is /etc/ppp/options).\n");
- #endif
- printf(" [-p] [--pidfile file] Specifies the file to write the process ID to\n");
-- printf(" (default is /var/run/pptpd.pid).\n");
-+ printf(" (default is "PIDFILE_DEFAULT").\n");
- #if !defined(BSDUSER_PPP)
- printf(" [-s] [--speed baud] Specifies the baud speed for the PPP daemon\n");
- printf(" (default is 115200).\n");
-@@ -111,7 +110,7 @@
- printf("\n\nLogs and debugging go to syslog as DAEMON.");
-
- printf("\n\nCommand line options will override any default settings and any settings\n");
-- printf("specified in the config file (default config file: /etc/pptpd.conf).\n\n");
-+ printf("specified in the config file.\n\n");
- }
+--- Makefile.am.orig Wed Jun 23 09:48:50 2004
++++ Makefile.am Thu Oct 20 22:33:48 2005
+@@ -32,7 +32,7 @@
+ debian/po/templates.pot
+ EXTRA_PROGRAMS =
+-sbin_PROGRAMS = pptpd pptpctrl bcrelay
++sbin_PROGRAMS = pptpd pptpctrl
+ # Header files are only used to determine what to put in a distribution, not
+ # for dependencies, so just attribute them all to pptpd.
diff --git a/net/poptop/files/patch-ae b/net/poptop/files/patch-ae
index 7d77fbbeb523..67c7324707cc 100644
--- a/net/poptop/files/patch-ae
+++ b/net/poptop/files/patch-ae
@@ -1,13 +1,51 @@
---- pptpctrl.c.orig Sat May 3 18:09:16 2003
-+++ pptpctrl.c Sat May 3 18:09:28 2003
-@@ -26,9 +26,9 @@
- #include <time.h>
- #include <sys/time.h>
- #include <dirent.h>
-+#include <sys/socket.h>
- #include <net/if.h>
- #include <sys/types.h>
--#include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #ifdef HAVE_OPENPTY
+--- Makefile.in.orig Wed Jun 23 10:03:07 2004
++++ Makefile.in Thu Oct 20 22:33:48 2005
+@@ -14,7 +14,7 @@
+
+ @SET_MAKE@
+
+-SOURCES = $(bcrelay_SOURCES) $(pptpctrl_SOURCES) $(pptpd_SOURCES)
++SOURCES = $(pptpctrl_SOURCES) $(pptpd_SOURCES)
+
+ srcdir = @srcdir@
+ top_srcdir = @top_srcdir@
+@@ -37,7 +37,7 @@
+ PRE_UNINSTALL = :
+ POST_UNINSTALL = :
+ EXTRA_PROGRAMS =
+-sbin_PROGRAMS = pptpd$(EXEEXT) pptpctrl$(EXEEXT) bcrelay$(EXEEXT)
++sbin_PROGRAMS = pptpd$(EXEEXT) pptpctrl$(EXEEXT)
+ subdir = .
+ DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
+ $(srcdir)/Makefile.in $(srcdir)/config.h.in \
+@@ -55,9 +55,6 @@
+ am__installdirs = "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)"
+ sbinPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(sbin_PROGRAMS)
+-am_bcrelay_OBJECTS = bcrelay.$(OBJEXT)
+-bcrelay_OBJECTS = $(am_bcrelay_OBJECTS)
+-bcrelay_LDADD = $(LDADD)
+ am_pptpctrl_OBJECTS = pptpctrl.$(OBJEXT) ctrlpacket.$(OBJEXT) \
+ inststr.$(OBJEXT) compat.$(OBJEXT) pptpgre.$(OBJEXT) \
+ ppphdlc.$(OBJEXT)
+@@ -76,8 +73,8 @@
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+-SOURCES = $(bcrelay_SOURCES) $(pptpctrl_SOURCES) $(pptpd_SOURCES)
+-DIST_SOURCES = $(bcrelay_SOURCES) $(pptpctrl_SOURCES) $(pptpd_SOURCES)
++SOURCES = $(pptpctrl_SOURCES) $(pptpd_SOURCES)
++DIST_SOURCES = $(pptpctrl_SOURCES) $(pptpd_SOURCES)
+ man5dir = $(mandir)/man5
+ man8dir = $(mandir)/man8
+ NROFF = nroff
+@@ -285,9 +282,6 @@
+
+ clean-sbinPROGRAMS:
+ -test -z "$(sbin_PROGRAMS)" || rm -f $(sbin_PROGRAMS)
+-bcrelay$(EXEEXT): $(bcrelay_OBJECTS) $(bcrelay_DEPENDENCIES)
+- @rm -f bcrelay$(EXEEXT)
+- $(LINK) $(bcrelay_LDFLAGS) $(bcrelay_OBJECTS) $(bcrelay_LDADD) $(LIBS)
+ pptpctrl$(EXEEXT): $(pptpctrl_OBJECTS) $(pptpctrl_DEPENDENCIES)
+ @rm -f pptpctrl$(EXEEXT)
+ $(LINK) $(pptpctrl_LDFLAGS) $(pptpctrl_OBJECTS) $(pptpctrl_LDADD) $(LIBS)
diff --git a/net/poptop/files/patch-defaults.h b/net/poptop/files/patch-defaults.h
new file mode 100644
index 000000000000..a1a0e7aab929
--- /dev/null
+++ b/net/poptop/files/patch-defaults.h
@@ -0,0 +1,11 @@
+--- defaults.h.orig Wed Apr 28 11:36:07 2004
++++ defaults.h Thu Oct 20 22:33:48 2005
+@@ -45,7 +45,7 @@
+ #if EMBED
+ #define PPTPD_CONFIG_FILE_DEFAULT "/etc/config/pptpd.conf"
+ #else
+-#define PPTPD_CONFIG_FILE_DEFAULT "/etc/pptpd.conf"
++#define PPTPD_CONFIG_FILE_DEFAULT "/usr/local/etc/pptpd.conf"
+ #endif
+ #define PIDFILE_DEFAULT "/var/run/pptpd.pid"
+
diff --git a/net/poptop/files/patch-pptpctrl.c b/net/poptop/files/patch-pptpctrl.c
new file mode 100644
index 000000000000..b344db4d88da
--- /dev/null
+++ b/net/poptop/files/patch-pptpctrl.c
@@ -0,0 +1,11 @@
+--- pptpctrl.c.orig Wed Apr 28 11:36:07 2004
++++ pptpctrl.c Thu Oct 20 22:33:48 2005
+@@ -734,7 +734,7 @@
+
+ if (pptp_logwtmp) {
+ pppd_argv[an++] = "plugin";
+- pppd_argv[an++] = "/usr/lib/pptpd/pptpd-logwtmp.so";
++ pppd_argv[an++] = "@@PREFIX@@/lib/pptpd/pptpd-logwtmp.so";
+ pppd_argv[an++] = "pptpd-original-ip";
+ pppd_argv[an++] = inet_ntoa(inetaddrs[1]);
+ }
diff --git a/net/poptop/files/patch-pptpd.8 b/net/poptop/files/patch-pptpd.8
new file mode 100644
index 000000000000..5cb54a362f29
--- /dev/null
+++ b/net/poptop/files/patch-pptpd.8
@@ -0,0 +1,20 @@
+--- pptpd.8.orig Mon May 24 13:39:03 2004
++++ pptpd.8 Mon Oct 24 11:53:31 2005
+@@ -29,7 +29,7 @@
+ specifies the configuration file for
+ .B pptpd
+ (default
+-.IR /etc/pptpd.conf )
++.IR %%PREFIX%%/etc/pptpd.conf )
+
+ .TP
+ .BR -d | --debug
+@@ -99,7 +99,7 @@
+ displays the current version of the pptp daemon.
+
+ .SH FILES
+-/etc/pptpd.conf
++%%PREFIX%%/etc/pptpd.conf
+ .br
+ /var/run/pptpd.pid
+ .SH AUTHORS
diff --git a/net/poptop/files/patch-pptpd.conf.5 b/net/poptop/files/patch-pptpd.conf.5
new file mode 100644
index 000000000000..09e55c7e121e
--- /dev/null
+++ b/net/poptop/files/patch-pptpd.conf.5
@@ -0,0 +1,11 @@
+--- pptpd.conf.5.orig Mon May 24 09:31:24 2004
++++ pptpd.conf.5 Thu Oct 20 22:33:48 2005
+@@ -5,7 +5,7 @@
+ .SH DESCRIPTION
+ .BR pptpd (8)
+ reads options from this file, usually
+-.IR /etc/pptpd.conf .
++.IR %%PREFIX%%/etc/pptpd.conf .
+ Most options can be overridden by the command line. The local and
+ remote IP addresses for clients must come from the configuration file
+ or from
diff --git a/net/poptop/pkg-plist b/net/poptop/pkg-plist
index 276fe4c72f18..05b090a0e2e7 100644
--- a/net/poptop/pkg-plist
+++ b/net/poptop/pkg-plist
@@ -1,4 +1,6 @@
-sbin/pptpd
-sbin/pptpctrl
etc/pptpd.conf.sample
etc/rc.d/pptpd.sh.sample
+lib/pptpd/pptpd-logwtmp.so
+sbin/pptpctrl
+sbin/pptpd
+@dirrm lib/pptpd