aboutsummaryrefslogtreecommitdiff
path: root/net/pptpclient
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /net/pptpclient
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Notes
Notes: svn path=/head/; revision=84842
Diffstat (limited to 'net/pptpclient')
-rw-r--r--net/pptpclient/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index 528089639a09..cd21d9023f68 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pptpclient
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pptpclient
@@ -16,12 +17,15 @@ DISTFILES= pptp-linux-1.1.0-1.tar.gz
MAINTAINER= thomas@cuivre.fr.eu.org
COMMENT= PPTP client for establishing a VPN link with an NT server
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_GETOPT_LONG=yes
-MAKE_ARGS= DEBUG="" \
- INCLUDE="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgnugetopt" \
- all
+.include <bsd.port.pre.mk>
+
+MAKE_ARGS= DEBUG=""
+.if ${OSVERSION} < 500041
+MAKE_ARGS+= INCLUDE="${CPPFLAGS}" \
+ LIBS="${LDFLAGS}"
+.endif
GUNZIP_CMD= ${GZIP_CMD} ${EXTRACT_BEFORE_ARGS}
@@ -39,4 +43,4 @@ do-install:
${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>