aboutsummaryrefslogtreecommitdiff
path: root/net/pptpclient
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-06-13 15:51:27 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-06-13 15:51:27 +0000
commitce16a2aa64255692788b08961674f262c1628914 (patch)
treea19e953b36bf0e1b09b18f4b8b8b263b4644bb31 /net/pptpclient
parent4a477009b607b1d20e5411ddb3846c78d221fe9a (diff)
downloadports-ce16a2aa64255692788b08961674f262c1628914.tar.gz
ports-ce16a2aa64255692788b08961674f262c1628914.zip
Update to 1.1.0.
Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=61222
Diffstat (limited to 'net/pptpclient')
-rw-r--r--net/pptpclient/Makefile15
-rw-r--r--net/pptpclient/distinfo2
-rw-r--r--net/pptpclient/files/patch-aa28
-rw-r--r--net/pptpclient/files/patch-ab70
-rw-r--r--net/pptpclient/files/patch-ad16
5 files changed, 23 insertions, 108 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index cc2b500f1c4f..1a1780cb89a5 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -5,12 +5,13 @@
# $FreeBSD$
#
-PORTNAME= pptpclient
-PORTVERSION= 1.0.3
-CATEGORIES= net
-MASTER_SITES= http://prdownloads.sourceforge.net/pptpclient/
-DISTNAME= pptp-linux-1.0.3
-DISTFILES= pptp-linux-1.0.3-1.tar.gz
+PORTNAME= pptpclient
+PORTVERSION= 1.1.0
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pptpclient
+DISTNAME= pptp-linux-1.1.0
+DISTFILES= pptp-linux-1.1.0-1.tar.gz
MAINTAINER= thomas@cuivre.fr.eu.org
@@ -19,7 +20,7 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
MAKE_ARGS= DEBUG="" \
INCLUDE="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lgnugetopt" \
- pptp
+ all
GUNZIP_CMD= ${GZIP_CMD} ${EXTRACT_BEFORE_ARGS}
diff --git a/net/pptpclient/distinfo b/net/pptpclient/distinfo
index f8dcb7641265..1e7f0904a746 100644
--- a/net/pptpclient/distinfo
+++ b/net/pptpclient/distinfo
@@ -1 +1 @@
-MD5 (pptp-linux-1.0.3-1.tar.gz) = 3feef84198b14bbe99cdbe17576c13e5
+MD5 (pptp-linux-1.1.0-1.tar.gz) = 03e340eb0a9118a8de94eef21560d6c9
diff --git a/net/pptpclient/files/patch-aa b/net/pptpclient/files/patch-aa
index 7aea6b6c64f4..15d16760f727 100644
--- a/net/pptpclient/files/patch-aa
+++ b/net/pptpclient/files/patch-aa
@@ -1,19 +1,19 @@
-diff -ur dist/pptp-linux-1.0.3/Makefile work/pptp-linux-1.0.3/Makefile
---- dist/pptp-linux-1.0.3/Makefile Mon May 7 05:19:34 2001
-+++ Makefile Thu May 10 00:43:58 2001
-@@ -11,12 +11,12 @@
+--- Makefile.orig Mon Mar 11 09:36:52 2002
++++ Makefile Thu Jun 13 15:20:18 2002
+@@ -2,14 +2,14 @@
+
#################################################################
# CHANGE THIS LINE to point to the location of your pppd binary.
-
--CFLAGS += '-DPPPD_BINARY="/usr/sbin/pppd"'
-+CFLAGS += '-DPPPD_BINARY="/usr/sbin/ppp"' -DUSER_PPP
+-PPPD = /usr/sbin/pppd
++PPPD = /usr/sbin/ppp
#################################################################
- PPTP_BIN = pptp
--PPTP_OBJS = pptp.o pptp_gre.o ppp_fcs.o pty.o \
-+PPTP_OBJS = pptp.o pptp_gre.o ppp_fcs.o \
- pptp_ctrl.o dirutil.o vector.o \
- inststr.o util.o version.o
--PPTP_DEPS = pptp_callmgr.h pptp_gre.h ppp_fcs.h pty.h util.h
-+PPTP_DEPS = pptp_callmgr.h pptp_gre.h ppp_fcs.h util.h
+ CC = gcc
+ RM = rm -f
+ DEBUG = -g
+ INCLUDE =
+-CFLAGS = -Wall -O1 $(DEBUG) $(INCLUDE)
++CFLAGS = -Wall -O1 $(DEBUG) $(INCLUDE) -DUSER_PPP
+ LIBS =
+ LDFLAGS = -lutil
diff --git a/net/pptpclient/files/patch-ab b/net/pptpclient/files/patch-ab
deleted file mode 100644
index 06fa6345189f..000000000000
--- a/net/pptpclient/files/patch-ab
+++ /dev/null
@@ -1,70 +0,0 @@
-diff -ur dist/pptp-linux-1.0.3/pptp.c work/pptp-linux-1.0.3/pptp.c
---- dist/pptp-linux-1.0.3/pptp.c Mon Apr 30 05:42:36 2001
-+++ pptp.c Thu May 10 00:43:02 2001
-@@ -7,7 +7,11 @@
-
- #include <sys/types.h>
- #include <sys/socket.h>
-+#ifdef __FreeBSD__
-+#include <libutil.h>
-+#else
- #include <pty.h>
-+#endif
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <sys/un.h>
-@@ -19,14 +23,15 @@
- #include <signal.h>
- #include <setjmp.h>
- #include <errno.h>
-+#include <fcntl.h>
- #include <sys/wait.h>
-+#include <limits.h>
- #include <getopt.h>
- #include "pptp_callmgr.h"
- #include "pptp_gre.h"
- #include "version.h"
- #include "inststr.h"
- #include "util.h"
--#include "pty.h"
-
- #ifndef PPPD_BINARY
- #define PPPD_BINARY "pppd"
-@@ -64,7 +69,7 @@
- int main(int argc, char **argv, char **envp) {
- struct in_addr inetaddr;
- int callmgr_sock;
-- char ttydev[TTYMAX];
-+ char ttydev[PATH_MAX];
- int pty_fd, tty_fd, rc;
- pid_t parent_pid, child_pid;
- u_int16_t call_id, peer_call_id;
-@@ -289,13 +294,23 @@
- void launch_pppd(char *ttydev, int argc, char **argv) {
- char *new_argv[argc+4]; /* XXX if not using GCC, hard code a limit here. */
- int i;
-+ int newi = 0;
-
-- new_argv[0] = PPPD_BINARY;
-- new_argv[1] = ttydev;
-- new_argv[2] = "38400";
-+ new_argv[newi++] = PPPD_BINARY;
-+#ifdef USER_PPP
-+ new_argv[newi++] = "-direct";
-+ if ((i = open(ttydev, O_RDWR)) == -1)
-+ fatal("Cannot open %s: %s", ttydev, strerror(errno));
-+ if (dup2(i, 0) == -1)
-+ fatal("dup2 failed: %s", strerror(errno));
-+ close(i);
-+#else
-+ new_argv[newi++] = ttydev;
-+ new_argv[newi++] = "38400";
-+#endif
- for (i=0; i<argc; i++)
-- new_argv[i+3] = argv[i];
-- new_argv[i+3] = NULL;
-+ new_argv[newi++] = argv[i];
-+ new_argv[newi] = NULL;
- execvp(new_argv[0], new_argv);
- }
-
diff --git a/net/pptpclient/files/patch-ad b/net/pptpclient/files/patch-ad
deleted file mode 100644
index 876fad22a113..000000000000
--- a/net/pptpclient/files/patch-ad
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ur dist/pptp-linux-1.0.3/pptp_gre.c work/pptp-linux-1.0.3/pptp_gre.c
---- dist/pptp-linux-1.0.3/pptp_gre.c Mon Apr 30 05:40:40 2001
-+++ pptp_gre.c Thu May 10 00:43:41 2001
-@@ -5,10 +5,10 @@
- * $Id: pptp_gre.c,v 1.3 2001/04/30 03:40:40 scott Exp $
- */
-
-+#include <sys/types.h>
-+#include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <sys/socket.h>
--#include <sys/types.h>
- #include <sys/stat.h>
- #include <sys/time.h>
- #include <unistd.h>