aboutsummaryrefslogtreecommitdiff
path: root/net/proxychains
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-08-20 13:44:02 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-08-20 13:44:02 +0000
commit187f303b30951e51291bcaa38c7a64fa6e8913c5 (patch)
treea4cb0a17ae6c2c5f4615b79547708fcdd9b954f3 /net/proxychains
parenta0fd1717e8071ab8c2226db0d745cc9c93b1a18c (diff)
downloadports-187f303b30951e51291bcaa38c7a64fa6e8913c5.tar.gz
ports-187f303b30951e51291bcaa38c7a64fa6e8913c5.zip
- This port requires dig during runtime
- Reroll patch to satisfy portlint - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=420511
Diffstat (limited to 'net/proxychains')
-rw-r--r--net/proxychains/Makefile4
-rw-r--r--net/proxychains/files/patch-proxychains-libproxychains.c8
2 files changed, 7 insertions, 5 deletions
diff --git a/net/proxychains/Makefile b/net/proxychains/Makefile
index 7beaa3ed4397..e883a749bdcd 100644
--- a/net/proxychains/Makefile
+++ b/net/proxychains/Makefile
@@ -3,7 +3,7 @@
PORTNAME= proxychains
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/version%20${PORTVERSION}
@@ -13,6 +13,8 @@ COMMENT= Redirect connection through proxy servers
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+RUN_DEPENDS= ${LOCALBASE}/bin/dig:dns/bind-tools
+
GNU_CONFIGURE= yes
USES= gmake libtool
USE_LDCONFIG= yes
diff --git a/net/proxychains/files/patch-proxychains-libproxychains.c b/net/proxychains/files/patch-proxychains-libproxychains.c
index f2492bc1b3c5..d74361bce9ae 100644
--- a/net/proxychains/files/patch-proxychains-libproxychains.c
+++ b/net/proxychains/files/patch-proxychains-libproxychains.c
@@ -1,6 +1,6 @@
---- proxychains/libproxychains.c.orig Wed Mar 15 18:16:59 2006
-+++ proxychains/libproxychains.c Sun Dec 10 01:16:37 2006
-@@ -160,7 +160,7 @@
+--- proxychains/libproxychains.c.orig 2006-03-15 16:16:59 UTC
++++ proxychains/libproxychains.c
+@@ -160,7 +160,7 @@ static inline void get_chain_data(
if(!(file=fopen("./proxychains.conf","r")))
if(!(file=fopen(buff,"r")))
@@ -9,7 +9,7 @@
{
perror("Can't locate proxychains.conf");
exit(1);
-@@ -290,8 +290,8 @@
+@@ -290,8 +290,8 @@ void freeaddrinfo(struct addrinfo *res)
int getnameinfo (const struct sockaddr * sa,
socklen_t salen, char * host,