aboutsummaryrefslogtreecommitdiff
path: root/net/proxychains
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 05:37:58 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 05:37:58 +0000
commit5f87cef0b9c7f52910072390c8f5393fb8318bb1 (patch)
tree2a2b7e504b59e66f13d40a25e7da84176233ccef /net/proxychains
parent3f463d1310ead0cb1bae4eb1cce7197b49c3fee1 (diff)
downloadports-5f87cef0b9c7f52910072390c8f5393fb8318bb1.tar.gz
ports-5f87cef0b9c7f52910072390c8f5393fb8318bb1.zip
New port, proxychains 1.8.2
This program forces any tcp connection made by any given tcp client to follow through proxy (or proxy chain). It is a kind of proxifier. It acts like sockscap / permeo / eborder driver (intercepts TCP calls). PR: ports/53318 Submitted by: Patrick MARIE <mycroft@virgaria.org>
Notes
Notes: svn path=/head/; revision=90746
Diffstat (limited to 'net/proxychains')
-rw-r--r--net/proxychains/Makefile31
-rw-r--r--net/proxychains/distinfo1
-rw-r--r--net/proxychains/files/patch-::config.h.in9
-rw-r--r--net/proxychains/files/patch-::configure22
-rw-r--r--net/proxychains/files/patch-proxychains::libproxychains.c22
-rw-r--r--net/proxychains/pkg-descr7
-rw-r--r--net/proxychains/pkg-plist3
7 files changed, 95 insertions, 0 deletions
diff --git a/net/proxychains/Makefile b/net/proxychains/Makefile
new file mode 100644
index 000000000000..4b87853a8d24
--- /dev/null
+++ b/net/proxychains/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: proxychains
+# Date created: 14 jui 2003
+# Whom: Patrick MARIE <mycroft@virgaria.org>
+# $FreeBSD$
+
+PORTNAME= proxychains
+PORTVERSION= 1.8.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= proxychains
+
+MAINTAINER= mycroft@virgaria.org
+COMMENT= Multi-proxifier
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/proxychains/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/proxychains/proxychains ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/proxychains/proxychains.conf \
+ ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/proxychains/.libs/libproxychains.so.9 \
+ ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/net/proxychains/distinfo b/net/proxychains/distinfo
new file mode 100644
index 000000000000..f319f7c18d41
--- /dev/null
+++ b/net/proxychains/distinfo
@@ -0,0 +1 @@
+MD5 (proxychains-1.8.2.tar.gz) = 276ad24c2680010a96f5e027ea27dcee
diff --git a/net/proxychains/files/patch-::config.h.in b/net/proxychains/files/patch-::config.h.in
new file mode 100644
index 000000000000..bc26541f4017
--- /dev/null
+++ b/net/proxychains/files/patch-::config.h.in
@@ -0,0 +1,9 @@
+--- config.h.in.old Sat Jun 14 15:08:43 2003
++++ config.h.in Sat Jun 14 15:09:24 2003
+@@ -6,3 +6,6 @@
+ /* Version number of package */
+ #undef VERSION
+
++/* PREFIX needed for libproxychains.c */
++#undef PREFIX
++
diff --git a/net/proxychains/files/patch-::configure b/net/proxychains/files/patch-::configure
new file mode 100644
index 000000000000..d97365486d48
--- /dev/null
+++ b/net/proxychains/files/patch-::configure
@@ -0,0 +1,22 @@
+--- configure.old Sat Jun 14 15:08:33 2003
++++ configure Sat Jun 14 15:09:49 2003
+@@ -807,6 +807,8 @@
+
+ VERSION=1.8.2
+
++PREFIX=$prefix
++
+ if test "`cd $srcdir && pwd`" != "`pwd`" && test -f $srcdir/config.status; then
+ { echo "configure: error: source directory already configured; run "make distclean" there first" 1>&2; exit 1; }
+ fi
+@@ -816,6 +818,10 @@
+
+ cat >> confdefs.h <<EOF
+ #define VERSION "$VERSION"
++EOF
++
++cat >> confdefs.h <<EOF
++#define PREFIX "$PREFIX"
+ EOF
+
+
diff --git a/net/proxychains/files/patch-proxychains::libproxychains.c b/net/proxychains/files/patch-proxychains::libproxychains.c
new file mode 100644
index 000000000000..e431672d5615
--- /dev/null
+++ b/net/proxychains/files/patch-proxychains::libproxychains.c
@@ -0,0 +1,22 @@
+--- proxychains/libproxychains.c.orig Wed Jun 4 11:11:03 2003
++++ proxychains/libproxychains.c Sat Jun 14 15:17:55 2003
+@@ -14,6 +14,10 @@
+ * (at your option) any later version. *
+ * *
+ ***************************************************************************/
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
++
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+@@ -72,7 +76,7 @@
+
+ if(!(file=fopen("./proxychains.conf","r")))
+ if(!(file=fopen(buff,"r")))
+- if(!(file=fopen("/etc/proxychains.conf","r")))
++ if(!(file=fopen(PREFIX "/etc/proxychains.conf","r")))
+ {
+ perror("1");
+ exit(1);
diff --git a/net/proxychains/pkg-descr b/net/proxychains/pkg-descr
new file mode 100644
index 000000000000..42e2504413aa
--- /dev/null
+++ b/net/proxychains/pkg-descr
@@ -0,0 +1,7 @@
+ProxyChains
+
+This program forces any tcp connection made by any given tcp client
+to follow through proxy (or proxy chain). It is a kind of proxifier.
+It acts like sockscap / permeo / eborder driver (intercepts TCP calls).
+
+WWW: http://proxylabs.netwu.com/proxychains/index.html
diff --git a/net/proxychains/pkg-plist b/net/proxychains/pkg-plist
new file mode 100644
index 000000000000..c4952d8b61da
--- /dev/null
+++ b/net/proxychains/pkg-plist
@@ -0,0 +1,3 @@
+bin/proxychains
+etc/proxychains.conf
+lib/libproxychains.so.9