aboutsummaryrefslogtreecommitdiff
path: root/net/ptpd2
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2010-11-16 19:28:37 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2010-11-16 19:28:37 +0000
commit855608db9ae31ed2b9dab490300f96d5ce5a2444 (patch)
treed82200ea0b76ce924a2dd51a74c9f328643111d7 /net/ptpd2
parent9adeac8d81d7b2a3b90ae451c33ee4e190e10cbc (diff)
downloadports-855608db9ae31ed2b9dab490300f96d5ce5a2444.tar.gz
ports-855608db9ae31ed2b9dab490300f96d5ce5a2444.zip
ptpd2 implements version 2 of the the Precision Time protocol as defined
by IEEE-1588-2008. PTP was developed to provide very precise time coordination of LAN connected computers. PTPd is a complete implementation of the IEEE 1588-2008 specification for a standard (non-boundary) clock
Notes
Notes: svn path=/head/; revision=264647
Diffstat (limited to 'net/ptpd2')
-rw-r--r--net/ptpd2/Makefile37
-rw-r--r--net/ptpd2/distinfo2
-rw-r--r--net/ptpd2/files/ptpd2.in24
-rw-r--r--net/ptpd2/pkg-descr7
4 files changed, 70 insertions, 0 deletions
diff --git a/net/ptpd2/Makefile b/net/ptpd2/Makefile
new file mode 100644
index 000000000000..605d8fe05146
--- /dev/null
+++ b/net/ptpd2/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ptpd2
+# Date created: 16 November 2010
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptpd
+DISTVERSION= 2.1.0
+CATEGORIES= net
+MASTER_SITES= SF
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Implementation of the precision time protocol IEEE 1588-2008
+
+LICENSE= BSD
+
+WRKSRC= ${WRKDIR}/ptpd-${DISTVERSION}/src
+
+CFLAGS+= -DBSD_INTERFACE_FUNCTIONS
+
+PLIST_FILES= sbin/ptpd2
+PORTDOCS= *
+
+USE_RC_SUBR= ptpd2
+
+MAN8= ptpd2.8
+
+do-install::
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}2 ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}2.8 ${MANPREFIX}/man/man8
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKDIR}/ptpd-${DISTVERSION}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ptpd2/distinfo b/net/ptpd2/distinfo
new file mode 100644
index 000000000000..59f279f1c509
--- /dev/null
+++ b/net/ptpd2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ptpd-2.1.0.tar.gz) = f83ce9457175a41db859da99bdb1257123e1f42e6543022e75a57b962d2be449
+SIZE (ptpd-2.1.0.tar.gz) = 578758
diff --git a/net/ptpd2/files/ptpd2.in b/net/ptpd2/files/ptpd2.in
new file mode 100644
index 000000000000..595ec358a7de
--- /dev/null
+++ b/net/ptpd2/files/ptpd2.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: ptpd2
+# REQUIRE: NETWORKING DAEMON
+# KEYWORD: nojail
+#
+# Add the following lines to /etc/rc.conf to enable ptpd
+#
+# ptpd2_enable (bool): Set to "NO" by default
+# Set it to "YES" to enable ptpd
+
+. /etc/rc.subr
+
+name="ptpd2"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/${name}"
+
+ptpd_enable=${ptpd2_enable:-"NO"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/ptpd2/pkg-descr b/net/ptpd2/pkg-descr
new file mode 100644
index 000000000000..64d839cf2d32
--- /dev/null
+++ b/net/ptpd2/pkg-descr
@@ -0,0 +1,7 @@
+ptpd2 is an implementation of version 2 the Precision Time Protocol
+(IEEE 1588-2008)
+
+PTP was developed to provide very precise time coordination of LAN connected
+computers.
+
+WWW: http://ptpd.sourceforge.net/