aboutsummaryrefslogtreecommitdiff
path: root/net/ptunnel
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-04-28 17:40:33 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-04-28 17:40:33 +0000
commitf83eb9ea5a75c09bf559e9d8977bd3516a7bd270 (patch)
treefae9f63e5c963993dba38a502ef1a672228b0737 /net/ptunnel
parent6a40d7a441686b012deab9a93dfea7656c11c31a (diff)
downloadports-f83eb9ea5a75c09bf559e9d8977bd3516a7bd270.tar.gz
ports-f83eb9ea5a75c09bf559e9d8977bd3516a7bd270.zip
add ptunnel-0.60
Ptunnel is an application that allows you to reliably tunnel TCP connections to a remote host using ICMP echo request and reply packets, commonly known as ping requests and replies. WWW: http://www.cs.uit.no/~daniels/PingTunnel/
Notes
Notes: svn path=/head/; revision=134321
Diffstat (limited to 'net/ptunnel')
-rw-r--r--net/ptunnel/Makefile36
-rw-r--r--net/ptunnel/distinfo2
-rw-r--r--net/ptunnel/pkg-descr5
3 files changed, 43 insertions, 0 deletions
diff --git a/net/ptunnel/Makefile b/net/ptunnel/Makefile
new file mode 100644
index 000000000000..049979181001
--- /dev/null
+++ b/net/ptunnel/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ptunnel
+# Date created: 23 April 2005
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptunnel
+PORTVERSION= 0.60
+CATEGORIES= net
+MASTER_SITES= http://www.cs.uit.no/~daniels/PingTunnel/
+DISTNAME= PingTunnel-${PORTVERSION}
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Tunneling TCP connections over ICMP echo request and reply
+
+WRKSRC= ${WRKDIR}/PingTunnel
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/ptunnel
+MAN8= ptunnel.8
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/' ${WRKSRC}/${MAKEFILE}
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's/stdint.h/inttypes.h/' ${WRKSRC}/ptunnel.h
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ptunnel ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ptunnel.8 ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.post.mk>
diff --git a/net/ptunnel/distinfo b/net/ptunnel/distinfo
new file mode 100644
index 000000000000..93f2ca348541
--- /dev/null
+++ b/net/ptunnel/distinfo
@@ -0,0 +1,2 @@
+MD5 (PingTunnel-0.60.tar.gz) = 2556e51ab975371ed8cad0aa87899aad
+SIZE (PingTunnel-0.60.tar.gz) = 53170
diff --git a/net/ptunnel/pkg-descr b/net/ptunnel/pkg-descr
new file mode 100644
index 000000000000..f3782f94cf66
--- /dev/null
+++ b/net/ptunnel/pkg-descr
@@ -0,0 +1,5 @@
+Ptunnel is an application that allows you to reliably tunnel TCP connections
+to a remote host using ICMP echo request and reply packets, commonly known as
+ping requests and replies.
+
+WWW: http://www.cs.uit.no/~daniels/PingTunnel/