aboutsummaryrefslogtreecommitdiff
path: root/net/pvm
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-12-19 19:13:53 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-12-19 19:13:53 +0000
commit4b59ba05e44d68c5934dc6abf467e158f295e563 (patch)
tree16e25cfb66b6970f3ba9956f7bae1e9e044f6c92 /net/pvm
parentace49a53ef536a7e829c8770e396920c3885f118 (diff)
downloadports-4b59ba05e44d68c5934dc6abf467e158f295e563.tar.gz
ports-4b59ba05e44d68c5934dc6abf467e158f295e563.zip
Define the -DSHAREDTMP option, since this allows one to simulate
clusters of pvm machines with jail(8). Basically, do this: ifconfig lo0 10.0.0.1 netmask 255.255.255.255 alias ifconfig lo0 10.0.0.2 netmask 255.255.255.255 alias ifconfig lo0 10.0.0.3 netmask 255.255.255.255 alias ... echo "10.0.0.1 ten-1" >> /etc/hosts echo "10.0.0.2 ten-2" >> /etc/hosts echo "10.0.0.3 ten-3" >> /etc/hosts ... jail / ten-1 10.0.0.1 /usr/libexec/inetd jail / ten-1 10.0.0.2 /usr/libexec/inetd jail / ten-1 10.0.0.3 /usr/libexec/inetd Tada! now you have three PVM enabled computers on your laptop :-) Submitted by: phk
Notes
Notes: svn path=/head/; revision=51854
Diffstat (limited to 'net/pvm')
-rw-r--r--net/pvm/Makefile1
-rw-r--r--net/pvm/files/patch-FREEBSD.def10
2 files changed, 11 insertions, 0 deletions
diff --git a/net/pvm/Makefile b/net/pvm/Makefile
index fb81e886df70..63265f1f4cc0 100644
--- a/net/pvm/Makefile
+++ b/net/pvm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pvm
PORTVERSION= 3.4.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.netlib.org/pvm3/ \
ftp://ftp.chg.ru/pub/prog/parallel/pvm/pvm3/
diff --git a/net/pvm/files/patch-FREEBSD.def b/net/pvm/files/patch-FREEBSD.def
new file mode 100644
index 000000000000..c140a5c4f2c5
--- /dev/null
+++ b/net/pvm/files/patch-FREEBSD.def
@@ -0,0 +1,10 @@
+--- conf/FREEBSD.def.orig Wed Dec 19 11:09:23 2001
++++ conf/FREEBSD.def Wed Dec 19 11:09:39 2001
+@@ -1,6 +1,6 @@
+ ARCHCFLAGS = -DSOCKADHASLEN -DNOREXEC -DRSHCOMMAND=\"/usr/bin/rsh\" \
+ -DHASSTDLIB -DNEEDMENDIAN -DHASERRORVARS \
+- -DFAKEXDRFLOAT -DSYSERRISCONST
++ -DFAKEXDRFLOAT -DSYSERRISCONST -DSHAREDTMP
+ ARCHDLIB =
+ ARCHDOBJ =
+ ARCHLIB = -lrpcsvc