aboutsummaryrefslogtreecommitdiff
path: root/net/pwhois
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-07 17:49:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-07 17:49:05 +0000
commitb15bd6d9f765184f5901573ebcf598c3fd0165bc (patch)
treec1cc7928b4d0d94445cde798076470c68f2729c9 /net/pwhois
parente5c1e6ef70a98360cbde351f7ce9a6a6e15c15bd (diff)
downloadports-b15bd6d9f765184f5901573ebcf598c3fd0165bc.tar.gz
ports-b15bd6d9f765184f5901573ebcf598c3fd0165bc.zip
Cleanup plist
Allow packaging as a user
Notes
Notes: svn path=/head/; revision=370379
Diffstat (limited to 'net/pwhois')
-rw-r--r--net/pwhois/Makefile10
-rw-r--r--net/pwhois/pkg-plist19
2 files changed, 8 insertions, 21 deletions
diff --git a/net/pwhois/Makefile b/net/pwhois/Makefile
index 31258fc6a9ef..29b18eea9691 100644
--- a/net/pwhois/Makefile
+++ b/net/pwhois/Makefile
@@ -5,26 +5,28 @@ PORTNAME= pwhois
PORTVERSION= 2.2.0.1
CATEGORIES= net
MASTER_SITES= http://pwhois.org/get/ \
- http://mirrors.rit.edu/zi/
+ http://mirrors.rit.edu/zi/
EXTRACT_SUFX= .tgz
MAINTAINER= zi@FreeBSD.org
COMMENT= Whois-compatible framework for disclosing routing data
RUN_DEPENDS= p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
- p5-Time-Format>0:${PORTSDIR}/devel/p5-Time-Format \
+ p5-Time-Format>0:${PORTSDIR}/devel/p5-Time-Format \
p5-Log-Dispatch>0:${PORTSDIR}/devel/p5-Log-Dispatch \
p5-Net-DNS>0:${PORTSDIR}/dns/p5-Net-DNS \
p5-Net-Telnet>0:${PORTSDIR}/net/p5-Net-Telnet \
p5-Net-CIDR>0:${PORTSDIR}/net-mgmt/p5-Net-CIDR \
p5-RPSL-Parser>0:${PORTSDIR}/devel/p5-RPSL-Parser \
- p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
+ p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
FETCH_ARGS= -p
USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
+USES= shebangfix tar:tgz
+SHEBANG_FILES= pwhois-updatedb
USE_MYSQL= client
USE_RC_SUBR= ${PORTNAME}d
SUB_FILES= pkg-message 512.pwhois-updatedb
@@ -55,7 +57,5 @@ do-install:
post-install:
@${MKDIR} ${STAGEDIR}/var/db/pwhois ${STAGEDIR}/var/log/pwhois
- @${CHOWN} 512:512 ${STAGEDIR}/var/db/pwhois ${STAGEDIR}/var/log/pwhois
- #@${CHOWN} ${USERS}:${GROUPS} ${STAGEDIR}/var/db/pwhois ${STAGEDIR}/var/log/pwhois
.include <bsd.port.mk>
diff --git a/net/pwhois/pkg-plist b/net/pwhois/pkg-plist
index 681413d25c9e..d60e051fe880 100644
--- a/net/pwhois/pkg-plist
+++ b/net/pwhois/pkg-plist
@@ -1,20 +1,7 @@
etc/periodic/daily/512.pwhois-updatedb
sbin/pwhois-updatedb
sbin/pwhoisd
-@group pwhois
-@mode 640
-@unexec if cmp -s %D/etc/pwhois/pwhoisd.conf %D/etc/pwhois/pwhoisd.conf.sample ; then rm -f %D/etc/pwhois/pwhoisd.conf ; fi
-%%ETCDIR%%/pwhoisd.conf.sample
-@exec if [ ! -f %D/etc/pwhois/pwhoisd.conf ]; then cp -p %D/%F %B/pwhoisd.conf; fi
-@group wheel
-@mode
+@sample(,pwhois,640) %%ETCDIR%%/pwhoisd.conf.sample
%%DATADIR%%/createdb.sql
-@dirrm %%DATADIR%%
-@dirrmtry %%ETCDIR%%
-@dirrmtry etc/periodic/daily
-@dirrmtry etc/periodic
-@cwd /
-@dirrmtry var/db/pwhois
-@dirrmtry var/log/pwhois
-@unexec if [ -d var/db/pwhois ]; then echo "You should remove /var/db/pwhois if you don't need it any more."; fi
-@unexec if [ -d var/log/pwhois ]; then echo "You should remove /var/log/pwhois if you don't need it any more."; fi
+@dir(pwhois,pwhois,) /var/db/pwhois
+@dir(pwhois,pwhois,) /var/log/pwhois