aboutsummaryrefslogtreecommitdiff
path: root/net/py-coherence
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /net/py-coherence
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'net/py-coherence')
-rw-r--r--net/py-coherence/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net/py-coherence/Makefile b/net/py-coherence/Makefile
index 8f8327f6b618..acb877dc68c4 100644
--- a/net/py-coherence/Makefile
+++ b/net/py-coherence/Makefile
@@ -12,16 +12,16 @@ COMMENT= DLNA/UPnP media server and framework for the digital living
LICENSE= PD
LICENSE_FILE= ${WRKSRC}/LICENCE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configobj>=4.3:devel/py-configobj \
- ${PYTHON_PKGNAMEPREFIX}twisted>8.2:devel/py-twisted \
- ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface \
- ${PYTHON_PKGNAMEPREFIX}Louie>0:devel/py-louie
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configobj>=4.3:devel/py-configobj@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>8.2:devel/py-twisted@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Louie>0:devel/py-louie@${FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= coherence-project
GH_TAGNAME= 4d5ee5f
-USES= python
+USES= python:2.7
USE_PYTHON= distutils autoplist
NO_ARCH= yes