aboutsummaryrefslogtreecommitdiff
path: root/net/py-dugong
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-22 15:31:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-22 15:31:05 +0000
commitb25d2e5e98a8c51983204f485d6ee4154c41865e (patch)
treec0a65a23c230e42fff6910c74032232798bc7e8f /net/py-dugong
parent029af196dbfe5fa908c28b12399ac8dc7077c537 (diff)
downloadports-b25d2e5e98a8c51983204f485d6ee4154c41865e.tar.gz
ports-b25d2e5e98a8c51983204f485d6ee4154c41865e.zip
The Python Dugong module provides an API for communicating with HTTP 1.1
servers. It is an alternative to the standard library's http.client (formerly httplib) module. In contrast to http.client, Dugong: * allows you to send multiple requests right after each other without having to read the responses first. * supports waiting for 100-continue before sending the request body. * raises an exception instead of silently delivering partial data if the connection is closed before all data has been received. * raises one specific exception (ConnectionClosed) if the connection has been closed (while http.client connection may raise any of BrokenPipeError, BadStatusLine, ConnectionAbortedError, ConnectionResetError, IncompleteRead or simply return '' on read) * supports non-blocking, asynchronous operation and is compatible with the asyncio module. * can in most cases distinguish between an unavailable DNS server and an unresolvable hostname. * is not compatible with old HTTP 0.9 or 1.0 servers. All request and response headers are represented as str, but must be encodable in latin1. Request and response body must be bytes-like objects or binary streams. WWW: https://bitbucket.org/nikratio/python-dugong/ PR: 203733 Submitted by: niklaas@kulturflatrate.net Approved by: mat (mentor) Differential Revision: D4639
Notes
Notes: svn path=/head/; revision=404243
Diffstat (limited to 'net/py-dugong')
-rw-r--r--net/py-dugong/Makefile18
-rw-r--r--net/py-dugong/distinfo2
-rw-r--r--net/py-dugong/pkg-descr24
3 files changed, 44 insertions, 0 deletions
diff --git a/net/py-dugong/Makefile b/net/py-dugong/Makefile
new file mode 100644
index 000000000000..e0035d0b6675
--- /dev/null
+++ b/net/py-dugong/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= dugong
+PORTVERSION= 3.5
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= niklaas@kulturflatrate.net
+COMMENT= HTTP 1.1 client module designed for RESTful protocols
+
+LICENSE= PSFL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.3+ tar:bzip2
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-dugong/distinfo b/net/py-dugong/distinfo
new file mode 100644
index 000000000000..a910d66c3c63
--- /dev/null
+++ b/net/py-dugong/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dugong-3.5.tar.bz2) = 44bc81cd25b2e8762458b59f2f2382a3e59869c457edbbcdfe03541e576f1978
+SIZE (dugong-3.5.tar.bz2) = 192228
diff --git a/net/py-dugong/pkg-descr b/net/py-dugong/pkg-descr
new file mode 100644
index 000000000000..1ff6ce86ad60
--- /dev/null
+++ b/net/py-dugong/pkg-descr
@@ -0,0 +1,24 @@
+The Python Dugong module provides an API for communicating with HTTP 1.1
+servers. It is an alternative to the standard library's http.client (formerly
+httplib) module. In contrast to http.client, Dugong:
+
+* allows you to send multiple requests right after each other without having to
+ read the responses first.
+* supports waiting for 100-continue before sending the request body.
+* raises an exception instead of silently delivering partial data if the
+ connection is closed before all data has been received.
+* raises one specific exception (ConnectionClosed) if the connection has been
+ closed (while http.client connection may raise any of BrokenPipeError,
+ BadStatusLine, ConnectionAbortedError, ConnectionResetError, IncompleteRead
+ or simply return '' on read)
+* supports non-blocking, asynchronous operation and is compatible with the
+ asyncio module.
+* can in most cases distinguish between an unavailable DNS server and an
+ unresolvable hostname.
+* is not compatible with old HTTP 0.9 or 1.0 servers.
+
+All request and response headers are represented as str, but must be encodable
+in latin1. Request and response body must be bytes-like objects or binary
+streams.
+
+WWW: https://bitbucket.org/nikratio/python-dugong/