aboutsummaryrefslogtreecommitdiff
path: root/net/py-gntp
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-07-03 09:32:30 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-07-03 09:32:30 +0000
commit799bedc94f99847e2e7986dc56ac07cec86e354c (patch)
treeb8716daaa031c23fda129bec71f8c86e5dcf2679 /net/py-gntp
parent7e7633dbf5b08b51952799905d65ee0b2fe3c3a4 (diff)
downloadports-799bedc94f99847e2e7986dc56ac07cec86e354c.tar.gz
ports-799bedc94f99847e2e7986dc56ac07cec86e354c.zip
net/py-gntp: Update to 1.0.3
* Enable build for all Python versions since the 1.0 release officially supports Python 3.3. The port works also well with later versions of Python 3 up to 3.7. [1] * Make the port concurrent safe as it installs also some scripts and documentation. [1] * Tweak the doc installation to get rid of the pkg-plist and to make full use of the "autoplist" feature. * Remove the superfluous defintion of ${DOCSDIR} that already is set automatically. * Add "python" as an additional category to make searching somewhat easier. * At last but not least: Add an test target to easen QA in the future. Changelog since 0.8: * Allow "file://" scheme to be used for icons * Fix bug with incoming password hash * Added info about license in each source file * Fix bug with binary data (images) being encoded incorrectly * Python 3.3 support * Remove duplicate code from gntp.config * Catch all errors and rethrow them as gntp.errors to make it easier for other programs to deal with errors from the gntp library * Ensure that we open resource files as "rb" and update the documentation PR: 234311 Submitted by: Kes Calhoun <kes-freebsd@h3m3.com> (initial patch) [1] Reviewed by: koobs Approved by: nivit (maintainer timeout)
Notes
Notes: svn path=/head/; revision=505738
Diffstat (limited to 'net/py-gntp')
-rw-r--r--net/py-gntp/Makefile28
-rw-r--r--net/py-gntp/distinfo5
-rw-r--r--net/py-gntp/pkg-plist32
3 files changed, 24 insertions, 41 deletions
diff --git a/net/py-gntp/Makefile b/net/py-gntp/Makefile
index 444dfe6759f6..3ff3dd842cd0 100644
--- a/net/py-gntp/Makefile
+++ b/net/py-gntp/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= gntp
-PORTVERSION= 0.8
+PORTVERSION= 1.0.3
DISTVERSIONPREFIX= v
-PORTREVISION= 6
-CATEGORIES= net
+CATEGORIES= net python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
@@ -13,12 +12,16 @@ COMMENT= Growl Notification Transport Protocol for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:2.7
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
+ gol:deskutils/growl-for-linux
+
+USES= python
USE_GITHUB= yes
GH_ACCOUNT= kfdm
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils autoplist concurrent
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+NO_ARCH= yes
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
@@ -27,6 +30,17 @@ DOCS_VARS= PYDISTUTILS_BUILD_TARGET+=build_sphinx
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/build/sphinx/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/build/sphinx/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
+ "! -name .buildinfo -and ! -name objects.inv"
+
+# Two tests (test_double_resource + test_single_resource) in test_resources.py
+# always fail because desktutils/growl-for-linux isn't (yet) capable to handle
+# messages with embedded icons.
+#
+# To get succesful results from the remaining tests a running instance of "gol"
+# (which needs X and is packaged with deskutils/growl-for-linux) is required.
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} && \
+ ${TOUCH} ${WRKDIR}/.gntp && ${PYTHON_CMD} -m nose -v -e 'test_(single|double)_resource')
.include <bsd.port.mk>
diff --git a/net/py-gntp/distinfo b/net/py-gntp/distinfo
index 77be591bd7c0..460f3c754f1f 100644
--- a/net/py-gntp/distinfo
+++ b/net/py-gntp/distinfo
@@ -1,2 +1,3 @@
-SHA256 (kfdm-gntp-v0.8_GH0.tar.gz) = 1e646e6b486c7367bb342f14230fa391265b134935b72e9e04b9e6bc372bd655
-SIZE (kfdm-gntp-v0.8_GH0.tar.gz) = 38357
+TIMESTAMP = 1558186402
+SHA256 (kfdm-gntp-v1.0.3_GH0.tar.gz) = e9fde29e5ec37dfb77a7659018a7c7f65cb1411054c864eae137ce3d008f794f
+SIZE (kfdm-gntp-v1.0.3_GH0.tar.gz) = 39511
diff --git a/net/py-gntp/pkg-plist b/net/py-gntp/pkg-plist
deleted file mode 100644
index b5c2333362c9..000000000000
--- a/net/py-gntp/pkg-plist
+++ /dev/null
@@ -1,32 +0,0 @@
-%%PORTDOCS%%%%DOCSDIR%%/.buildinfo
-%%PORTDOCS%%%%DOCSDIR%%/_sources/core.rst.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/index.rst.txt
-%%PORTDOCS%%%%DOCSDIR%%/_static/ajax-loader.gif
-%%PORTDOCS%%%%DOCSDIR%%/_static/basic.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/classic.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment-bright.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment-close.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/default.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/doctools.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/down-pressed.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/down.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/file.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/jquery-3.1.0.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/jquery.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/minus.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/plus.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/pygments.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/searchtools.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/sidebar.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/underscore-1.3.1.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/underscore.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/up.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
-%%PORTDOCS%%%%DOCSDIR%%/core.html
-%%PORTDOCS%%%%DOCSDIR%%/genindex.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/objects.inv
-%%PORTDOCS%%%%DOCSDIR%%/search.html
-%%PORTDOCS%%%%DOCSDIR%%/searchindex.js