aboutsummaryrefslogtreecommitdiff
path: root/net/py-kafka-python
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-15 17:26:50 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-15 17:26:50 +0000
commit9ba099c0e0fde1c36f0b6905d20d96fcf0132ad9 (patch)
tree44e54fb4541af415b02be409f59588a5a436d138 /net/py-kafka-python
parent62cf405131dc4546d18e1dde1e649d24e65dd194 (diff)
downloadports-9ba099c0e0fde1c36f0b6905d20d96fcf0132ad9.tar.gz
ports-9ba099c0e0fde1c36f0b6905d20d96fcf0132ad9.zip
This module provides low-level protocol support for Apache Kafka as well as
high-level consumer and producer classes. Request batching is supported by the protocol as well as broker-aware request routing. Gzip and Snappy compression is also supported for message sets. WWW: https://github.com/mumrah/kafka-python PR: 202000 Submitted by: Christer Edwards <christer.edwards@gmail.com>
Notes
Notes: svn path=/head/; revision=411196
Diffstat (limited to 'net/py-kafka-python')
-rw-r--r--net/py-kafka-python/Makefile20
-rw-r--r--net/py-kafka-python/distinfo2
-rw-r--r--net/py-kafka-python/pkg-descr6
3 files changed, 28 insertions, 0 deletions
diff --git a/net/py-kafka-python/Makefile b/net/py-kafka-python/Makefile
new file mode 100644
index 000000000000..daebba05d4ce
--- /dev/null
+++ b/net/py-kafka-python/Makefile
@@ -0,0 +1,20 @@
+# Created by: Christer Edwards <christer.edwards@gmail.com>
+# $FreeBSD$
+
+PORTNAME= kafka-python
+PORTVERSION= 0.9.4
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= christer.edwards@gmail.com
+COMMENT= Pure Python client for Apache Kafka
+
+LICENSE= APACHE20
+
+USE_PYTHON= autoplist distutils
+USES= python shebangfix
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:${PORTSDIR}/devel/py-six
+
+.include <bsd.port.mk>
diff --git a/net/py-kafka-python/distinfo b/net/py-kafka-python/distinfo
new file mode 100644
index 000000000000..80c9a0a77a68
--- /dev/null
+++ b/net/py-kafka-python/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kafka-python-0.9.4.tar.gz) = 6cd463b688d98fec1c1f602e316eb7745aef0e55dc57fe9ff2f203cf0865c8c7
+SIZE (kafka-python-0.9.4.tar.gz) = 63119
diff --git a/net/py-kafka-python/pkg-descr b/net/py-kafka-python/pkg-descr
new file mode 100644
index 000000000000..2f9da4a8b773
--- /dev/null
+++ b/net/py-kafka-python/pkg-descr
@@ -0,0 +1,6 @@
+This module provides low-level protocol support for Apache Kafka as well as
+high-level consumer and producer classes. Request batching is supported by the
+protocol as well as broker-aware request routing. Gzip and Snappy compression
+is also supported for message sets.
+
+WWW: https://github.com/mumrah/kafka-python