aboutsummaryrefslogtreecommitdiff
path: root/net/py-ldap0
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2018-05-03 13:26:25 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2018-05-03 13:26:25 +0000
commit76c3268173cd9cce70cd75f696920cab2fabdc48 (patch)
tree57f9f6065c134caae70aee54bde0a2d5b418a186 /net/py-ldap0
parent9fb6b9e60377329179954da0a9d790d982b9fa38 (diff)
downloadports-76c3268173cd9cce70cd75f696920cab2fabdc48.tar.gz
ports-76c3268173cd9cce70cd75f696920cab2fabdc48.zip
Update web2ldap to verstion 1.3.16
Also welcome py-ldap0 to the ports tree as a dependency. This version adds a rc script to start the standalone mode. Taking maintainership as bsam@ offered to step down. Releasenotes: https://web2ldap.de/changes-1.3.html#r1.3.16 PR: 227459
Notes
Notes: svn path=/head/; revision=468926
Diffstat (limited to 'net/py-ldap0')
-rw-r--r--net/py-ldap0/Makefile21
-rw-r--r--net/py-ldap0/distinfo3
-rw-r--r--net/py-ldap0/files/patch-setup.py11
-rw-r--r--net/py-ldap0/pkg-descr6
4 files changed, 41 insertions, 0 deletions
diff --git a/net/py-ldap0/Makefile b/net/py-ldap0/Makefile
new file mode 100644
index 000000000000..3cf47dfffebf
--- /dev/null
+++ b/net/py-ldap0/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= ldap0
+PORTVERSION= 0.0.60
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= girgen@FreeBSD.org
+COMMENT= Python module package for implementing LDAP clients
+
+LICENSE= PSFL
+
+MAKE_ENV+= INCLUDES=${LOCALBASE}/include
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0.2.1:devel/py-pyasn1-modules@${PY_FLAVOR}
+
+USES= python
+USE_OPENLDAP= yes
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-ldap0/distinfo b/net/py-ldap0/distinfo
new file mode 100644
index 000000000000..8d591b2c9e3e
--- /dev/null
+++ b/net/py-ldap0/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1525015315
+SHA256 (ldap0-0.0.60.tar.gz) = a6f02941dda63249e8c7c68947d0c7fb47efaa59ca085396a3ddedadb90a65fe
+SIZE (ldap0-0.0.60.tar.gz) = 219348
diff --git a/net/py-ldap0/files/patch-setup.py b/net/py-ldap0/files/patch-setup.py
new file mode 100644
index 000000000000..6f31242362c8
--- /dev/null
+++ b/net/py-ldap0/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2018-02-06 13:04:47 UTC
++++ setup.py
+@@ -22,7 +22,7 @@ class OpenLDAP2BuildConfig:
+
+ def __init__(self, meta_defines):
+ self.library_dirs = []
+- self.include_dirs = []
++ self.include_dirs = [os.environ['INCLUDES']]
+ self.extra_compile_args = []
+ self.extra_link_args = []
+ self.extra_objects = []
diff --git a/net/py-ldap0/pkg-descr b/net/py-ldap0/pkg-descr
new file mode 100644
index 000000000000..170cb112d72b
--- /dev/null
+++ b/net/py-ldap0/pkg-descr
@@ -0,0 +1,6 @@
+ldap3 is a pure Python LDAP 3 client library strictly conforming to RFC4511
+released under the LGPL v3 open source license. RFC4511 is the current LDAP
+specification (June 2006) from IETF and obsoletes the previous LDAP RFCs
+2251, 2830, 3771 (December 1997)
+
+WWW: https://github.com/cannatag/ldap3