aboutsummaryrefslogtreecommitdiff
path: root/net/py-mpi4py
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-10-15 13:34:33 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-10-15 13:34:33 +0000
commitde105b8841532a74cd0f9ed91655593b814487ac (patch)
treef7e62c455853b6861b3b0903ed69eb2915546728 /net/py-mpi4py
parent93c4582fed7cf1723a44db4907cd3d1f6e43cead (diff)
downloadports-de105b8841532a74cd0f9ed91655593b814487ac.tar.gz
ports-de105b8841532a74cd0f9ed91655593b814487ac.zip
net/py-mpi4py: Move OpenMPI dependecy from net/openmpi3 to net/openmpi (OpenMPI 4)
Reported by: linimon
Notes
Notes: svn path=/head/; revision=552414
Diffstat (limited to 'net/py-mpi4py')
-rw-r--r--net/py-mpi4py/Makefile3
-rw-r--r--net/py-mpi4py/files/mpi.cfg2
-rw-r--r--net/py-mpi4py/files/mpi2.cfg6
3 files changed, 3 insertions, 8 deletions
diff --git a/net/py-mpi4py/Makefile b/net/py-mpi4py/Makefile
index 1e05f7730dab..ab88caeaa825 100644
--- a/net/py-mpi4py/Makefile
+++ b/net/py-mpi4py/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mpi4py
DISTVERSION= 3.0.3
+PORTREVISION= 1
CATEGORIES= net parallel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -25,7 +26,7 @@ MPICH2_USES= fortran
MPICH2_LIB_DEPENDS= libmpich.so:net/mpich2
MPICH2_LDFLAGS= ${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libgcc_s.so
-OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi3
+OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi
PORTDOCS= *
diff --git a/net/py-mpi4py/files/mpi.cfg b/net/py-mpi4py/files/mpi.cfg
index 35b3d00e56e6..2057be4b343f 100644
--- a/net/py-mpi4py/files/mpi.cfg
+++ b/net/py-mpi4py/files/mpi.cfg
@@ -1,5 +1,5 @@
[mpi]
-mpi_dir = %%LOCALBASE%%/mpi/openmpi3
+mpi_dir = %%LOCALBASE%%/mpi/openmpi
mpicc = %(mpi_dir)s/bin/mpicc
mpicxx = %(mpi_dir)s/bin/mpicxx
library_dirs = %(mpi_dir)s/lib
diff --git a/net/py-mpi4py/files/mpi2.cfg b/net/py-mpi4py/files/mpi2.cfg
deleted file mode 100644
index 3ce4d9df0afd..000000000000
--- a/net/py-mpi4py/files/mpi2.cfg
+++ /dev/null
@@ -1,6 +0,0 @@
-[mpi]
-mpi_dir = %%LOCALBASE%%/mpi/openmpi2
-mpicc = %(mpi_dir)s/bin/mpicc
-mpicxx = %(mpi_dir)s/bin/mpicxx
-library_dirs = %(mpi_dir)s/lib
-runtime_library_dirs = %(library_dirs)s