aboutsummaryrefslogtreecommitdiff
path: root/net/py-ndg-httpsclient
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-05 13:50:46 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-05 13:50:46 +0000
commitfa656fbeef57ce5bd75ee098757166eab2f5b462 (patch)
treedf0daa8ddfb337fd17f941fd116f811cb47b69b5 /net/py-ndg-httpsclient
parent904f1e9503d96374467843779e92dbc8b19ed708 (diff)
downloadports-fa656fbeef57ce5bd75ee098757166eab2f5b462.tar.gz
ports-fa656fbeef57ce5bd75ee098757166eab2f5b462.zip
Move net/py-ndg_httpsclient to net/py-ndg-httpsclient
Notes
Notes: svn path=/head/; revision=557060
Diffstat (limited to 'net/py-ndg-httpsclient')
-rw-r--r--net/py-ndg-httpsclient/Makefile26
-rw-r--r--net/py-ndg-httpsclient/distinfo3
-rw-r--r--net/py-ndg-httpsclient/pkg-descr5
3 files changed, 34 insertions, 0 deletions
diff --git a/net/py-ndg-httpsclient/Makefile b/net/py-ndg-httpsclient/Makefile
new file mode 100644
index 000000000000..cc6b4451639d
--- /dev/null
+++ b/net/py-ndg-httpsclient/Makefile
@@ -0,0 +1,26 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= ndg-httpsclient
+PORTVERSION= 0.5.1
+PORTREVISION= 1
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ndg_httpsclient-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Enhance HTTPS support for httplib and urllib2
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/ndg/httpsclient/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.4:devel/py-pyasn1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.13:security/py-openssl@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-ndg-httpsclient/distinfo b/net/py-ndg-httpsclient/distinfo
new file mode 100644
index 000000000000..76fcf33bbd3c
--- /dev/null
+++ b/net/py-ndg-httpsclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532810640
+SHA256 (ndg_httpsclient-0.5.1.tar.gz) = d72faed0376ab039736c2ba12e30695e2788c4aa569c9c3e3d72131de2592210
+SIZE (ndg_httpsclient-0.5.1.tar.gz) = 26665
diff --git a/net/py-ndg-httpsclient/pkg-descr b/net/py-ndg-httpsclient/pkg-descr
new file mode 100644
index 000000000000..e8c18dcdf9e0
--- /dev/null
+++ b/net/py-ndg-httpsclient/pkg-descr
@@ -0,0 +1,5 @@
+This is a HTTPS client implementation for httplib and urllib2 based on
+PyOpenSSL.
+
+WWW: https://pypi.org/project/ndg-httpsclient/
+WWW: https://github.com/cedadev/ndg_httpsclient