aboutsummaryrefslogtreecommitdiff
path: root/net/py-pcapy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-15 23:26:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-15 23:26:32 +0000
commitd061b81815ea4204fc6c68b0ccae34e704291c55 (patch)
tree218a8e110acdb8a2e0202075da02ac926704dc43 /net/py-pcapy
parent924d490ce12044af96af457cc0a9357f39d6d82c (diff)
downloadports-d061b81815ea4204fc6c68b0ccae34e704291c55.tar.gz
ports-d061b81815ea4204fc6c68b0ccae34e704291c55.zip
Pcapy is a Python extension module that interfaces with
the libpcap packet capture library. Pcapy enables Python scripts to capture packets on the network. Pcapy is highly effective when used in conjunction with a packet-handling package such as Impacket, which is a collection of Python classes for constructing and dissecting network packets. PR: ports/86184 Submitted by: Marcin Jessa <yazzy@yazzy.org>
Notes
Notes: svn path=/head/; revision=142859
Diffstat (limited to 'net/py-pcapy')
-rw-r--r--net/py-pcapy/Makefile22
-rw-r--r--net/py-pcapy/distinfo2
-rw-r--r--net/py-pcapy/pkg-descr13
3 files changed, 37 insertions, 0 deletions
diff --git a/net/py-pcapy/Makefile b/net/py-pcapy/Makefile
new file mode 100644
index 000000000000..ec1aadab4b6f
--- /dev/null
+++ b/net/py-pcapy/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: pcapy
+# Date created: 15th September 2005
+# Whom: Marcin Jessa <yazzy@yazzy.org>
+# $FreeBSD$
+
+PORTNAME= pcapy
+PORTVERSION= 0.10.3
+CATEGORIES= net python
+MASTER_SITES= http://oss.coresecurity.com/repo/ \
+ http://www.yazzy.org/ports/pcapy/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yazzy@yazzy.org
+COMMENT= Python extension module to capture packets on the network
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/pcapy.so
+PORTDOCS= README LICENSE pcapy.html
+
+.include <bsd.port.mk>
diff --git a/net/py-pcapy/distinfo b/net/py-pcapy/distinfo
new file mode 100644
index 000000000000..af9439380b5f
--- /dev/null
+++ b/net/py-pcapy/distinfo
@@ -0,0 +1,2 @@
+MD5 (pcapy-0.10.3.tar.gz) = 2a9eb722156f9ce08370ea4da475af20
+SIZE (pcapy-0.10.3.tar.gz) = 19009
diff --git a/net/py-pcapy/pkg-descr b/net/py-pcapy/pkg-descr
new file mode 100644
index 000000000000..28ea6523b275
--- /dev/null
+++ b/net/py-pcapy/pkg-descr
@@ -0,0 +1,13 @@
+Pcapy is a Python extension module that interfaces with
+the libpcap packet capture library. Pcapy enables Python
+scripts to capture packets on the network.
+
+Pcapy is highly effective when used in conjunction with
+a packet-handling package such as Impacket, which is a
+collection of Python classes for constructing and dissecting
+network packets.
+
+- Marcin Jessa
+yazzy@yazzy.org
+
+WWW: http://oss.coresecurity.com/projects/pcapy.html