aboutsummaryrefslogtreecommitdiff
path: root/net/py-pyenet
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-09 15:34:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-09 15:34:48 +0000
commitf480a259a0ba622c43e81ca3d0ac2f8e62f6b70d (patch)
treeb653c396582cff6b3d53d5c5156f41c1c7ac5267 /net/py-pyenet
parentc7a523f665ee4845535e5a47abca973c92e620c6 (diff)
downloadports-f480a259a0ba622c43e81ca3d0ac2f8e62f6b70d.tar.gz
ports-f480a259a0ba622c43e81ca3d0ac2f8e62f6b70d.zip
- Add net/py-pyenet
pyenet is a python wrapper for the ENet library by Lee Salzman, http://enet.bespin.org WWW: https://pypi.python.org/pypi/pyenet PR: 221090 Submitted by: freebsd@skinc.ru
Notes
Notes: svn path=/head/; revision=519620
Diffstat (limited to 'net/py-pyenet')
-rw-r--r--net/py-pyenet/Makefile24
-rw-r--r--net/py-pyenet/distinfo3
-rw-r--r--net/py-pyenet/files/patch-README.rst11
-rw-r--r--net/py-pyenet/pkg-descr4
4 files changed, 42 insertions, 0 deletions
diff --git a/net/py-pyenet/Makefile b/net/py-pyenet/Makefile
new file mode 100644
index 000000000000..673ed7ca0e90
--- /dev/null
+++ b/net/py-pyenet/Makefile
@@ -0,0 +1,24 @@
+# Created by: Ilia Skalozubov <freebsd@skinc.ru>
+# $FreeBSD$
+
+PORTNAME= pyenet
+DISTVERSION= 1.3.13.post7
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd@skinc.ru
+COMMENT= Python wrapper for the ENet library by Lee Salzman
+
+LICENSE= BSD3CLAUSE MIT
+LICENSE_COMB= multi
+LICENSE_FILE_BSD3CLAUSE=${WRKSRC}/LICENSE
+LICENSE_FILE_MIT= ${WRKSRC}/enet/LICENSE
+
+USES= python
+USE_PYTHON= autoplist cython distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/enet.so
+
+.include <bsd.port.mk>
diff --git a/net/py-pyenet/distinfo b/net/py-pyenet/distinfo
new file mode 100644
index 000000000000..7504b955275f
--- /dev/null
+++ b/net/py-pyenet/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1574269594
+SHA256 (pyenet-1.3.13.post7.tar.gz) = a36ed3ab9ddad25dc5416fa5223830f7f0ae628af986a4045def103057921ebf
+SIZE (pyenet-1.3.13.post7.tar.gz) = 745118
diff --git a/net/py-pyenet/files/patch-README.rst b/net/py-pyenet/files/patch-README.rst
new file mode 100644
index 000000000000..0939b29cc1d8
--- /dev/null
+++ b/net/py-pyenet/files/patch-README.rst
@@ -0,0 +1,11 @@
+--- README.rst.orig 2018-10-30 23:51:01 UTC
++++ README.rst
+@@ -62,7 +62,7 @@ Packaging notes
+ (``python3 -m venv venv && source venv/bin/activate``)
+ - install the requirements: ``pip install -r dev-requirements.txt``
+ - build the source dist: ``python setup.py sdist``
+-- make sure docker is installed and running and you’re on a 64bit linux
++- make sure docker is installed and running and you're on a 64bit linux
+ machine
+ - build the binary dists: ``./scripts/build_packages.sh``
+ - upload to pypi: ``twine upload dist/* wheelhouse/pyenet*``
diff --git a/net/py-pyenet/pkg-descr b/net/py-pyenet/pkg-descr
new file mode 100644
index 000000000000..d785cca8f7ff
--- /dev/null
+++ b/net/py-pyenet/pkg-descr
@@ -0,0 +1,4 @@
+pyenet is a python wrapper for the ENet library by Lee Salzman,
+http://enet.bespin.org
+
+WWW: https://pypi.python.org/pypi/pyenet