aboutsummaryrefslogtreecommitdiff
path: root/net/py-python-barbicanclient
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-12-17 16:38:26 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-12-17 16:38:26 +0000
commit99190c62e9d85f9c7a19901a28159505bc923a23 (patch)
tree3c1308aa243898294c7bbb107ef0e86044ec6c49 /net/py-python-barbicanclient
parent8ee1b0a870171ec2c3a7308be0c9842763ebf01a (diff)
downloadports-99190c62e9d85f9c7a19901a28159505bc923a23.tar.gz
ports-99190c62e9d85f9c7a19901a28159505bc923a23.zip
Add py-python-barbicanclient 4.1.0, client Library for OpenStack
Barbican Key Management API. PR: 215298 Submitted by: Alexander Nusov <alexander.nusov@nfvexpress.com>
Notes
Notes: svn path=/head/; revision=428780
Diffstat (limited to 'net/py-python-barbicanclient')
-rw-r--r--net/py-python-barbicanclient/Makefile30
-rw-r--r--net/py-python-barbicanclient/distinfo3
-rw-r--r--net/py-python-barbicanclient/pkg-descr5
3 files changed, 38 insertions, 0 deletions
diff --git a/net/py-python-barbicanclient/Makefile b/net/py-python-barbicanclient/Makefile
new file mode 100644
index 000000000000..10bccb7deed1
--- /dev/null
+++ b/net/py-python-barbicanclient/Makefile
@@ -0,0 +1,30 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= python-barbicanclient
+PORTVERSION= 4.1.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= Client Library for OpenStack Barbican Key Management API
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.10.0:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}python-keystoneclient>=0:net/py-python-keystoneclient \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.16.0:devel/py-oslo.utils \
+ ${PYTHON_PKGNAMEPREFIX}oslo.serialization>=1.10.0:devel/py-oslo.serialization \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n \
+ ${PYTHON_PKGNAMEPREFIX}cliff>=0:devel/py-cliff
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-python-barbicanclient/distinfo b/net/py-python-barbicanclient/distinfo
new file mode 100644
index 000000000000..8ced241e2e80
--- /dev/null
+++ b/net/py-python-barbicanclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481137848
+SHA256 (python-barbicanclient-4.1.0.tar.gz) = 843678153d6091ad40133191229128b481d58d4c7d170ed21ceac5d8bfade3d7
+SIZE (python-barbicanclient-4.1.0.tar.gz) = 106512
diff --git a/net/py-python-barbicanclient/pkg-descr b/net/py-python-barbicanclient/pkg-descr
new file mode 100644
index 000000000000..b11b57b2078c
--- /dev/null
+++ b/net/py-python-barbicanclient/pkg-descr
@@ -0,0 +1,5 @@
+This is a client for the Barbican Key Management API. There is a Python
+library for accessing the API (barbicanclient module), and a command-line
+script (barbican).
+
+WWW: http://pypi.python.org/pypi/python-barbicanclient