aboutsummaryrefslogtreecommitdiff
path: root/net/py-python-bitcoinrpc
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2015-08-07 05:22:00 +0000
committerFukang Chen <loader@FreeBSD.org>2015-08-07 05:22:00 +0000
commitea1d74dac92beccff5f038c18104f6c100718bb4 (patch)
tree751c502add86028fb3ed8a75e4e868b5a1ed3f61 /net/py-python-bitcoinrpc
parenta784ad08265fc7a52f731f2e8ffe89d8b5a0fdb9 (diff)
downloadports-ea1d74dac92beccff5f038c18104f6c100718bb4.tar.gz
ports-ea1d74dac92beccff5f038c18104f6c100718bb4.zip
Notes
Diffstat (limited to 'net/py-python-bitcoinrpc')
-rw-r--r--net/py-python-bitcoinrpc/Makefile21
-rw-r--r--net/py-python-bitcoinrpc/distinfo2
-rw-r--r--net/py-python-bitcoinrpc/pkg-descr18
3 files changed, 41 insertions, 0 deletions
diff --git a/net/py-python-bitcoinrpc/Makefile b/net/py-python-bitcoinrpc/Makefile
new file mode 100644
index 000000000000..4e9dff5bda3e
--- /dev/null
+++ b/net/py-python-bitcoinrpc/Makefile
@@ -0,0 +1,21 @@
+# Created by: loader <loader@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-bitcoinrpc
+PORTVERSION= 0.3.0.20150403
+CATEGORIES= net finance python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= Enhanced version of python-jsonrpc for use with Bitcoin
+
+LICENSE= LGPL20
+
+USE_GITHUB= yes
+GH_ACCOUNT= jgarzik
+GH_TAGNAME= f607fe7
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-python-bitcoinrpc/distinfo b/net/py-python-bitcoinrpc/distinfo
new file mode 100644
index 000000000000..59aeddb074a2
--- /dev/null
+++ b/net/py-python-bitcoinrpc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jgarzik-python-bitcoinrpc-0.3.0.20150403-f607fe7_GH0.tar.gz) = f8ea6c2b33bdf70b6dcc25a915f6a81241be0869ae612b24036b503f3f52a2ed
+SIZE (jgarzik-python-bitcoinrpc-0.3.0.20150403-f607fe7_GH0.tar.gz) = 3942
diff --git a/net/py-python-bitcoinrpc/pkg-descr b/net/py-python-bitcoinrpc/pkg-descr
new file mode 100644
index 000000000000..065599797b57
--- /dev/null
+++ b/net/py-python-bitcoinrpc/pkg-descr
@@ -0,0 +1,18 @@
+AuthServiceProxy is an improved version of python-jsonrpc.
+
+It includes the following generic improvements:
+
+- HTTP connections persist for the life of the AuthServiceProxy object
+- sends protocol 'version', per JSON-RPC 1.1
+- sends proper, incrementing 'id'
+- uses standard Python json lib
+- can optionally log all RPC calls and results
+- JSON-2.0 batch support
+
+It also includes the following bitcoin-specific details:
+
+- sends Basic HTTP authentication headers
+- parses all JSON numbers that look like floats as Decimal,
+ and serializes Decimal values to JSON-RPC connections.
+
+WWW: https://github.com/jgarzik/python-bitcoinrpc