aboutsummaryrefslogtreecommitdiff
path: root/net/py-python-cinderclient5
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-16 18:00:07 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-16 18:00:07 +0000
commit6b7ac2a240e55781164933c447ce54affc6973f3 (patch)
tree77d2b67035dffc98c9e9f2e460b652d9447c5259 /net/py-python-cinderclient5
parent80886517da109df291b942993219b377de859ebe (diff)
downloadports-6b7ac2a240e55781164933c447ce54affc6973f3.tar.gz
ports-6b7ac2a240e55781164933c447ce54affc6973f3.zip
Add py-python-cinderclient5 5.0.0 (copied from py-python-cinderclient)
- Add PORTSCOUT
Notes
Notes: svn path=/head/; revision=526274
Diffstat (limited to 'net/py-python-cinderclient5')
-rw-r--r--net/py-python-cinderclient5/Makefile37
-rw-r--r--net/py-python-cinderclient5/distinfo3
-rw-r--r--net/py-python-cinderclient5/pkg-descr9
3 files changed, 49 insertions, 0 deletions
diff --git a/net/py-python-cinderclient5/Makefile b/net/py-python-cinderclient5/Makefile
new file mode 100644
index 000000000000..453614cd6c46
--- /dev/null
+++ b/net/py-python-cinderclient5/Makefile
@@ -0,0 +1,37 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= python-cinderclient
+PORTVERSION= 5.0.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 5
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OpenStack Block Storage API Client Library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=3.4.0:devel/py-keystoneauth1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=3.15.3:devel/py-oslo.i18n@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.33.0:devel/py-oslo.utils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0.7.1<0.8:devel/py-prettytable@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.14.2:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=3.5.1:devel/py-simplejson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR}
+
+USES= python shebangfix
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^5\.
+
+SHEBANG_GLOB= *.sh
+
+.include <bsd.port.mk>
diff --git a/net/py-python-cinderclient5/distinfo b/net/py-python-cinderclient5/distinfo
new file mode 100644
index 000000000000..4aade97bacbf
--- /dev/null
+++ b/net/py-python-cinderclient5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578401178
+SHA256 (python-cinderclient-5.0.0.tar.gz) = d61bc8d816c1fe18304843b70bbb33220ebb5ae554b4c3a1c83486ad0d7d1509
+SIZE (python-cinderclient-5.0.0.tar.gz) = 254510
diff --git a/net/py-python-cinderclient5/pkg-descr b/net/py-python-cinderclient5/pkg-descr
new file mode 100644
index 000000000000..89888d5f1d47
--- /dev/null
+++ b/net/py-python-cinderclient5/pkg-descr
@@ -0,0 +1,9 @@
+This is a client for the OpenStack Cinder API. There's a Python API (the
+cinderclient module), and a command-line script (cinder). Each implements 100%
+of the OpenStack Cinder API.
+
+See the OpenStack CLI Reference for information on how to use the cinder
+command-line tool. You may also want to look at the OpenStack API documentation.
+
+WWW: https://docs.openstack.org/python-cinderclient/latest/
+WWW: https://github.com/openstack/python-cinderclient