aboutsummaryrefslogtreecommitdiff
path: root/net/py-python-glanceclient2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-26 12:11:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-26 12:11:05 +0000
commit1c47b1f789d8d220097441c145417dec7baa56b7 (patch)
tree82c1f71164ef0adac4201814ce13b41469c7458a /net/py-python-glanceclient2
parentd581a1e8e29c7bdde3c23999e74a1e9de35ccf03 (diff)
downloadports-1c47b1f789d8d220097441c145417dec7baa56b7.tar.gz
ports-1c47b1f789d8d220097441c145417dec7baa56b7.zip
Add py-python-glanceclient2 2.17.0 (copied from py-python-glanceclient)
- Add PORTSCOUT
Notes
Notes: svn path=/head/; revision=536610
Diffstat (limited to 'net/py-python-glanceclient2')
-rw-r--r--net/py-python-glanceclient2/Makefile49
-rw-r--r--net/py-python-glanceclient2/distinfo3
-rw-r--r--net/py-python-glanceclient2/pkg-descr7
3 files changed, 59 insertions, 0 deletions
diff --git a/net/py-python-glanceclient2/Makefile b/net/py-python-glanceclient2/Makefile
new file mode 100644
index 000000000000..276e5f6d1cb3
--- /dev/null
+++ b/net/py-python-glanceclient2/Makefile
@@ -0,0 +1,49 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= python-glanceclient
+PORTVERSION= 2.17.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 2
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OpenStack Image API Client Library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0.7.1<0.8:devel/py-prettytable@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=17.1.0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.14.2:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}warlock>=1.2.0<2:devel/py-warlock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wrapt>=1.7.0:devel/py-wrapt@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+# python-glanceclient 3.0.0+ requires Python 3.6+
+PORTSCOUT= limit:^2\.
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3600
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}keystoneauth13>=3.6.2:devel/py-keystoneauth13@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n3>=3.15.3:devel/py-oslo.i18n3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils3>=3.33.0:devel/py-oslo.utils3@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=3.6.2:devel/py-keystoneauth1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=3.15.3:devel/py-oslo.i18n@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.33.0:devel/py-oslo.utils@${PY_FLAVOR}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/glance|${PREFIX}&|g' ${WRKSRC}/glanceclient/shell.py
+
+.include <bsd.port.post.mk>
diff --git a/net/py-python-glanceclient2/distinfo b/net/py-python-glanceclient2/distinfo
new file mode 100644
index 000000000000..35e3ddb43320
--- /dev/null
+++ b/net/py-python-glanceclient2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578401182
+SHA256 (python-glanceclient-2.17.0.tar.gz) = cb9d1168aa4857800069419b0114756cb78fea5f1c38ae1d78a2851e49561142
+SIZE (python-glanceclient-2.17.0.tar.gz) = 189397
diff --git a/net/py-python-glanceclient2/pkg-descr b/net/py-python-glanceclient2/pkg-descr
new file mode 100644
index 000000000000..70d24778c99c
--- /dev/null
+++ b/net/py-python-glanceclient2/pkg-descr
@@ -0,0 +1,7 @@
+This is a client library for Glance built on the OpenStack Images API. It
+provides a Python API (the glanceclient module) and a command-line tool
+(glance). This library fully supports the v1 Images API, while support for the
+v2 API is in progress.
+
+WWW: https://docs.openstack.org/python-glanceclient/latest/
+WWW: https://github.com/openstack/python-glanceclient