aboutsummaryrefslogtreecommitdiff
path: root/net/py-python-openstackclient
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /net/py-python-openstackclient
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'net/py-python-openstackclient')
-rw-r--r--net/py-python-openstackclient/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/net/py-python-openstackclient/Makefile b/net/py-python-openstackclient/Makefile
index adacbc0670b6..94d9f65b3003 100644
--- a/net/py-python-openstackclient/Makefile
+++ b/net/py-python-openstackclient/Makefile
@@ -13,19 +13,19 @@ COMMENT= Client for the OpenStack
LICENSE= APACHE20
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.8:devel/py-pbr
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel \
- ${PYTHON_PKGNAMEPREFIX}cliff>=2.3.0:devel/py-cliff \
- ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=2.16.0:devel/py-keystoneauth1 \
- ${PYTHON_PKGNAMEPREFIX}openstacksdk>=0.9.10:devel/py-openstacksdk \
- ${PYTHON_PKGNAMEPREFIX}osc-lib>=1.2.0:devel/py-osc-lib \
- ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n \
- ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.18.0:devel/py-oslo.utils \
- ${PYTHON_PKGNAMEPREFIX}python-glanceclient>=2.5.0:net/py-python-glanceclient \
- ${PYTHON_PKGNAMEPREFIX}python-keystoneclient>=3.8.0:net/py-python-keystoneclient \
- ${PYTHON_PKGNAMEPREFIX}python-novaclient>=0:net/py-python-novaclient \
- ${PYTHON_PKGNAMEPREFIX}python-cinderclient>=0:net/py-python-cinderclient \
- ${PYTHON_PKGNAMEPREFIX}python-neutronclient>=0:net/py-python-neutronclient
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.8:devel/py-pbr@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cliff>=2.3.0:devel/py-cliff@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=2.16.0:devel/py-keystoneauth1@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openstacksdk>=0.9.10:devel/py-openstacksdk@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}osc-lib>=1.2.0:devel/py-osc-lib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.18.0:devel/py-oslo.utils@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-glanceclient>=2.5.0:net/py-python-glanceclient@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-keystoneclient>=3.8.0:net/py-python-keystoneclient@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-novaclient>=0:net/py-python-novaclient@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-cinderclient>=0:net/py-python-cinderclient@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-neutronclient>=0:net/py-python-neutronclient@${FLAVOR}
USES= python shebangfix
USE_PYTHON= distutils autoplist noegginfo