aboutsummaryrefslogtreecommitdiff
path: root/net/py-python-twitter
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2017-05-16 01:09:34 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2017-05-16 01:09:34 +0000
commitd1fba0e62a2e225b6f09ec16011732d1f498ae84 (patch)
tree19504376f2bd29498a4341175f626267ccb64703 /net/py-python-twitter
parent870d67a2c534a341f2d84ecaed538eac66776a2f (diff)
downloadports-d1fba0e62a2e225b6f09ec16011732d1f498ae84.tar.gz
ports-d1fba0e62a2e225b6f09ec16011732d1f498ae84.zip
net/py-twitter: Rename to py-python-twitter
Renamed to reflect official name at PyPI/Github. PR: 212673 Approved by: garga (mentor), python (miwi) Differential Revision: https://reviews.freebsd.org/D10705
Notes
Notes: svn path=/head/; revision=440987
Diffstat (limited to 'net/py-python-twitter')
-rw-r--r--net/py-python-twitter/Makefile23
-rw-r--r--net/py-python-twitter/distinfo3
-rw-r--r--net/py-python-twitter/files/patch-setup.py10
-rw-r--r--net/py-python-twitter/pkg-descr7
4 files changed, 43 insertions, 0 deletions
diff --git a/net/py-python-twitter/Makefile b/net/py-python-twitter/Makefile
new file mode 100644
index 000000000000..a8b9ea9dc546
--- /dev/null
+++ b/net/py-python-twitter/Makefile
@@ -0,0 +1,23 @@
+# Created by: ijliao
+# $FreeBSD$
+
+PORTNAME= python-twitter
+PORTVERSION= 3.2.1
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Python wrapper around the Twitter API
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0:www/py-requests-oauthlib
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-python-twitter/distinfo b/net/py-python-twitter/distinfo
new file mode 100644
index 000000000000..976aff3837f8
--- /dev/null
+++ b/net/py-python-twitter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485179216
+SHA256 (python-twitter-3.2.1.tar.gz) = f621e035e114435114967a35a34d3346e59544df4c69fbedb1e382d9677087db
+SIZE (python-twitter-3.2.1.tar.gz) = 84189
diff --git a/net/py-python-twitter/files/patch-setup.py b/net/py-python-twitter/files/patch-setup.py
new file mode 100644
index 000000000000..81702979369e
--- /dev/null
+++ b/net/py-python-twitter/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2016-12-23 00:11:09 UTC
++++ setup.py
+@@ -57,7 +57,6 @@ setup(
+ packages=find_packages(exclude=('tests', 'docs')),
+ platforms=['Any'],
+ install_requires=['future', 'requests', 'requests-oauthlib'],
+- setup_requires=['pytest-runner'],
+ tests_require=['pytest'],
+ keywords='twitter api',
+ classifiers=[
diff --git a/net/py-python-twitter/pkg-descr b/net/py-python-twitter/pkg-descr
new file mode 100644
index 000000000000..8cbd3f3dce4e
--- /dev/null
+++ b/net/py-python-twitter/pkg-descr
@@ -0,0 +1,7 @@
+This library provides a pure python interface for the Twitter API.
+
+Twitter provides a service that allows people to connect via the web, IM, and
+SMS. Twitter exposes a web services API and this library is intended to make it
+even easier for python programmers to use.
+
+WWW: https://github.com/bear/python-twitter