aboutsummaryrefslogtreecommitdiff
path: root/net/py-qt5-networkauth
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-03-08 06:49:17 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-03-08 06:49:17 +0000
commit108f234f7f692f592a08cd969eef7f74e8cff51f (patch)
tree0799882dc637a360900380bd9d4ad99ba969a0eb /net/py-qt5-networkauth
parent7a8e6f04393be5ff33e8f39b29a6b0d0431f25bf (diff)
downloadports-108f234f7f692f592a08cd969eef7f74e8cff51f.tar.gz
ports-108f234f7f692f592a08cd969eef7f74e8cff51f.zip
PyQt5: Update PyQt5 to 5.15.3, QScintilla2 to 2.12.0, py-qtbuilder to 1.9.0
* PyQt5: update to 5.15.3 This is a minor feature and bug-fix release. There are corresponding releases of the other PyQt5-related packages. - Added the missing QImage.setAlphaChannel(). - Support for the QtNetworkAuth library has been moved to a separate PyQtNetworkAuth package. - Wheels no longer bundle the corresponding Qt libraries and instead automatically install them from an external wheel. * QScintilla2: update to 2.12.0 This adds support for Qt6 and removes support for Qt4. - Change the new distname (again)i due to a conflict - Use the new sip-build system * devel/py-qtbuilder: update to 1.9.0 * devel/py-sip: fix flavor for sip-distinfo PR: 253865 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=567825
Diffstat (limited to 'net/py-qt5-networkauth')
-rw-r--r--net/py-qt5-networkauth/Makefile31
-rw-r--r--net/py-qt5-networkauth/distinfo3
-rw-r--r--net/py-qt5-networkauth/pkg-plist2
3 files changed, 28 insertions, 8 deletions
diff --git a/net/py-qt5-networkauth/Makefile b/net/py-qt5-networkauth/Makefile
index a80697e9432e..3de08972382a 100644
--- a/net/py-qt5-networkauth/Makefile
+++ b/net/py-qt5-networkauth/Makefile
@@ -1,30 +1,47 @@
# $FreeBSD$
PORTNAME= networkauth
-PORTREVISION= 1
+PORTVERSION= ${PYQT5_VERSION}
CATEGORIES= net devel python
+MASTER_SITES= ${MASTER_SITES_PYQTNETWORKAUTH}
+PKGNAMEPREFIX= ${PYQT_PY_RELNAME}-
+DISTNAME= ${PYQTNETWORKAUTH_DISTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt5 toolkit, QtNetworkAuth module
-CONFIGURE_ARGS= --enable QtNetworkAuth
-PYQT_DIST= yes
-
USES= python:3.5+ pyqt:5 qt:5
-USE_PYQT= sip_build core_run
+USE_PYQT= sip_build core gui network widgets
USE_PYTHON= concurrent flavors py3kplist
-USE_QT= core network networkauth qmake_build
+USE_QT= core gui network networkauth qmake_build
+USE_GL+= gl
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --verbose --no-dist-info \
+ -d ${PYTHONPREFIX_SITELIBDIR}/PyQt5 \
+ -q ${QMAKE} \
+ --sip ${SIP} \
+ --pyqt-sipdir=${PYQT_SIPDIR}
+DESTDIRNAME= INSTALL_ROOT
OPTIONS_DEFINE= API DEBUG
OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtNetworkAuth API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
+API_CONFIGURE_ON= --apidir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
+post-patch:
+ ${REINPLACE_CMD} -e "s/sip-module/sip-module-${PYTHON_VER}/" ${WRKSRC}/configure.py;
+ ${REINPLACE_CMD} -e "s/-gui/gui/" ${WRKSRC}/configure.py ${WRKSRC}/pyproject.toml
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${PYTHON_CMD} configure.py ${CONFIGURE_ARGS}
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtNetworkAuth.so
diff --git a/net/py-qt5-networkauth/distinfo b/net/py-qt5-networkauth/distinfo
new file mode 100644
index 000000000000..d23dd153db18
--- /dev/null
+++ b/net/py-qt5-networkauth/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614867526
+SHA256 (PyQtNetworkAuth-5.15.3.tar.gz) = 2590eae76d4b87ceb9f0d857a5631e13dd14f7fdab2b5e696df61f77e4e3fd82
+SIZE (PyQtNetworkAuth-5.15.3.tar.gz) = 35833
diff --git a/net/py-qt5-networkauth/pkg-plist b/net/py-qt5-networkauth/pkg-plist
index aae55df20e83..94d164faa869 100644
--- a/net/py-qt5-networkauth/pkg-plist
+++ b/net/py-qt5-networkauth/pkg-plist
@@ -1,6 +1,6 @@
%%PYTHON_SITELIBDIR%%/PyQt5/QtNetworkAuth.pyi
%%PYTHON_SITELIBDIR%%/PyQt5/QtNetworkAuth.so
-%%API%%%%PYQT_APIDIR%%/api/python/QtNetworkAuth.api
+%%API%%%%PYQT_APIDIR%%/api/python/PyQtNetworkAuth.api
%%PYQT_SIPDIR%%/QtNetworkAuth/QtNetworkAuthmod.sip
%%PYQT_SIPDIR%%/QtNetworkAuth/qabstractoauth.sip
%%PYQT_SIPDIR%%/QtNetworkAuth/qabstractoauth2.sip