aboutsummaryrefslogtreecommitdiff
path: root/net/py-s3transfer
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-10 19:59:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-10 19:59:01 +0000
commit676e08254a5f6ba1638e07403be82a4b9ad1ac9a (patch)
tree6cbdcc8581423f2c2c8b9fd62c01af742f25b85b /net/py-s3transfer
parent4e51297cf6e76ff28b0411bcc3125c34abe69586 (diff)
Notes
Diffstat (limited to 'net/py-s3transfer')
-rw-r--r--net/py-s3transfer/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/net/py-s3transfer/Makefile b/net/py-s3transfer/Makefile
index 81f4e3fea156..21b5c654a530 100644
--- a/net/py-s3transfer/Makefile
+++ b/net/py-s3transfer/Makefile
@@ -12,7 +12,8 @@ COMMENT= Amazon S3 Transfer Manager for Python
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.3.0:devel/py-botocore@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.3.0:devel/py-botocore@${FLAVOR} \
+ ${PY_FUTURES}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.3.3:devel/py-nose@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=1.3.0:devel/py-mock@${FLAVOR}
@@ -22,15 +23,9 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>=2.2.0:devel/py-futures@${FLAVOR}
-.endif
-
# setup.py test runs integration tests which fail
# https://github.com/boto/s3transfer/issues/41
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v tests/unit tests/functional
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>