aboutsummaryrefslogtreecommitdiff
path: root/net/py-s3transfer
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-08-06 11:55:47 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-08-06 11:55:47 +0000
commit7432e90df48eb81035790342e5dc2a7575f72d8a (patch)
tree8d17d3ab68d6fc088f635f9c29488741b9ca3f58 /net/py-s3transfer
parent8d69dae7ee6dc74235d424020c6a947676686244 (diff)
downloadports-7432e90df48eb81035790342e5dc2a7575f72d8a.tar.gz
ports-7432e90df48eb81035790342e5dc2a7575f72d8a.zip
net/py-s3transfer: Update to 0.1.1, Modernize
* Update PORTVERSION and distinfo checksum (0.1.1) * Add LICENSE_FILE * Document actual Python version support in a comment for later * Patch setup.py to properly declare test dependencies and hook up the test command * Add TEST_DEPENDS and test target for QA https://github.com/boto/s3transfer/blob/0.1.1/CHANGELOG.rst Approved by: Bradley Hughes <bradleythughes fastmail fm> (maintainer, via email)
Notes
Notes: svn path=/head/; revision=419740
Diffstat (limited to 'net/py-s3transfer')
-rw-r--r--net/py-s3transfer/Makefile12
-rw-r--r--net/py-s3transfer/distinfo5
-rw-r--r--net/py-s3transfer/files/patch-setup.py22
3 files changed, 36 insertions, 3 deletions
diff --git a/net/py-s3transfer/Makefile b/net/py-s3transfer/Makefile
index 9f7694e69985..ec89d2914d3e 100644
--- a/net/py-s3transfer/Makefile
+++ b/net/py-s3transfer/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= s3transfer
-PORTVERSION= 0.0.1
+PORTVERSION= 0.1.1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,11 +10,16 @@ MAINTAINER= bradleythughes@fastmail.fm
COMMENT= Amazon S3 Transfer Manager for Python
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.3.0:devel/py-botocore
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.3.3:devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}mock>=1.3.0:devel/py-mock
+#Actually -2.7,3.3-3.5
USES= python
USE_PYTHON= autoplist distutils
+
NO_ARCH= yes
.include <bsd.port.pre.mk>
@@ -23,4 +28,9 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>=2.2.0:devel/py-futures
.endif
+# setup.py test runs integration tests which fail
+# https://github.com/boto/s3transfer/issues/41
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v tests/unit tests/functional
+
.include <bsd.port.post.mk>
diff --git a/net/py-s3transfer/distinfo b/net/py-s3transfer/distinfo
index 8fbf6f62ddf5..a16b48ae1756 100644
--- a/net/py-s3transfer/distinfo
+++ b/net/py-s3transfer/distinfo
@@ -1,2 +1,3 @@
-SHA256 (s3transfer-0.0.1.tar.gz) = 2bb9ed8db58af94dfa78f75f554d646dfe4b4741fc87f63a20c2bfb3f70f4355
-SIZE (s3transfer-0.0.1.tar.gz) = 9465
+TIMESTAMP = 1470477581
+SHA256 (s3transfer-0.1.1.tar.gz) = 6b9131b704819b0e559a97eec373ff6cc8a9b258e4c8f58ad339650b5019f00f
+SIZE (s3transfer-0.1.1.tar.gz) = 82198
diff --git a/net/py-s3transfer/files/patch-setup.py b/net/py-s3transfer/files/patch-setup.py
new file mode 100644
index 000000000000..5c6ef40e8707
--- /dev/null
+++ b/net/py-s3transfer/files/patch-setup.py
@@ -0,0 +1,22 @@
+--- setup.py.orig 2016-08-06 10:02:48 UTC
++++ setup.py
+@@ -14,6 +14,10 @@ requires = [
+ 'botocore>=1.3.0,<2.0.0',
+ ]
+
++tests_require = [
++ 'nose>=1.3.3',
++ 'mock>=1.3.0',
++]
+
+ if sys.version_info[0] == 2:
+ # concurrent.futures is only in python3, so for
+@@ -41,6 +45,8 @@ setup(
+ ':python_version=="2.6" or python_version=="2.7"': [
+ 'futures>=2.2.0,<4.0.0']
+ },
++ tests_require=tests_require,
++ test_suite='nose.collector',
+ license="Apache License 2.0",
+ classifiers=(
+ 'Development Status :: 1 - Planning',