aboutsummaryrefslogtreecommitdiff
path: root/net/py-sbws
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2018-10-19 14:09:32 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2018-10-19 14:09:32 +0000
commitd1759eb1f234f94d1176edf652dcefc02f3d0645 (patch)
tree9c22c8e9102944a4e9f40be7a532a716327d8315 /net/py-sbws
parent6ad9ccd707597e0a06371c555e75fed3f4e3e9a7 (diff)
downloadports-d1759eb1f234f94d1176edf652dcefc02f3d0645.tar.gz
ports-d1759eb1f234f94d1176edf652dcefc02f3d0645.zip
[NEW PORT] net/py-sbws: Tor network bandwidth scanner
Simple Bandwidth Scanner (a.k.a sbws) is a Tor bandwidth scanner that produces bandwidth measurements files to be used by Directory Authorities. The scanner builds two hop circuits consisting of the relay being measured and a fast exit. Over these circuits it measures RTT and bandwidth. WWW: https://sbws.readthedocs.io/ Approved by: araujo (mentor) Differential Revision: https://reviews.freebsd.org/D17606
Notes
Notes: svn path=/head/; revision=482429
Diffstat (limited to 'net/py-sbws')
-rw-r--r--net/py-sbws/Makefile29
-rw-r--r--net/py-sbws/distinfo3
-rw-r--r--net/py-sbws/pkg-descr7
3 files changed, 39 insertions, 0 deletions
diff --git a/net/py-sbws/Makefile b/net/py-sbws/Makefile
new file mode 100644
index 000000000000..cb8bc55449b5
--- /dev/null
+++ b/net/py-sbws/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= sbws
+PORTVERSION= 0.8.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= egypcio@googlemail.com
+COMMENT= Tor network bandwidth scanner
+
+LICENSE= CC0-1.0
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stem>=1.7.0:security/py-stem@${PY_FLAVOR} \
+ tor:security/tor
+
+USES= cpe python:3.5+ shebangfix
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils flavors
+
+CPE_VENDOR= torproject
+GH_ACCOUNT= torproject
+
+SHEBANG_FILES= tests/testnets/simple.common/03-network-in-ready-state.py \
+ tests/testnets/simple-ipv4/03-network-in-ready-state.py \
+ tests/testnets/simple-ipv6/03-network-in-ready-state.py
+
+.include <bsd.port.mk>
diff --git a/net/py-sbws/distinfo b/net/py-sbws/distinfo
new file mode 100644
index 000000000000..8cc82c6d7ca1
--- /dev/null
+++ b/net/py-sbws/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539850400
+SHA256 (torproject-sbws-v0.8.0_GH0.tar.gz) = 0520f40caa405bf49baa5380f6846c61c617d31649adc4e472162f49bb67cb8f
+SIZE (torproject-sbws-v0.8.0_GH0.tar.gz) = 156048
diff --git a/net/py-sbws/pkg-descr b/net/py-sbws/pkg-descr
new file mode 100644
index 000000000000..a54dc14a5033
--- /dev/null
+++ b/net/py-sbws/pkg-descr
@@ -0,0 +1,7 @@
+Simple Bandwidth Scanner (a.k.a sbws) is a Tor bandwidth scanner that produces
+bandwidth measurements files to be used by Directory Authorities.
+
+The scanner builds two hop circuits consisting of the relay being measured and
+a fast exit. Over these circuits it measures RTT and bandwidth.
+
+WWW: https://sbws.readthedocs.io/