aboutsummaryrefslogtreecommitdiff
path: root/net/py-smart-open
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-02 01:35:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-02 01:35:25 +0000
commit93e023ad8b4b6720d36c8b041ba9f7acd4eca5fb (patch)
tree0e719b9e9d231a0594b0c6beae36dd6f2e6ebc66 /net/py-smart-open
parente4289f4048ce160a423b62487fad571876c03c0b (diff)
downloadports-93e023ad8b4b6720d36c8b041ba9f7acd4eca5fb.tar.gz
ports-93e023ad8b4b6720d36c8b041ba9f7acd4eca5fb.zip
Move net/py-smart_open to net/py-smart-open
Notes
Notes: svn path=/head/; revision=533605
Diffstat (limited to 'net/py-smart-open')
-rw-r--r--net/py-smart-open/Makefile39
-rw-r--r--net/py-smart-open/distinfo3
-rw-r--r--net/py-smart-open/pkg-descr6
3 files changed, 48 insertions, 0 deletions
diff --git a/net/py-smart-open/Makefile b/net/py-smart-open/Makefile
new file mode 100644
index 000000000000..25245bc8e694
--- /dev/null
+++ b/net/py-smart-open/Makefile
@@ -0,0 +1,39 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= smart-open
+PORTVERSION= 1.11.1
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= smart_open-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Utils for streaming large files
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramiko>=0:security/py-paramiko@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pathlib2>=0:devel/py-pathlib2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-rerunfailures>=0:devel/py-pytest-rerunfailures@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}responses>=0:devel/py-responses@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= AWS GCP
+OPTIONS_DEFAULT=AWS GCP
+AWS_DESC= Amazon Web Services (AWS) support
+GCP_DESC= Google Cloud Platform (GCP) support
+
+AWS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>=0:devel/py-boto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boto3>=0:www/py-boto3@${PY_FLAVOR}
+GCP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-cloud-storage>=0:www/py-google-cloud-storage@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/net/py-smart-open/distinfo b/net/py-smart-open/distinfo
new file mode 100644
index 000000000000..a89634e60383
--- /dev/null
+++ b/net/py-smart-open/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1587445408
+SHA256 (smart_open-1.11.1.tar.gz) = 221cc08ae926af6ad72d141f208d228e1e801b1ee9b15f3e466eecf89d931002
+SIZE (smart_open-1.11.1.tar.gz) = 105305
diff --git a/net/py-smart-open/pkg-descr b/net/py-smart-open/pkg-descr
new file mode 100644
index 000000000000..fa2c529ebdf1
--- /dev/null
+++ b/net/py-smart-open/pkg-descr
@@ -0,0 +1,6 @@
+smart_open is a Python 2 & Python 3 library for efficient streaming of very
+large files from/to S3, HDFS, WebHDFS, HTTP, or local (compressed) files. It is
+well tested (using moto), well documented and sports a simple, Pythonic API.
+
+WWW: https://pypi.org/project/smart_open/
+WWW: https://github.com/RaRe-Technologies/smart_open