aboutsummaryrefslogtreecommitdiff
path: root/net/py-soappy
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-25 20:05:43 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-25 20:05:43 +0000
commite39e0ababd9ffb6cd76ac6fb661860fda373da19 (patch)
tree98807179402f82c60511e5c04bf2858825014f16 /net/py-soappy
parentdbfc687b0659b8a5bd8def6a6f8c90fc98c309b2 (diff)
downloadports-e39e0ababd9ffb6cd76ac6fb661860fda373da19.tar.gz
ports-e39e0ababd9ffb6cd76ac6fb661860fda373da19.zip
Notes
Diffstat (limited to 'net/py-soappy')
-rw-r--r--net/py-soappy/Makefile18
-rw-r--r--net/py-soappy/distinfo4
-rw-r--r--net/py-soappy/files/patch-python2556
-rw-r--r--net/py-soappy/pkg-descr4
4 files changed, 12 insertions, 70 deletions
diff --git a/net/py-soappy/Makefile b/net/py-soappy/Makefile
index 60dd14651f12..6f695b2ee081 100644
--- a/net/py-soappy/Makefile
+++ b/net/py-soappy/Makefile
@@ -2,24 +2,22 @@
# $FreeBSD$
PORTNAME= soappy
-PORTVERSION= 0.11.6
-PORTREVISION= 1
+PORTVERSION= 0.12.22
CATEGORIES= net python
-MASTER_SITES= SF/pywebsvcs/SOAP.py/${PORTVERSION}
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= SOAPpy-${PORTVERSION}
MAINTAINER= bofh@FreeBSD.org
-COMMENT= SOAP implementation
-
+COMMENT= SOAP Services for Python
+# Actual LICENSE is in GH Repo but not in pypi release
LICENSE= BSD3CLAUSE
-PORTSCOUT= skipv:0.12.0 # This is a release candidate and is ports tree py*-soappy-devel
-USES= python
-USE_PYTHON= distutils autoplist
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defusedxml>0:${PORTSDIR}/devel/py-defusedxml \
+ ${PYTHON_PKGNAMEPREFIX}wstools>0:${PORTSDIR}/textproc/py-wstools
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/fpconst.py:${PORTSDIR}/math/py-fpconst
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= python:2 zip
+USE_PYTHON= autoplist distutils
CONFLICTS= py*-soappy-devel-0.12.*
diff --git a/net/py-soappy/distinfo b/net/py-soappy/distinfo
index 55080c14bdcf..fbba31c9a29e 100644
--- a/net/py-soappy/distinfo
+++ b/net/py-soappy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (SOAPpy-0.11.6.tar.gz) = 42c8cb3e42b439bc36b6ba3f090ddb72a214ca9264a2babf102c98731dea8e6a
-SIZE (SOAPpy-0.11.6.tar.gz) = 159078
+SHA256 (SOAPpy-0.12.22.zip) = e70845906bb625144ae6a8df4534d66d84431ff8e21835d7b401ec6d8eb447a5
+SIZE (SOAPpy-0.12.22.zip) = 172855
diff --git a/net/py-soappy/files/patch-python25 b/net/py-soappy/files/patch-python25
deleted file mode 100644
index 2970754d4f8a..000000000000
--- a/net/py-soappy/files/patch-python25
+++ /dev/null
@@ -1,56 +0,0 @@
---- ./SOAPpy/Client.py.orig Fri Mar 30 08:41:24 2007
-+++ ./SOAPpy/Client.py Fri Mar 30 08:41:31 2007
-@@ -40,10 +40,10 @@
- ################################################################################
- """
-
-+from __future__ import nested_scopes
- ident = '$Id: Client.py,v 1.20 2004/04/10 04:22:52 irjudson Exp $'
- from version import __version__
-
--from __future__ import nested_scopes
-
- #import xml.sax
- import urllib
---- ./SOAPpy/GSIServer.py.orig Fri Mar 30 08:41:46 2007
-+++ ./SOAPpy/GSIServer.py Fri Mar 30 08:42:16 2007
-@@ -43,10 +43,10 @@
- ################################################################################
- """
-
-+from __future__ import nested_scopes
- ident = '$Id: GSIServer.py,v 1.4 2004/02/04 03:21:02 irjudson Exp $'
- from version import __version__
-
--from __future__ import nested_scopes
-
- #import xml.sax
- import re
---- ./SOAPpy/Server.py.orig Fri Mar 30 08:41:53 2007
-+++ ./SOAPpy/Server.py Fri Mar 30 08:42:24 2007
-@@ -40,10 +40,10 @@
- ################################################################################
- """
-
-+from __future__ import nested_scopes
- ident = '$Id: Server.py,v 1.20 2004/04/28 21:47:10 warnes Exp $'
- from version import __version__
-
--from __future__ import nested_scopes
-
- #import xml.sax
- import re
---- ./SOAPpy/Types.py.orig Fri Mar 30 08:41:56 2007
-+++ ./SOAPpy/Types.py Fri Mar 30 08:42:29 2007
-@@ -33,10 +33,10 @@
- ################################################################################
- """
-
-+from __future__ import nested_scopes
- ident = '$Id: Types.py,v 1.17 2004/09/11 03:03:33 warnes Exp $'
- from version import __version__
-
--from __future__ import nested_scopes
-
- import UserList
- import base64
diff --git a/net/py-soappy/pkg-descr b/net/py-soappy/pkg-descr
index d4619cecf69c..6f9a9ff1cb01 100644
--- a/net/py-soappy/pkg-descr
+++ b/net/py-soappy/pkg-descr
@@ -1,3 +1,3 @@
-A SOAP implementation for python.
+SOAPpy provides tools for building SOAP clients and servers.
-WWW: http://pywebsvcs.sourceforge.net/
+WWW: https://github.com/kiorky/SOAPpy