aboutsummaryrefslogtreecommitdiff
path: root/net/py-sshuttle
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-10-10 05:13:54 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-10-10 05:13:54 +0000
commitfe5af3d123c1a5d277ee16f1fde77af918e089d9 (patch)
tree9add2c1390fbbf9a2652b9894940a8068db0f592 /net/py-sshuttle
parent7d390a59a417b068ab017d0ca81264e9c95c32ab (diff)
downloadports-fe5af3d123c1a5d277ee16f1fde77af918e089d9.tar.gz
ports-fe5af3d123c1a5d277ee16f1fde77af918e089d9.zip
Notes
Diffstat (limited to 'net/py-sshuttle')
-rw-r--r--net/py-sshuttle/Makefile28
-rw-r--r--net/py-sshuttle/distinfo3
-rw-r--r--net/py-sshuttle/files/patch-setup.py19
-rw-r--r--net/py-sshuttle/pkg-descr18
4 files changed, 68 insertions, 0 deletions
diff --git a/net/py-sshuttle/Makefile b/net/py-sshuttle/Makefile
new file mode 100644
index 000000000000..9bbb6567d7fc
--- /dev/null
+++ b/net/py-sshuttle/Makefile
@@ -0,0 +1,28 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sshuttle
+PORTVERSION= 0.78.1
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Full-featured VPN over an SSH tunnel
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/net/py-sshuttle/distinfo b/net/py-sshuttle/distinfo
new file mode 100644
index 000000000000..339c99f3295b
--- /dev/null
+++ b/net/py-sshuttle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476071476
+SHA256 (sshuttle-0.78.1.tar.gz) = 03a71648ce476de06a075bd9a972492d494b414ae51304bf535b80ff22be2d3c
+SIZE (sshuttle-0.78.1.tar.gz) = 67173
diff --git a/net/py-sshuttle/files/patch-setup.py b/net/py-sshuttle/files/patch-setup.py
new file mode 100644
index 000000000000..dd8f7fd2d766
--- /dev/null
+++ b/net/py-sshuttle/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py.orig 2016-10-10 04:57:26 UTC
++++ setup.py
+@@ -36,7 +36,7 @@ setup(
+ 'write_to': "sshuttle/version.py",
+ 'version_scheme': version_scheme,
+ },
+- setup_requires=['setuptools_scm', 'pytest-runner'],
++ setup_requires=['setuptools_scm'],
+ # version=version,
+ url='https://github.com/sshuttle/sshuttle',
+ author='Brian May',
+@@ -61,6 +61,6 @@ setup(
+ 'sshuttle = sshuttle.cmdline:main',
+ ],
+ },
+- tests_require=['pytest', 'mock'],
++ tests_require=['pytest', 'pytest-runner', 'mock'],
+ keywords="ssh vpn",
+ )
diff --git a/net/py-sshuttle/pkg-descr b/net/py-sshuttle/pkg-descr
new file mode 100644
index 000000000000..c3d371b9867c
--- /dev/null
+++ b/net/py-sshuttle/pkg-descr
@@ -0,0 +1,18 @@
+As far as I (the author) knows, sshuttle is the only program that solves
+the following common case:
+
+ * Your client machine (or router) is Linux, FreeBSD, or MacOS.
+ * You have access to a remote network via ssh.
+ * You don't necessarily have admin access on the remote network.
+ * The remote network has no VPN, or only stupid/complex VPN protocols
+ (IPsec, PPTP, etc). Or maybe you are the admin and you just got
+ frustrated with the awful state of VPN tools.
+ * You don't want to create an ssh port forward for every single host/port
+ on the remote network.
+ * You hate openssh's port forwarding because it's randomly slow and/or
+ stupid.
+ * You can't use openssh's PermitTunnel feature because it's disabled by
+ default on openssh servers; plus it does TCP-over-TCP, which has
+ terrible performance
+
+WWW: https://github.com/sshuttle/sshuttle