aboutsummaryrefslogtreecommitdiff
path: root/net/py-transip/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-13 17:41:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-13 17:41:10 +0000
commit3848d732280bd5fe10be15d983f147c37c9bcc43 (patch)
treed05fdce9321b3af07138ededc3aea9281651ec36 /net/py-transip/Makefile
parent24a404344b3a26173e10b515c2a1be61a4134ef5 (diff)
downloadports-3848d732280bd5fe10be15d983f147c37c9bcc43.tar.gz
ports-3848d732280bd5fe10be15d983f147c37c9bcc43.zip
Notes
Diffstat (limited to 'net/py-transip/Makefile')
-rw-r--r--net/py-transip/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/py-transip/Makefile b/net/py-transip/Makefile
new file mode 100644
index 000000000000..86ab2df34085
--- /dev/null
+++ b/net/py-transip/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= transip
+PORTVERSION= 2.0.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= TransIP API Connector
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}suds-jurko>=0:net/py-suds-jurko@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>