aboutsummaryrefslogtreecommitdiff
path: root/net/py-txamqp/Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2009-07-04 19:17:11 +0000
committerBruce M Simpson <bms@FreeBSD.org>2009-07-04 19:17:11 +0000
commit1e5447a9bc7f84b573166aaccc37bd3fee0f5908 (patch)
tree0167da4e73dc5607d74fa2948f45c688a4524ac9 /net/py-txamqp/Makefile
parent37bb6161f08acfd9933a15742cca8ef7892ee01f (diff)
Notes
Diffstat (limited to 'net/py-txamqp/Makefile')
-rw-r--r--net/py-txamqp/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/py-txamqp/Makefile b/net/py-txamqp/Makefile
new file mode 100644
index 000000000000..96eb8f654e0b
--- /dev/null
+++ b/net/py-txamqp/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: txamqp
+# Date created: 2009-07-04
+# Whom: Bruce Simpson
+#
+# $FreeBSD$
+#
+
+PORTNAME= txamqp
+PORTVERSION= 0.2.1
+CATEGORIES= net python
+MASTER_SITES= http://launchpadlibrarian.net/20320545/ \
+ # http://launchpad.net/txamqp/trunk/${PORTVERSION}/+download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Twisted Python library for the AMQP messaging protocol
+
+USE_BZIP2= yes
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+USE_TWISTED= yes
+
+PYDISTUTILS_PKGNAME= txAMQP
+PYDISTUTILS_PKGVERSION= 0.2
+PLIST_SUB= PORTNAME="${PORTNAME}"
+
+# TODO: Install AMQP spec files in a separate leaf port.
+# TODO: Install txAMQP examples.
+# TODO: Build and re-introduce Thrift runtime dependencies.
+
+post-install:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Note: Thrift is not yet supported, Python bindings need fixed."
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>