aboutsummaryrefslogtreecommitdiff
path: root/net/py-txamqp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-08-22 16:41:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-08-22 16:41:09 +0000
commit3a2328b88340fdbd342ffdaf6a1876e1c0b75a08 (patch)
treec645c1e0994dcd209db75d47acd5f4e6efe53411 /net/py-txamqp
parent786a782517018ac440fd2bfe5f6f64dd9316033e (diff)
downloadports-3a2328b88340fdbd342ffdaf6a1876e1c0b75a08.tar.gz
ports-3a2328b88340fdbd342ffdaf6a1876e1c0b75a08.zip
Modernize port
- Sort USE_PYTHON - Remove no-op PLIST_SUB - Remove post-patch: - Regenerate patch file with makepatch: - Pass maintainership to python@
Notes
Notes: svn path=/head/; revision=448560
Diffstat (limited to 'net/py-txamqp')
-rw-r--r--net/py-txamqp/Makefile12
-rw-r--r--net/py-txamqp/files/patch-src__txamqp__codec.py10
2 files changed, 8 insertions, 14 deletions
diff --git a/net/py-txamqp/Makefile b/net/py-txamqp/Makefile
index 37380fbdc50d..bee276366c5d 100644
--- a/net/py-txamqp/Makefile
+++ b/net/py-txamqp/Makefile
@@ -10,24 +10,18 @@ MASTER_SITES= http://launchpadlibrarian.net/30388120/ \
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= python-${PORTNAME}_${PORTVERSION}.orig
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT= Twisted Python library for the AMQP messaging protocol
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}thrift>0:devel/py-thrift \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}thrift>=0:devel/py-thrift \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted
NO_ARCH= yes
USES= python:2
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
WRKSRC= ${WRKDIR}/python-${PORTNAME}-${PORTVERSION}
-PLIST_SUB= PORTNAME="${PORTNAME}"
-
# TODO: Install txAMQP examples.
-# Don't try to install Twisted yourself, txAMQP. thx!
-post-patch:
- @${REINPLACE_CMD} -e '/install_requires/s/^/#/' ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/net/py-txamqp/files/patch-src__txamqp__codec.py b/net/py-txamqp/files/patch-src__txamqp__codec.py
index 33692abea963..2281a0162437 100644
--- a/net/py-txamqp/files/patch-src__txamqp__codec.py
+++ b/net/py-txamqp/files/patch-src__txamqp__codec.py
@@ -1,6 +1,6 @@
---- ./src/txamqp/codec.py.orig 2009-08-16 19:25:45.000000000 +0800
-+++ ./src/txamqp/codec.py 2013-05-30 13:54:50.000000000 +0800
-@@ -25,12 +25,12 @@
+--- src/txamqp/codec.py.orig 2009-08-16 11:25:45 UTC
++++ src/txamqp/codec.py
+@@ -25,12 +25,12 @@ fields.
"""
from cStringIO import StringIO
@@ -15,7 +15,7 @@
def __init__(self, stream):
self.stream = stream
-@@ -153,6 +153,13 @@
+@@ -153,6 +153,13 @@ class Codec:
def decode_longstr(self):
return self.dec_str("!L")
@@ -29,7 +29,7 @@
# table
def encode_table(self, tbl):
enc = StringIO()
-@@ -180,6 +187,10 @@
+@@ -180,6 +187,10 @@ class Codec:
value = self.decode_longstr()
elif type == "I":
value = self.decode_long()