aboutsummaryrefslogtreecommitdiff
path: root/net/py-urllib3
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /net/py-urllib3
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Notes
Diffstat (limited to 'net/py-urllib3')
-rw-r--r--net/py-urllib3/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/net/py-urllib3/Makefile b/net/py-urllib3/Makefile
index 8c02e4dc8bb8..7da693e1fb6e 100644
--- a/net/py-urllib3/Makefile
+++ b/net/py-urllib3/Makefile
@@ -13,16 +13,16 @@ COMMENT= HTTP library with thread-safe connection pooling, file post, and more
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography \
- ${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py-idna \
- ${PYTHON_PKGNAMEPREFIX}openssl>=16.0:security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}pysocks>=1.5.7:net/py-pysocks
-TEST_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock \
- ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose \
- ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest
-#TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=0:www/py-tornado
-
-USES?= python
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py-idna@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=16.0:security/py-openssl@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pysocks>=1.5.7:net/py-pysocks@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${FLAVOR}
+#TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=0:www/py-tornado@${FLAVOR}
+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
SUB_FILES= pkg-message
@@ -30,13 +30,11 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ipaddress>=0:net/py-ipaddress
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ipaddress>=0:net/py-ipaddress@${FLAVOR}
.endif
-.if ${PYTHON_REL} < 3300
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi
-.elif ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py3-certifi
+.if ${PYTHON_REL} < 3400
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${FLAVOR}
.endif
.include <bsd.port.post.mk>