aboutsummaryrefslogtreecommitdiff
path: root/net/qt4-network
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-12-02 19:47:17 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-12-02 19:47:17 +0000
commit43a46c6993b270c965c21db4fac822d938ec1475 (patch)
treeaf45a12b238a5ed25cadc0e0fb5a4984cacebafc /net/qt4-network
parentde0eaeceeccc6bcf986371e4c3367b326eac64a6 (diff)
downloadports-43a46c6993b270c965c21db4fac822d938ec1475.tar.gz
ports-43a46c6993b270c965c21db4fac822d938ec1475.zip
Notes
Diffstat (limited to 'net/qt4-network')
-rw-r--r--net/qt4-network/Makefile6
-rw-r--r--net/qt4-network/files/patch-src__network__ssl__qsslsocket_openssl.cpp10
-rw-r--r--net/qt4-network/pkg-plist9
3 files changed, 24 insertions, 1 deletions
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index baf7bb802238..083e3bad88f9 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -7,13 +7,15 @@
#
PORTNAME= network
-PORTVERSION= ${QT4_VERSION}
+DISTVERSION= ${QT4_VERSION}
CATEGORIES?= net ipv6
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt network library
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build rcc_build corelib
QT_NONSTANDARD= yes
@@ -60,5 +62,7 @@ post-configure:
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/lib/pkgconfig/QtNetwork.pc
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/src/network/ssl/qsslsocket_openssl.cpp
.include <bsd.port.mk>
diff --git a/net/qt4-network/files/patch-src__network__ssl__qsslsocket_openssl.cpp b/net/qt4-network/files/patch-src__network__ssl__qsslsocket_openssl.cpp
new file mode 100644
index 000000000000..a387b3ed2be2
--- /dev/null
+++ b/net/qt4-network/files/patch-src__network__ssl__qsslsocket_openssl.cpp
@@ -0,0 +1,10 @@
+--- ./src/network/ssl/qsslsocket_openssl.cpp.orig 2010-11-06 04:55:18.000000000 +0300
++++ ./src/network/ssl/qsslsocket_openssl.cpp 2010-11-12 00:05:19.726416792 +0300
+@@ -777,6 +777,7 @@
+ systemCerts.append(QSslCertificate::fromPath(QLatin1String("/opt/openssl/certs/*.pem"), QSsl::Pem, QRegExp::Wildcard)); // HP-UX
+ systemCerts.append(QSslCertificate::fromPath(QLatin1String("/etc/ssl/certs/*.pem"), QSsl::Pem, QRegExp::Wildcard)); // (K)ubuntu, OpenSUSE, Mandriva, ...
+ systemCerts.append(QSslCertificate::fromPath(QLatin1String("/etc/pki/tls/certs/ca-bundle.crt"), QSsl::Pem)); // Fedora
++ systemCerts.append(QSslCertificate::fromPath(QLatin1String("/usr/local/share/certs/ca-root-nss.crt"), QSsl::Pem)); // FreeBSD's ca_root_nss
+ systemCerts.append(QSslCertificate::fromPath(QLatin1String("/usr/lib/ssl/certs/*.pem"), QSsl::Pem, QRegExp::Wildcard)); // Gentoo, Mandrake
+ systemCerts.append(QSslCertificate::fromPath(QLatin1String("/usr/share/ssl/*.pem"), QSsl::Pem, QRegExp::Wildcard)); // Centos, Redhat, SuSE
+ systemCerts.append(QSslCertificate::fromPath(QLatin1String("/usr/local/ssl/*.pem"), QSsl::Pem, QRegExp::Wildcard)); // Normal OpenSSL Tarball
diff --git a/net/qt4-network/pkg-plist b/net/qt4-network/pkg-plist
index e077ccfdacc8..3aa7db5b336e 100644
--- a/net/qt4-network/pkg-plist
+++ b/net/qt4-network/pkg-plist
@@ -9,6 +9,8 @@ include/qt4/Qt/qhttp.h
include/qt4/Qt/qlocalserver.h
include/qt4/Qt/qlocalsocket.h
include/qt4/Qt/qnetworkaccessmanager.h
+include/qt4/Qt/qnetworkconfigmanager.h
+include/qt4/Qt/qnetworkconfiguration.h
include/qt4/Qt/qnetworkcookie.h
include/qt4/Qt/qnetworkcookiejar.h
include/qt4/Qt/qnetworkdiskcache.h
@@ -16,6 +18,7 @@ include/qt4/Qt/qnetworkinterface.h
include/qt4/Qt/qnetworkproxy.h
include/qt4/Qt/qnetworkreply.h
include/qt4/Qt/qnetworkrequest.h
+include/qt4/Qt/qnetworksession.h
include/qt4/Qt/qssl.h
include/qt4/Qt/qsslcertificate.h
include/qt4/Qt/qsslcipher.h
@@ -43,6 +46,8 @@ include/qt4/QtNetwork/QLocalSocket
include/qt4/QtNetwork/QNetworkAccessManager
include/qt4/QtNetwork/QNetworkAddressEntry
include/qt4/QtNetwork/QNetworkCacheMetaData
+include/qt4/QtNetwork/QNetworkConfiguration
+include/qt4/QtNetwork/QNetworkConfigurationManager
include/qt4/QtNetwork/QNetworkCookie
include/qt4/QtNetwork/QNetworkCookieJar
include/qt4/QtNetwork/QNetworkDiskCache
@@ -52,6 +57,7 @@ include/qt4/QtNetwork/QNetworkProxyFactory
include/qt4/QtNetwork/QNetworkProxyQuery
include/qt4/QtNetwork/QNetworkReply
include/qt4/QtNetwork/QNetworkRequest
+include/qt4/QtNetwork/QNetworkSession
include/qt4/QtNetwork/QSsl
include/qt4/QtNetwork/QSslCertificate
include/qt4/QtNetwork/QSslCipher
@@ -75,6 +81,8 @@ include/qt4/QtNetwork/qhttp.h
include/qt4/QtNetwork/qlocalserver.h
include/qt4/QtNetwork/qlocalsocket.h
include/qt4/QtNetwork/qnetworkaccessmanager.h
+include/qt4/QtNetwork/qnetworkconfigmanager.h
+include/qt4/QtNetwork/qnetworkconfiguration.h
include/qt4/QtNetwork/qnetworkcookie.h
include/qt4/QtNetwork/qnetworkcookiejar.h
include/qt4/QtNetwork/qnetworkdiskcache.h
@@ -82,6 +90,7 @@ include/qt4/QtNetwork/qnetworkinterface.h
include/qt4/QtNetwork/qnetworkproxy.h
include/qt4/QtNetwork/qnetworkreply.h
include/qt4/QtNetwork/qnetworkrequest.h
+include/qt4/QtNetwork/qnetworksession.h
include/qt4/QtNetwork/qssl.h
include/qt4/QtNetwork/qsslcertificate.h
include/qt4/QtNetwork/qsslcipher.h