aboutsummaryrefslogtreecommitdiff
path: root/net/quagga
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2011-01-14 16:14:07 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2011-01-14 16:14:07 +0000
commitcf3754b692362d23985c60e8dabde04af4f9077d (patch)
tree46167b4ac64ffa9850b0060397a9d1a37532bcb8 /net/quagga
parented4913c17ee266af8e785878b321e4e8c95b899f (diff)
downloadports-cf3754b692362d23985c60e8dabde04af4f9077d.tar.gz
ports-cf3754b692362d23985c60e8dabde04af4f9077d.zip
Notes
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/patch-git-220
-rw-r--r--net/quagga/files/patch-git-340
-rw-r--r--net/quagga/files/patch-git-417
4 files changed, 78 insertions, 1 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 0d2d8fd98045..e98bb55d5d75 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.17
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/patch-git-2 b/net/quagga/files/patch-git-2
new file mode 100644
index 000000000000..84c7d6feb0ab
--- /dev/null
+++ b/net/quagga/files/patch-git-2
@@ -0,0 +1,20 @@
+diff --git a/lib/zclient.c b/lib/zclient.c
+index d3d5322..52a3627 100644
+--- lib/zclient.c
++++ lib/zclient.c
+@@ -339,12 +339,12 @@ zclient_start (struct zclient *zclient)
+ /* Create read thread. */
+ zclient_event (ZCLIENT_READ, zclient);
+
+- /* We need interface information. */
+- zebra_message_send (zclient, ZEBRA_INTERFACE_ADD);
+-
+ /* We need router-id information. */
+ zebra_message_send (zclient, ZEBRA_ROUTER_ID_ADD);
+
++ /* We need interface information. */
++ zebra_message_send (zclient, ZEBRA_INTERFACE_ADD);
++
+ /* Flush all redistribute request. */
+ for (i = 0; i < ZEBRA_ROUTE_MAX; i++)
+ if (i != zclient->redist_default && zclient->redist[i])
diff --git a/net/quagga/files/patch-git-3 b/net/quagga/files/patch-git-3
new file mode 100644
index 000000000000..c21eb750acf8
--- /dev/null
+++ b/net/quagga/files/patch-git-3
@@ -0,0 +1,40 @@
+diff --git a/ospf6d/ospf6_spf.c b/ospf6d/ospf6_spf.c
+index bfb6df2..04367f0 100644
+--- ospf6d/ospf6_spf.c
++++ ospf6d/ospf6_spf.c
+@@ -50,7 +50,9 @@ ospf6_vertex_cmp (void *a, void *b)
+ struct ospf6_vertex *vb = (struct ospf6_vertex *) b;
+
+ /* ascending order */
+- return (va->cost - vb->cost);
++ if (va->cost != vb->cost)
++ return (va->cost - vb->cost);
++ return (va->hops - vb->hops);
+ }
+
+ static int
+@@ -320,22 +322,8 @@ ospf6_spf_install (struct ospf6_vertex *v,
+ }
+
+ prev = (struct ospf6_vertex *) route->route_option;
+- if (prev->hops > v->hops)
+- {
+- for (ALL_LIST_ELEMENTS (prev->child_list, node, nnode, w))
+- {
+- assert (w->parent == prev);
+- w->parent = v;
+- listnode_add_sort (v->child_list, w);
+- }
+- listnode_delete (prev->parent->child_list, prev);
+- listnode_add_sort (v->parent->child_list, v);
+-
+- ospf6_vertex_delete (prev);
+- route->route_option = v;
+- }
+- else
+- ospf6_vertex_delete (v);
++ assert (prev->hops <= v->hops);
++ ospf6_vertex_delete (v);
+
+ return -1;
+ }
diff --git a/net/quagga/files/patch-git-4 b/net/quagga/files/patch-git-4
new file mode 100644
index 000000000000..bbf3607ee0a8
--- /dev/null
+++ b/net/quagga/files/patch-git-4
@@ -0,0 +1,17 @@
+diff --git a/bgpd/bgp_packet.c b/bgpd/bgp_packet.c
+index a5f9552..9102add 100644
+--- bgpd/bgp_packet.c
++++ bgpd/bgp_packet.c
+@@ -1885,12 +1885,6 @@ bgp_notify_receive (struct peer *peer, bgp_size_t size)
+ bgp_notify.subcode == BGP_NOTIFY_OPEN_UNSUP_PARAM )
+ UNSET_FLAG (peer->sflags, PEER_STATUS_CAPABILITY_OPEN);
+
+- /* Also apply to Unsupported Capability until remote router support
+- capability. */
+- if (bgp_notify.code == BGP_NOTIFY_OPEN_ERR &&
+- bgp_notify.subcode == BGP_NOTIFY_OPEN_UNSUP_CAPBL)
+- UNSET_FLAG (peer->sflags, PEER_STATUS_CAPABILITY_OPEN);
+-
+ BGP_EVENT_ADD (peer, Receive_NOTIFICATION_message);
+ }
+