aboutsummaryrefslogtreecommitdiff
path: root/net/quagga
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-01-08 12:47:04 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-01-08 12:47:04 +0000
commitd91ad918ab4d3d3ad2f564205c45c1f4e0792325 (patch)
tree3e838b0eeb744cb27bf4baacabd86f7a65a66b26 /net/quagga
parent18e3c0adae41e6f5f1c8a8156f503f3be414775b (diff)
downloadports-d91ad918ab4d3d3ad2f564205c45c1f4e0792325.tar.gz
ports-d91ad918ab4d3d3ad2f564205c45c1f4e0792325.zip
net/quagga: fix EXAMPLES option
PR: 234738 Submitted by: tobik
Notes
Notes: svn path=/head/; revision=489676
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile10
-rw-r--r--net/quagga/pkg-plist20
2 files changed, 15 insertions, 15 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 270ee9ebf02e..dbf9537a7cba 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quagga
PORTVERSION= 1.2.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net ipv6
MASTER_SITES= SAVANNAH
@@ -20,7 +20,6 @@ CONFLICTS= frr3 frr4 frr5 frr6 openbgpd pimd zebra
USES= compiler:c11 cpe gmake libtool makeinfo \
perl5 readline ssl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-exampledir=${PREFIX}/share/examples/quagga
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USE_PERL5= build
@@ -64,6 +63,9 @@ CONFIGURE_ARGS= --enable-user=${ENABLE_USER} \
CONFIGURE_ARGS+=--enable-vty-group=${ENABLE_VTY_GROUP}
.endif
+EXAMPLES_CONFIGURE_ON= --enable-exampledir=${PREFIX}/share/examples/quagga
+EXAMPLES_CONFIGURE_OFF= --disable-exampledir
+
ISISD_CONFIGURE_ENABLE= isisd
ISIS_TOPOLOGY_CONFIGURE_ENABLE= isis-topology
PIMD_CONFIGURE_ENABLE= pimd
@@ -102,8 +104,6 @@ pre-everything::
@${ECHO} "LOCALSTATE_DIR Specify directory for Quagga runtime files"
post-install:
- ${MKDIR} ${STAGEDIR}${LOCALSTATE_DIR} ${STAGEDIR}${SYSCONF_DIR} \
- ${STAGEDIR}${EXAMPLESDIR}
- @${MV} ${STAGEDIR}${SYSCONF_DIR}/* ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${LOCALSTATE_DIR} ${STAGEDIR}${SYSCONF_DIR}
.include <bsd.port.mk>
diff --git a/net/quagga/pkg-plist b/net/quagga/pkg-plist
index bec6e377a2a3..c25931a835d9 100644
--- a/net/quagga/pkg-plist
+++ b/net/quagga/pkg-plist
@@ -95,15 +95,15 @@ sbin/ripd
sbin/ripngd
sbin/watchquagga
sbin/zebra
-%%EXAMPLESDIR%%/bgpd.conf.sample
-%%EXAMPLESDIR%%/bgpd.conf.sample2
-%%ISISD%%%%EXAMPLESDIR%%/isisd.conf.sample
-%%EXAMPLESDIR%%/ospf6d.conf.sample
-%%EXAMPLESDIR%%/ospfd.conf.sample
-%%PIMD%%%%EXAMPLESDIR%%/pimd.conf.sample
-%%EXAMPLESDIR%%/ripd.conf.sample
-%%EXAMPLESDIR%%/ripngd.conf.sample
-%%EXAMPLESDIR%%/vtysh.conf.sample
-%%EXAMPLESDIR%%/zebra.conf.sample
+%%EXAMPLES%%%%EXAMPLESDIR%%/bgpd.conf.sample
+%%EXAMPLES%%%%EXAMPLESDIR%%/bgpd.conf.sample2
+%%EXAMPLES%%%%ISISD%%%%EXAMPLESDIR%%/isisd.conf.sample
+%%EXAMPLES%%%%EXAMPLESDIR%%/ospf6d.conf.sample
+%%EXAMPLES%%%%EXAMPLESDIR%%/ospfd.conf.sample
+%%EXAMPLES%%%%PIMD%%%%EXAMPLESDIR%%/pimd.conf.sample
+%%EXAMPLES%%%%EXAMPLESDIR%%/ripd.conf.sample
+%%EXAMPLES%%%%EXAMPLESDIR%%/ripngd.conf.sample
+%%EXAMPLES%%%%EXAMPLESDIR%%/vtysh.conf.sample
+%%EXAMPLES%%%%EXAMPLESDIR%%/zebra.conf.sample
@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%LOCALSTATE_DIR%%
@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%SYSCONF_DIR%%