aboutsummaryrefslogtreecommitdiff
path: root/net/rdesktop
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2008-05-21 06:44:36 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2008-05-21 06:44:36 +0000
commitadd734a62b4f88d56dbc7cce5cfad362602bc377 (patch)
tree94c3bc96b505d6ec409539f738268884a6f450fa /net/rdesktop
parente54edb727e15cc034572fab182730582b37a1744 (diff)
downloadports-add734a62b4f88d56dbc7cce5cfad362602bc377.tar.gz
ports-add734a62b4f88d56dbc7cce5cfad362602bc377.zip
Add a debugging knob (WITH_RDESKTOP_DEBUG) to help folks figure out any
problems they may have. [parts derived from the PR] PR: 123720 Submitted-by: Alexander Logvinov <ports@logvinov.com>
Notes
Notes: svn path=/head/; revision=213446
Diffstat (limited to 'net/rdesktop')
-rw-r--r--net/rdesktop/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 5be8cf1cfbc7..9c272c1a5f5c 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -22,10 +22,23 @@ GNU_CONFIGURE= yes
DOCS= doc/AUTHORS doc/TODO doc/*.txt
MAN1= rdesktop.1
-.if !defined(WITHOUT_IPV6)
+.if !defined(WITHOUT_RDESKTOP_IPV6) && !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --with-ipv6
.endif
+.if defined(WITH_RDESKTOP_DEBUG)
+CONFIGURE_ARGS+= --with-debug\
+ --with-debug-kbd\
+ --with-debug-rdp5\
+ --with-debug-clipboard\
+ --with-debug-sound\
+ --with-debug-channel\
+ --with-debug-seamless
+
+post-configure:
+ ${ECHO} "#define WITH_DEBUG_SERIAL 1" >> ${WRKSRC}/rdesktop.h
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rdesktop ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/rdesktop.1 ${MAN1PREFIX}/man/man1