aboutsummaryrefslogtreecommitdiff
path: root/net/read_bbrlog
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2020-08-03 20:40:06 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2020-08-03 20:40:06 +0000
commitc58f43938c6a44f4ecca02c2edd78bb08a1780b3 (patch)
tree1787357640f021c1495ada84c9051014ab2731c6 /net/read_bbrlog
parent9b38ef5198eafb87d76b483aee2e4e26e98222e9 (diff)
downloadports-c58f43938c6a44f4ecca02c2edd78bb08a1780b3.tar.gz
ports-c58f43938c6a44f4ecca02c2edd78bb08a1780b3.zip
New port: net/read_bbrlog
Decode BBR log dumps generated with tcplog_dumper. Sponsored by: Netflix
Notes
Notes: svn path=/head/; revision=544108
Diffstat (limited to 'net/read_bbrlog')
-rw-r--r--net/read_bbrlog/Makefile38
-rw-r--r--net/read_bbrlog/distinfo3
-rw-r--r--net/read_bbrlog/pkg-descr4
3 files changed, 45 insertions, 0 deletions
diff --git a/net/read_bbrlog/Makefile b/net/read_bbrlog/Makefile
new file mode 100644
index 000000000000..5defbebbada0
--- /dev/null
+++ b/net/read_bbrlog/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= read_bbrlog
+PORTVERSION= 0.1.1
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+
+MAINTAINER= olivier@FreeBSD.org
+COMMENT= Decode BBR log dumps generated with tcplog_dumper
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+
+BUILD_DEPENDS= ${PREFIX}/include/bbparse.h:devel/bbparse
+
+USE_GITHUB= yes
+GH_ACCOUNT= Netflix
+
+PLIST_FILES= bin/read_bbrlog \
+ man/man1/read_bbrlog.1.gz
+
+CFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300076
+IGNORE= builds only on FreeBSD 13-head with minimum revision 356414
+.endif
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/read_bbrlog ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/read_bbrlog.1.gz ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/read_bbrlog/distinfo b/net/read_bbrlog/distinfo
new file mode 100644
index 000000000000..012e8df8d0a6
--- /dev/null
+++ b/net/read_bbrlog/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1596381036
+SHA256 (Netflix-read_bbrlog-v0.1.1_GH0.tar.gz) = aad8ddc00098fa9f4464148b128dda115279cdf30c0efa4f3169a56ceaae1936
+SIZE (Netflix-read_bbrlog-v0.1.1_GH0.tar.gz) = 45003
diff --git a/net/read_bbrlog/pkg-descr b/net/read_bbrlog/pkg-descr
new file mode 100644
index 000000000000..7d3c0346e115
--- /dev/null
+++ b/net/read_bbrlog/pkg-descr
@@ -0,0 +1,4 @@
+The read_bbrlog is a utility that knows how to read the pcapng[.xz] files
+created by the net/tcplog_dumper from BBR.
+
+WWW: https://github.com/Netflix/read_bbrlog