aboutsummaryrefslogtreecommitdiff
path: root/net/remmina
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-19 14:00:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-19 14:00:08 +0000
commit3df6bfa470416ddb50c93f7bae6e3241fa204c1f (patch)
tree743ec4158c73820e50c90400da29e48c6e138c7b /net/remmina
parent6f77308f24c1270ac73dd5a805c09f931a9f3480 (diff)
downloadports-3df6bfa470416ddb50c93f7bae6e3241fa204c1f.tar.gz
ports-3df6bfa470416ddb50c93f7bae6e3241fa204c1f.zip
- Remove desktop-file-utils (only needed if .desktop files contain
mime-type info) - Remove UNIQUE option (no reference to it in the code) - Remove post-install that displays pkg-message
Notes
Notes: svn path=/head/; revision=368562
Diffstat (limited to 'net/remmina')
-rw-r--r--net/remmina/Makefile18
-rw-r--r--net/remmina/pkg-plist2
2 files changed, 4 insertions, 16 deletions
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index d575354c9675..487986c59719 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -3,7 +3,7 @@
PORTNAME= remmina
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net gnome
MAINTAINER= fluffy@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= The GTK+ Remote Desktop Client
LICENSE= GPLv2
-USES= cmake desktop-file-utils gmake pkgconfig
+USES= cmake gmake pkgconfig
USE_GNOME= atk gdkpixbuf2 glib20 gtk20 pango
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -Wl,-rpath -Wl,${LOCALBASE}/lib -lX11 \
@@ -26,13 +26,12 @@ GH_COMMIT= 356c033
GH_TAGNAME= ${PORTVERSION}
WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-Remmina-${GH_COMMIT}
-OPTIONS_DEFINE= SSH GCRYPT TERM AVAHI UNIQUE NLS
-OPTIONS_DEFAULT= SSH GCRYPT TERM AVAHI UNIQUE NLS
+OPTIONS_DEFINE= SSH GCRYPT TERM AVAHI NLS
+OPTIONS_DEFAULT= SSH GCRYPT TERM AVAHI NLS
SSH_DESC= Build with SSH tunneling support
GCRYPT_DESC= Build with libgcrypt support for password encryption
TERM_DESC= Build with terminal support
AVAHI_DESC= Build with Avahi support
-UNIQUE_DESC= Build with Unique-App support
.include <bsd.port.options.mk>
@@ -75,12 +74,6 @@ LIB_DEPENDS+= libavahi-ui.so:${PORTSDIR}/net/avahi-gtk
CMAKE_ARGS+= -DWITH_AVAHI=OFF
.endif
-.if ${PORT_OPTIONS:MUNIQUE}
-LIB_DEPENDS+= libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
-.else
-CMAKE_ARGS+= -DWITH_UNIQUE=OFF
-.endif
-
post-patch:
# fix pkgconfig
${REINPLACE_CMD} -e 's,$${CMAKE_INSTALL_LIBDIR}/pkgconfig,libdata/pkgconfig,' ${WRKSRC}/remmina/CMakeLists.txt
@@ -92,7 +85,4 @@ post-patch:
${REINPLACE_CMD} -e's|add_subdirectory(po)||' ${WRKSRC}/remmina/CMakeLists.txt
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/net/remmina/pkg-plist b/net/remmina/pkg-plist
index 73d6c345806f..413386ae0adf 100644
--- a/net/remmina/pkg-plist
+++ b/net/remmina/pkg-plist
@@ -44,6 +44,4 @@ share/icons/hicolor/scalable/apps/remmina.svg
%%NLS%%share/locale/tr/LC_MESSAGES/remmina.mo
%%NLS%%share/locale/uk/LC_MESSAGES/remmina.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/remmina.mo
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry include/remmina