aboutsummaryrefslogtreecommitdiff
path: root/net/remmina
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-11-23 15:47:53 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-11-23 15:47:53 +0000
commit8d33b9af06f349d1a07a9f7e867ca1dd475b694e (patch)
treead6c30c8d5862b879e099549e6d0a21060501273 /net/remmina
parent0974bef9670a5ea8a728531abdcc6e326d1103c4 (diff)
downloadports-8d33b9af06f349d1a07a9f7e867ca1dd475b694e.tar.gz
ports-8d33b9af06f349d1a07a9f7e867ca1dd475b694e.zip
net/remmina: Add USES=gettext localbase:ldflags
- bin/remmina links to lib/libintl.so.8 regardless of NLS option Note: that NLS option still prevents translations from being installed - cmake needs to search for gettext within localbase net/remmina-plugin-*: Add USES=localbase:ldflags - The plugins need to search localbase/include for headers, and some also link with libraries in localbase Reported by: marino Approved by: adamw (mentor, implicit)
Notes
Notes: svn path=/head/; revision=426940
Diffstat (limited to 'net/remmina')
-rw-r--r--net/remmina/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index 3bcdac8499e2..24bb3ed62d47 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -16,7 +16,7 @@ USE_GITHUB= yes
GH_ACCOUNT= FreeRDP
GH_PROJECT= Remmina
-USES= cmake:outsource gmake pathfix pkgconfig
+USES= cmake:outsource gettext gmake localbase:ldflags pathfix pkgconfig
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
USE_XORG= ice sm x11 xext
PATHFIX_WRKSRC= ${WRKSRC}/remmina
@@ -41,8 +41,7 @@ AVAHI_CMAKE_BOOL= WITH_AVAHI
GCRYPT_LIB_DEPENDS= libgcrypt.so:security/libgcrypt
GCRYPT_CMAKE_BOOL= WITH_GCRYPT
-NLS_USES= gettext localbase
-NLS_CMAKE_BOOL= WITH_GETTEXT
+NLS_CMAKE_BOOL= WITH_TRANSLATIONS
SSH_LIB_DEPENDS= libssh_threads.so:security/libssh
SSH_LDFLAGS= -fstack-protector
@@ -66,7 +65,5 @@ post-patch:
${REINPLACE_CMD} -e's|add_subdirectory(remmina-plugins)||' ${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e's|add_subdirectory(remmina-plugins-gnome)||' ${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e's|add_subdirectory(external_tools)||' ${WRKSRC}/remmina/CMakeLists.txt
-post-patch-NLS-off:
- ${REINPLACE_CMD} -e's|add_subdirectory(po)||' ${WRKSRC}/remmina/CMakeLists.txt
.include <bsd.port.post.mk>