aboutsummaryrefslogtreecommitdiff
path: root/net/rtpproxy/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2008-06-17 05:52:53 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2008-06-17 05:52:53 +0000
commit02cff2632a35b9031da98c7ab097832fc07f44da (patch)
tree19ae0855f3d39415947fd64978b7bc3f8f5f7144 /net/rtpproxy/Makefile
parentdea0c173edc96b42ada24373a3dcfe356beaed35 (diff)
downloadports-02cff2632a35b9031da98c7ab097832fc07f44da.tar.gz
ports-02cff2632a35b9031da98c7ab097832fc07f44da.zip
Notes
Diffstat (limited to 'net/rtpproxy/Makefile')
-rw-r--r--net/rtpproxy/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/rtpproxy/Makefile b/net/rtpproxy/Makefile
new file mode 100644
index 000000000000..3d034b256d8d
--- /dev/null
+++ b/net/rtpproxy/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: rtpproxy
+# Date created: 20 April 2005
+# Whom: sobomax@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtpproxy
+PORTVERSION= 1.1
+CATEGORIES= net
+MASTER_SITES= http://www.rtpproxy.org/chrome/site/
+
+MAINTAINER= sobomax@FreeBSD.org
+COMMENT= A high-performance RTP proxy server for the SIP Express Router (SER)
+
+LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
+#CONFIGURE_ARGS= --mandir=${LOCALBASE}/man
+MAN8= rtpproxy.8
+
+post-build:
+ ${SED} 's|%%PREFIX%%|${PREFIX}|g ; s|%%RC_SUBR%%|/etc/rc.subr|g' \
+ ${WRKSRC}/freebsd/rtpproxy.in > ${WRKDIR}/rtpproxy
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/rtpproxy ${PREFIX}/etc/rc.d/rtpproxy
+
+.include <bsd.port.mk>