aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-amqp-utils
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-08-06 17:05:18 +0000
committerSteve Wills <swills@FreeBSD.org>2011-08-06 17:05:18 +0000
commit7d0ae458df413e4806b63bbd7c0ef5280725ca31 (patch)
tree33adb54dfecb4957675a8fe3294221f8771ea367 /net/rubygem-amqp-utils
parent2b99c12181af69ec088b2434e6746602930e54e1 (diff)
downloadports-7d0ae458df413e4806b63bbd7c0ef5280725ca31.tar.gz
ports-7d0ae458df413e4806b63bbd7c0ef5280725ca31.zip
Command line utilies for interacting with AMQP compliant queues.
The intention is provide simple management tools that can be used to complete ad hoc housework on an AMQP queue. In addition, simple scripts can be layered over the tools when needed. WWW: http://rubygems.org/gems/amqp-utils PR: ports/158816 Submitted by: Loic Pefferkorn <loic-freebsd at loicp.eu>
Notes
Notes: svn path=/head/; revision=279043
Diffstat (limited to 'net/rubygem-amqp-utils')
-rw-r--r--net/rubygem-amqp-utils/Makefile30
-rw-r--r--net/rubygem-amqp-utils/distinfo2
-rw-r--r--net/rubygem-amqp-utils/pkg-descr6
3 files changed, 38 insertions, 0 deletions
diff --git a/net/rubygem-amqp-utils/Makefile b/net/rubygem-amqp-utils/Makefile
new file mode 100644
index 000000000000..43d2a6edaa7b
--- /dev/null
+++ b/net/rubygem-amqp-utils/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: rubygem-amqp-utils
+# Date created: 11 July 2011
+# Whom: Loic Pefferkorn <loic-freebsd@loicp.eu>
+#
+# $FreeBSD$
+
+PORTNAME= amqp-utils
+PORTVERSION= 0.4.3
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= loic-freebsd@loicp.eu
+COMMENT= Command line utilies for interacting with AMQP compliant queues
+
+RUN_DEPENDS= rubygem-amqp>=0.7.1:${PORTSDIR}/net/rubygem-amqp \
+ rubygem-clio>=0.3.0:${PORTSDIR}/devel/rubygem-clio \
+ rubygem-facets>=2.9.1:${PORTSDIR}/devel/rubygem-facets \
+ rubygem-heredoc_unindent>=1.1.2:${PORTSDIR}/textproc/rubygem-heredoc_unindent \
+ rubygem-json>=1.5.3:${PORTSDIR}/devel/rubygem-json \
+ rubygem-msgpack>=0.4.5:${PORTSDIR}/devel/rubygem-msgpack \
+ rubygem-trollop>=1.16.2:${PORTSDIR}/devel/rubygem-trollop
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES+= bin/amqp-deleteq bin/amqp-dequeue bin/amqp-enqueue bin/amqp-peek bin/amqp-pop \
+ bin/amqp-purge bin/amqp-spy bin/amqp-statq bin/amqp-unbind
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-amqp-utils/distinfo b/net/rubygem-amqp-utils/distinfo
new file mode 100644
index 000000000000..2f03de33c74f
--- /dev/null
+++ b/net/rubygem-amqp-utils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/amqp-utils-0.4.3.gem) = ed251b25d044c7bbd00a2bb5b43e7a760bd725215d9e20b9eaf774b8664d1231
+SIZE (rubygem/amqp-utils-0.4.3.gem) = 11264
diff --git a/net/rubygem-amqp-utils/pkg-descr b/net/rubygem-amqp-utils/pkg-descr
new file mode 100644
index 000000000000..5617bb7f7a59
--- /dev/null
+++ b/net/rubygem-amqp-utils/pkg-descr
@@ -0,0 +1,6 @@
+Command line utilies for interacting with AMQP compliant queues.
+The intention is provide simple management tools that can be used to complete
+ad hoc housework on an AMQP queue.
+In addition, simple scripts can be layered over the tools when needed.
+
+WWW: http://rubygems.org/gems/amqp-utils