aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-amqp
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-02-20 12:28:42 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-02-20 12:28:42 +0000
commitb2b76822d7747ad348ff0d7ac606cee0e97bef08 (patch)
tree225f4593c41d9c09bc4ac0cb36aead3b3d003b40 /net/rubygem-amqp
parent94236687bf63dc1276c1cd8c96bfcc134c3192f9 (diff)
downloadports-b2b76822d7747ad348ff0d7ac606cee0e97bef08.tar.gz
ports-b2b76822d7747ad348ff0d7ac606cee0e97bef08.zip
Notes
Diffstat (limited to 'net/rubygem-amqp')
-rw-r--r--net/rubygem-amqp/Makefile21
-rw-r--r--net/rubygem-amqp/distinfo2
-rw-r--r--net/rubygem-amqp/pkg-descr7
3 files changed, 30 insertions, 0 deletions
diff --git a/net/rubygem-amqp/Makefile b/net/rubygem-amqp/Makefile
new file mode 100644
index 000000000000..7aa6c8df195d
--- /dev/null
+++ b/net/rubygem-amqp/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: rubygem-amqp
+# Date created: 20 Feb 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= amqp
+PORTVERSION= 0.7.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= An implementation of the AMQP protocol for RabbitMQ clients
+
+RUN_DEPENDS= rubygem-eventmachine>=0.12.0:${PORTSDIR}/devel/rubygem-eventmachine
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-amqp/distinfo b/net/rubygem-amqp/distinfo
new file mode 100644
index 000000000000..0e4741be658f
--- /dev/null
+++ b/net/rubygem-amqp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/amqp-0.7.0.gem) = 1ea4c577741516c794165221f6c3144cef78be6b73afb912e9344311922f032b
+SIZE (rubygem/amqp-0.7.0.gem) = 90112
diff --git a/net/rubygem-amqp/pkg-descr b/net/rubygem-amqp/pkg-descr
new file mode 100644
index 000000000000..0eb35dab9e27
--- /dev/null
+++ b/net/rubygem-amqp/pkg-descr
@@ -0,0 +1,7 @@
+Simple asynchronous AMQP driver for Ruby/EventMachine.
+This library works with Ruby 1.8, Ruby 1.9, JRuby and Rubinius.
+
+This library was tested primarily with RabbitMQ, although it
+should be compatible with any server implementing the AMQP 0-8 spec.
+
+WWW: https://github.com/ruby-amqp/amqp