aboutsummaryrefslogtreecommitdiff
path: root/net/sipsak
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-18 13:35:47 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-18 13:35:47 +0000
commit3ba1a3ce974a0c6aaa281ce007c0a626fb5d143d (patch)
tree4c52d382a1cf8952877bb307716a36492c805306 /net/sipsak
parent753126c8ec13804dfd983ee4bcb865c2f10aee32 (diff)
downloadports-3ba1a3ce974a0c6aaa281ce007c0a626fb5d143d.tar.gz
ports-3ba1a3ce974a0c6aaa281ce007c0a626fb5d143d.zip
Notes
Diffstat (limited to 'net/sipsak')
-rw-r--r--net/sipsak/Makefile29
-rw-r--r--net/sipsak/distinfo1
-rw-r--r--net/sipsak/pkg-descr7
-rw-r--r--net/sipsak/pkg-plist2
4 files changed, 39 insertions, 0 deletions
diff --git a/net/sipsak/Makefile b/net/sipsak/Makefile
new file mode 100644
index 000000000000..6067c225f711
--- /dev/null
+++ b/net/sipsak/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: sipsak
+# Date created: 2003-06-30
+# Whom: jesusr
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipsak
+PORTVERSION= 0.8.1
+CATEGORIES= net
+MASTER_SITES= http://download.berlios.de/sipsak/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jesusr@FreeBSD.org
+COMMENT= Small command line tool for SIP testing
+
+MAN1= sipsak.1
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -c md5.c && \
+ ${CC} ${CFLAGS} -c sipsak.c && \
+ ${CC} ${LDFLAGS} -o sipsak md5.o sipsak.o
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sipsak ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sipsak.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/sipsak/distinfo b/net/sipsak/distinfo
new file mode 100644
index 000000000000..df808d8cf68f
--- /dev/null
+++ b/net/sipsak/distinfo
@@ -0,0 +1 @@
+MD5 (sipsak-0.8.1.tgz) = 52d7799baee1af23c0fed682a620a867
diff --git a/net/sipsak/pkg-descr b/net/sipsak/pkg-descr
new file mode 100644
index 000000000000..2d234e99d162
--- /dev/null
+++ b/net/sipsak/pkg-descr
@@ -0,0 +1,7 @@
+Sipsak is a small command line tool for developers and administrators of
+Session Initiation Protocol (SIP) applications.
+It can be used for some simple tests on SIP applications and services.
+
+WWW: http://sipsak.berlios.de/
+
+- JesusR <jesusr@freebsd.org>
diff --git a/net/sipsak/pkg-plist b/net/sipsak/pkg-plist
new file mode 100644
index 000000000000..09e55b01d417
--- /dev/null
+++ b/net/sipsak/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+bin/sipsak